1 2 Previous Next 23 Replies Latest reply on Nov 15, 2012 10:32 AM by Dennis Lovelady Go to original post
      • 15. Re: Oracle VM 3.1.1, Oracle VM Server, PeopleSoft Templates and networking
        1. I did a QUICK search of the user guide and what would you guess... I found the first mention on page 81. Just search for bond0.

        During installation of Oracle VM Server, the network interface (selected when prompted for the
        management port) is configured as a bonded interface. The bond is created with only one interface. This is
        done because the reconfiguration of the management interface on the Oracle VM Servers is not supported.

        2. No you don't have to rebuild the network. Do what you want. I just made a suggestion. I honestly believe you are lost in understand the various network definitions. Put everything on one single network until you understand the process. Just use the default bond.

        Edited by: user12273962 on Nov 9, 2012 5:25 AM
        • 16. Re: Oracle VM 3.1.1, Oracle VM Server, PeopleSoft Templates and networking
          Dennis Lovelady
          I said I don't want a war, and I'll stand by that comment. In general, only Oracle is providing Templates (or Appliances) for Oracle products. Nobody else is doing that, and it's probably because of licensing. But, my heavens, the list of available VMWare appliances is astounding. I cannot make you click on this link. . . . but if you do, I think you'll realize that bragging about the number of Oracle templates available, is like bragging about how quickly your horse can get from San Francisco to San Jose. In short, if you click there, Welcome to the real world. https://solutionexchange.vmware.com/store/category_groups/19

          Edited by: Dennis Lovelady on Nov 9, 2012 5:36 AM - Added the actual link (d'oh!)
          • 17. Re: Oracle VM 3.1.1, Oracle VM Server, PeopleSoft Templates and networking
            user12273962 wrote:
            That's because they are BIG. BIG files.. A lot of space. Funny how that works.

            How BIG is your non Oracle VM Peoplesoft deployment? Imagine "wrapping" all of it up into a "template".... I think you get the point.
            I know they are big, database is quite big, etc. I'm working a lot with those Peoplesoft templates.
            As an Oracle and Peoplesoft administrator for the last decade, I'm very much aware of what Peoplesoft is, and requires. Thanks.

            And for all the Peoplesoft templates, there's a dedicated forum PeopleSoft OVM Templates in which, if I can say, I'm participating as much as I can to help, and report issues too.


            PS: I'm sorry, did not want to disturb the discussion.
            • 18. Re: Oracle VM 3.1.1, Oracle VM Server, PeopleSoft Templates and networking
              Dennis Lovelady
              OK. In the user guide, but not in installation or getting started. And the "what does that mean" ramifications are not clearly stated. Typical, but I can live with that; it is clearly my oversight. Honest. :)

              At the risk of further straining this relationship - and I'm truly sorry to ask this, but you are the only person kind enough to hang with me on this (No good deed shall go unpunished!) - can you give me a blow-by-blow of what you believe needs to happen? (For starters, I'm not quite sure what you mean by "reinstall the VM.") I can take that literally (I hope it is this simple) to mean that I blow away the Linux 6 and VMM installation; everything else (Oracle VM Servers, Repositories, et al) can stay as-is. . . Discovery will fix everything. Or it can mean, scrap everything and start again. Or it might mean something I hadn't considered.

              A light is coming on, maybe. Can I just repurpose the eth0 network, by changing the wiring (plugging VMS eth0 into the 10.* net and changing the ifcfg-bond0 (and maybe ifcfg-eth0) file(s)? (Of course, I would then bring down eth1...) Yeah, maybe that should work. Unless I hear otherwise, I'll try that when I have next opportunity....

              But I am definitely open to other suggestsions.

              And I definitely want it clear that, in spite of disagreement about whose milkshake flavor is better, I deeply appreciate your advice.
              • 19. Re: Oracle VM 3.1.1, Oracle VM Server, PeopleSoft Templates and networking
                No problem.

                You can't change the default bond0 after installing the VM Server. Its not supported. You maybe able to change the IP address and rediscover the VM server. Not sure. Never done it. I agree that the documentation should address this sooner. It maybe in the release notes. Can't remember. Seems like it is. You can try. Wouldn't hurt. May have to rediscover the server.

                Personally, I believe your VM Manager should be on the same subnet as the default bond0 of your VM servers. Its doesn't have to be but to me.... I don't want traffic hooping to the management interface. The routing specs/bandwidth of any router or switch that is routing traffic... is much less than the layer 2 bandwidth. If you have a good router or switch. You'll be fine. I'd just rather avoid it. If your VM Manger is multhomed... then you're okay there as well as long as you have one of nics on the same subnet. Just a suggestion. Just realize that a multhomes linux server needs to have strict routing inforced. Especially if your setting multiple gateways. You want what traffic that comes in on eth0 to go back out eth0. In the same manner you want traffic that comes on eth1 to go back out eth1.

                I wouldn't blow anything away. I've never done this exactly the way I'm suggesting so take it with a "grain of salt".

                I'd delete the VM server. Reinstall the VM server to have a single bond. After installation. Rediscover the server. If you want to... configure link aggregation on Bond0 by adding a nic. Attach the VM server to your storage. Rediscover your repo. Add the new VM server to your pool. This is very high level. You will also have to migrate your VM Guest to "unassigned" virutal machines before you can delete your server. You may have to move the server out of the server pool. Not sure. Been a little while since I done this.

                If I missed anything let me know.
                • 20. Re: Oracle VM 3.1.1, Oracle VM Server, PeopleSoft Templates and networking
                  I will add.... if all you need is to load the peoplesoft templates. Then all you need is a single nic. I have the EBS r12 templates running on 6 year old servers with 8GB of ram using NFS storage. Just use the minimum spec. It'll be a little slow but it works just fine.

                  Edited by: user12273962 on Nov 9, 2012 7:25 AM
                  • 21. Re: Oracle VM 3.1.1, Oracle VM Server, PeopleSoft Templates and networking
                    Dennis Lovelady
                    Thanks for your reply. Building upon your reply, and reading between the lines, I used another solution. I installed a new, third VMS -> ora-vms3, IP This server has only one NIC (eth0) and ifconfig looks like:

                    [root@ora-vms3 ~]# ifconfig
                    bond0 Link encap:Ethernet HWaddr 00:0C:29:03:95:95
                    inet addr: Bcast: Mask:
                    UP BROADCAST RUNNING MASTER MULTICAST MTU:1500 Metric:1
                    RX packets:19390 errors:0 dropped:0 overruns:0 frame:0
                    TX packets:8978 errors:0 dropped:0 overruns:0 carrier:0
                    collisions:0 txqueuelen:0
                    RX bytes:21503911 (20.5 MiB) TX bytes:2183389 (2.0 MiB)

                    eth0 Link encap:Ethernet HWaddr 00:0C:29:03:95:95
                    UP BROADCAST RUNNING SLAVE MULTICAST MTU:1500 Metric:1
                    RX packets:19405 errors:0 dropped:0 overruns:0 frame:0
                    TX packets:8993 errors:0 dropped:0 overruns:0 carrier:0
                    collisions:0 txqueuelen:1000
                    RX bytes:21504901 (20.5 MiB) TX bytes:2185499 (2.0 MiB)

                    lo Link encap:Local Loopback
                    inet addr: Mask:
                    UP LOOPBACK RUNNING MTU:16436 Metric:1
                    RX packets:151 errors:0 dropped:0 overruns:0 frame:0
                    TX packets:151 errors:0 dropped:0 overruns:0 carrier:0
                    collisions:0 txqueuelen:0
                    RX bytes:36411 (35.5 KiB) TX bytes:36411 (35.5 KiB)

                    I did no customization to this server, except entering `hostname ora-vms3` and setting the same into /etc/sysconfig/network.

                    Discovered the server. Presented storage. Ensured the VMM network configuration (which I found was already up to date).

                    Migrated one of my Virtual Machines over to this server - all flawless to here.

                    When I try to start the virtual machine, I get:

                    Starting operation 'Virtual Machine Start' on object '0004fb0000060000fde09793c9a6d9aa (ps-hcm)'
                    Job Internal Error (Operation)com.oracle.ovm.mgr.api.exception.FailedOperationException: OVMAPI_4010E Attempt to send command: dispatch to server: ora-vms3 failed. OVMAPI_4004E Server Failed Command: dispatch https://?uname?:?pwd?@ start_vm 0004fb0000030000b6d0effde787cdfa 0004fb0000060000fde09793c9a6d9aa, Status: org.apache.xmlrpc.XmlRpcException: exceptions.RuntimeError:Command: ['xm', 'create', '/OVS/Repositories/0004fb0000030000b6d0effde787cdfa/VirtualMachines/0004fb0000060000fde09793c9a6d9aa/vm.cfg'] failed (1): stderr: Error: Device 0 (vif) could not be connected. Could not find bridge, and none was specified
                    stdout: Using config file "/OVS/Repositories/0004fb0000030000b6d0effde787cdfa/VirtualMachines/0004fb0000060000fde09793c9a6d9aa/vm.cfg".

                    Google searches told me this might mean that xend is not running, but `service xend status` shows that is running.

                    Rebooted everything and tried again, with the same result.

                    I don't know if I'm supposed to edit the vm.cfg - wasn't necessary before, though. What else might I look at?
                    • 22. Re: Oracle VM 3.1.1, Oracle VM Server, PeopleSoft Templates and networking
                      run through the setting for the virtual nic of VM guest. Sounds like the VM guest is looking for a network definition that isn't there anymore or has changed since your rebuild.
                      • 23. Re: Oracle VM 3.1.1, Oracle VM Server, PeopleSoft Templates and networking
                        Dennis Lovelady
                        Sorry I've been quiet.

                        Recall that I was not here to learn Oracle VM - and in fact had some issues with the product's nuances.

                        At your suggestion, I took a look at VirtualBox (pretty nice, and works for me). I also took a look at Jim Marion's "Converting PeopleSoft OVM Templates to VirtualBox Guests" article at http://jjmpsj.blogspot.com/2012/05/converting-peoplesoft-ovm-templates-to.html

                        ... drum roll, please ...

                        And I now have a working PeopleSoft implementation. Woo hoo!

                        Thanks for your help - sincerely. But I think I will take my leave from OracleVM for a bit, and focus on the swamp I came here to drain.
                        1 2 Previous Next