This discussion is archived
11 Replies Latest reply: Nov 13, 2012 12:09 AM by gimbal2 RSS

Applications based on JRE1.6 and JRE1.7 could not co-exist

973720 Newbie
Currently Being Moderated
Hi,

We got trouble to support multiple application GUIs on same PC, one application GUI requires JRE1.6, the other one requires JRE1.7. We have both JRE1.6 and JRE1.7 activated on PC, the one requires JRE1.7 works fine, but the JRE1.6 one failed even the develop force the jave version to JRE1.6 in it 's code.

I know there is way in "Java control Panel" to enable/disable JRE version, but it is not acceptable for this case. The customer does not like to do the manual switch everytime.

Since it is allowed to have JRE1.6 and JRE1.7, is it reasonable to allow the application to hardcode to use certain Java version, not sure why oracle does not do this:-(

Please advice,

Thanks,

Mickey

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points