3 Replies Latest reply: Nov 12, 2012 8:32 AM by satrap RSS

    ERROR   OGG-01161  Bad column index (15880) specified for table

    956456
      My GoldenGate replicat is abending due to the Bad Column Index Error.

      We recently added new column to the source/target table and even exception tables. Generated Def files and copied to target server too.


      OGG-01161 Bad column index (15880) specified for table CCI.METADOC_DOMAIN, max columns = 9.

      Any one have idea on how to troubleshoot the error.
        • 1. Re: ERROR   OGG-01161  Bad column index (15880) specified for table
          -joe
          Hi.

          You probably had data in flight (captured from the source, in trail files, but not yet applied to the target) when you made these changes on source and target. So basically you changed the target DDL while there were still transactions to be applied that were formatted for the older DDL.

          If you're not doing DDL replication and making DDL changes then you need to stop user activity on source, make sure replicat lag is zero, then stop OGG, apply DDL changes on both source and target, and then start replication. When you restart extract or replicat it will pick up the new meta data. But it's much easier to just replicate the DDL.

          If your stuck then you can flashback your target to a time before you made the new DDL changes. The OGG checkpoint table will make sure that you don't miss or repost transactions. The the tricky part will be to find the line in the trail where your new changes are coming in and stop replicat just before that. It can be done but this is a good time to call Oracle Support for details.

          In the future, if you can't stop user activity to apply the DDL, then look into setting up your own DDL trigger that populates a table which you control. Use this table to key off EVENTACTIONS to coordinate the replication stop/pause between DDL changes.

          Good luck,
          -joe
          • 2. Re: ERROR   OGG-01161  Bad column index (15880) specified for table
            user11263016
            we have the same error in our MIS GG env. today. 11/08/2012
            1 replicat process abended:
            The gglog said:
            2012-11-08 14:44:35 INFO OGG-00996 Oracle GoldenGate Delivery for Oracle, rp1p258b.prm: REPLICAT RP1P258B started.
            2012-11-08 14:44:35 ERROR OGG-01161 Oracle GoldenGate Delivery for Oracle, rp1p258b.prm: Bad column index (43) specified for table BIAPP.XTRA_CONTACT, max columns = 43.
            2012-11-08 14:44:35 ERROR OGG-01668 Oracle GoldenGate Delivery for Oracle, rp1p258b.prm: PROCESS ABENDING.

            After checked the source DB and target DB, we found this table has 46 columns on the source ( 3 new columns were added this morning), but GG did not replicat the ddl ( add 3 new columns ) to the target DB, the table on the target DB is still in 43 columns.

            question:
            --- why GG did not replicate this add coulmn ddl ?
            we have ddl extract and replicat parameter set in the prm files.
            ---- how to fix it ? manually add these 3 new columns, and restart replicat process ?

            Thanks!
            • 3. Re: ERROR   OGG-01161  Bad column index (15880) specified for table
              satrap
              Could you provide a snapshot of your extract and replicat param files?