2 Replies Latest reply on Nov 14, 2012 4:48 AM by MichaelR

    Form 10g Error : FRM 92101

      Hello all,

      I'm having the following error while trying to run my form locally from forms builder:

      RegisterWebUtil - Loading WebUtil Version
      connectMode=HTTP, native.
      Forms Applet version is :
      oracle.forms.net.ConnectionException: Forms session <9> aborted: unable to communicate with runtime process.
           at oracle.forms.net.ConnectionException.createConnectionException(Unknown Source)
           at oracle.forms.net.HTTPNStream.getResponse(Unknown Source)
           at oracle.forms.net.HTTPNStream.doFlush(Unknown Source)
           at oracle.forms.net.HTTPNStream.flush(Unknown Source)
           at java.io.DataOutputStream.flush(Unknown Source)
           at oracle.forms.net.StreamMessageWriter.run(Unknown Source)
           at java.io.DataInputStream.readUnsignedByte(Unknown Source)
           at oracle.forms.engine.Message.readDetails(Unknown Source)
           at oracle.forms.engine.Message.readDetails(Unknown Source)
           at oracle.forms.net.StreamMessageReader.run(Unknown Source)

      I've already search on all the threads available here on this forum, and i still cant solve this issue.

      I've tried solution provided in :
      1. Re: FRM-92101 error message
      2. Re: WNFI trigger raises error when form run on OAS against DB

      and much more without success.

      Please can someone help me?


      Start OC4J
      Open Forms Builder.
      Open Form.
      Compile (ctrl + Shift + k)
      Run (ctrl + R)
      get following error in oc4j screen:
      12/11/13 05:30:13 Forms session <9> aborted: unable to communicate with runtime process.

      And in the java console, i get the the first error i mentioned earlier in the post.

      Thanking you in advance


      Edited by: MichaelR on 13-Nov-2012 03:20
        • 1. Re: Form 10g Error : FRM 92101
          Michael Ferrante-Oracle
          Unfortunately, the information you provided doesn't really help. Both the error message and console output represent a symptom, after the fact. In other words, they are just telling you what you already know and are telling you "why". For example, FRM-92101 simply means that the Forms runtime (frmweb) was either unable to start or started and crashed. Basically, it is like an unhandled exception.

          What you need to do some basic troubleshooting and simplify as you go. And, when you post in this or any forum, be sure to include the details of exactly what you did and the complete versions of what you are using. For example, on what OS are you performing these tasks? Which browser and version have you tested? Which JRE and version are you using? What else have you tested and what were the results?

          I would start by testing the included test form. Does it work correctly? This is important because that will help to understand if the problem is related to the form you created or the product installation.

          So, do something like this:

          1. Close ALL open browsers.
          2. Delete the JRE (or Jinitiator) cache.
          3. Open just one browser session and enter a url something like this:
          Change the above port number to whatever is configured on your machine.

          If that works, you can assume something is wrong with your failing form, which would lead me to either create a new form from scratch or do the following:
          <blockquote>1. If your form uses WebUtil, open webutil.pll in the Builder.
          2. If you are not already connected to the db which has the WebUtil objects, connect now
          3. Execute a CTRL+SHIFT+K or use the menu to do a compile_all pl/sql
          4. Select Save from the menu or CTRL+S
          5. Generate a new plx either using CTRL+T or from the menu

          6. Now follow the same exact steps with your form.
          7. Retest. If the form does use WebUtil, ensure that your url includes config=webutil or ensure that you have added the WebUtil config info to your own section of formsweb.cfg</blockquote>
          Other things to consider:
          <blockquote>1. Forms is not supported with many of the newer browsers versions. Refer to the Client Statement of Direction for details:


          2. Java (JRE) 7 is not supported for use with Forms 10. If you have Java 7 installed, I would recommend uninstalling it at least for the sake of this testing. You should not install any version newer than 1.6.0_37
          3. If you are attempting to run directly from the Builder using the "Run Form" button, you MUST configure the Application Server URL and Browser Location fields in the Preferences on the Runtime tab.
          4. If you don't already have it, there is a WebUtil demo form on OTN. You don't necessarily need to setup the entire demo for the sake of what you are testing. So just download it and compile the FMB and run. Some functionality may not work correctly because it isn't fully setup, but the point is to see whether or not you can successfully run a WebUtil enabled form.

          1 person found this helpful
          • 2. Re: Form 10g Error : FRM 92101

            Thank you for your reply.

            Just a few additional info:

            OS : Windows 7 Professional 64 bit.

            JRE: 1.6.0_31

            I've tested on the following browsers: Chrome, IE9.

            I've just tried the test form. It works fine.

            I'll will try the other tips you mentioned in this post tonight.