This discussion is archived
5 Replies Latest reply: Nov 14, 2012 6:08 AM by 970418 RSS

Remote deployment failed (oracle.jdevimpl.deploy.common.Jsr88RemoteDeployer

970418 Newbie
Currently Being Moderated
Hi all,
I'm trying to deploy a page on a remote server but throws me the following error:


[10:00:16 AM] ---- Deployment started. ----
[10:00:16 AM] Target platform is (Weblogic 10.3).
[10:00:17 AM] Retrieving existing application information
[10:00:17 AM] Running dependency analysis...
[10:00:17 AM] Deploying 2 profiles...
[10:00:17 AM] Wrote Web Application Module to /home/hernael/.jdeveloper/system11.1.2.3.39.62.76.1/o.j2ee/drs/Libra/ViewControllerWebApp.war
[10:00:18 AM] Wrote Enterprise Application Module to /home/hernael/.jdeveloper/system11.1.2.3.39.62.76.1/o.j2ee/drs/Libra
[10:00:18 AM] Deploying Application...
[10:00:18 AM] Deployment cancelled.
[10:00:18 AM] ---- Deployment incomplete ----.
[10:00:18 AM] Remote deployment failed (oracle.jdevimpl.deploy.common.Jsr88RemoteDeployer)
#### Cannot run application Libra due to error deploying to WLSDesarrollo.
[Application Libra stopped and undeployed from Server Instance WLSDesarrollo]


it seems that not even try deploy on the server, ie, that there is something on the server that does not allow the deploy via JDeveloper.

WebLogic Server: 10.3.6.0
JDeveloper Studio Edition Version 11.1.2.3.0
  • 1. Re: Remote deployment failed (oracle.jdevimpl.deploy.common.Jsr88RemoteDeployer
    Sudipto Desmukh Expert
    Currently Being Moderated
    Is that all that shows up in the logs ?
    Did you check that the server is up and running just in case ...
  • 2. Re: Remote deployment failed (oracle.jdevimpl.deploy.common.Jsr88RemoteDeployer
    970418 Newbie
    Currently Being Moderated
    Thanks to answer me!

    Yes that's all it shows the log!
    and yes the server is running!

    between the PC and the server there is a firewall with ports 7001 and 7005 (wl console and application) only enabled, another port will be enabled?
    or should we do something special on the server?

    Edited by: 967415 on 12/11/2012 05:39
  • 3. Re: Remote deployment failed (oracle.jdevimpl.deploy.common.Jsr88RemoteDeployer
    970418 Newbie
    Currently Being Moderated
    Hi,
    please anyone who can help me:

    when:
    Application->deploy->Libra_Project1_Libra (this is default)->Deploy to Application Server->WLSDesarrollo->Deploy to selected instances in the domain (Libra)->next->finish

    then:
    Log Deployment
    [04:06:52 PM] ---- Deployment started. ----
    [04:06:52 PM] Target platform is (Weblogic 10.3).
    [04:06:53 PM] Retrieving existing application information
    [04:06:53 PM] Running dependency analysis...
    [04:06:53 PM] Building...
    [04:06:54 PM] Deploying 2 profiles...
    [04:06:55 PM] Wrote Web Application Module to /home/hernael/jdeveloper/mywork/Libra/ViewController/deploy/Libra_ViewController_webapp.war
    [04:06:55 PM] Wrote Enterprise Application Module to /home/hernael/jdeveloper/mywork/Libra/deploy/Libra_Project1_Libra.ear
    [04:06:57 PM] Redeploying Application...
    [04:06:58 PM] [Deployer:149191]Operation 'deploy' on application 'Libra_Project1_Libra' is initializing on 'Libra'
    [04:06:58 PM] [Deployer:149194]Operation 'deploy' on application 'Libra_Project1_Libra' has succeeded on 'Libra'
    [04:06:58 PM] Application Redeployed Successfully.
    [04:06:58 PM] Elapsed time for deployment: 6 seconds
    [04:06:58 PM] ---- Deployment finished. ----

    But:
    In the page untitled1.jsf:
    mouse second click->Run

    then:
    Log Remote: WLSDesarrollo
    [Running application Libra on Server Instance WLSDesarrollo...]
    [03:56:09 PM] Web Module ViewControllerWebApp.war recognized in project ViewController.jpr
    [03:56:09 PM] ---- Deployment started. ----
    [03:56:09 PM] Target platform is (Weblogic 10.3).
    [03:56:10 PM] Retrieving existing application information
    [03:56:10 PM] Running dependency analysis...
    [03:56:10 PM] Deploying 2 profiles...
    [03:56:10 PM] Wrote Web Application Module to /home/hernael/.jdeveloper/system11.1.2.3.39.62.76.1/o.j2ee/drs/Libra/ViewControllerWebApp.war
    [03:56:11 PM] Wrote Enterprise Application Module to /home/hernael/.jdeveloper/system11.1.2.3.39.62.76.1/o.j2ee/drs/Libra
    [03:56:11 PM] Deploying Application...
    #### Cannot run application Libra due to error deploying to WLSDesarrollo.
    [03:56:11 PM] Deployment cancelled.
    [03:56:11 PM] ---- Deployment incomplete ----.
    [03:56:11 PM] Remote deployment failed (oracle.jdevimpl.deploy.common.Jsr88RemoteDeployer)
    [Application Libra stopped and undeployed from Server Instance WLSDesarrollo]


    I fail to deploy an page (any) on the remote server to test development :(
  • 4. Re: Remote deployment failed (oracle.jdevimpl.deploy.common.Jsr88RemoteDeployer
    Sudipto Desmukh Expert
    Currently Being Moderated
    This beats me ...
    You already seem to have deployed your application on the server . Then , shouldnot you be directly accessing your .jsf page from the URL instead of trying to run it again ?
  • 5. Re: Remote deployment failed (oracle.jdevimpl.deploy.common.Jsr88RemoteDeployer
    970418 Newbie
    Currently Being Moderated
    Thank you very much for your response and interest Sudipto!!!

    Effectively in Application Server Navigator, deployments show: Libra_Proyect1_Libra, and there:
    Libra_Proyect1_Libra.ear->mouse second click->run
    show me:
    Running: ViewControler.jrp - log:
    The target Libra_Project1_Libra.ear cannot be started because it does not exist.

    "I do not know what this means, and do not know how to directly accessing my .jsf page" :(

    In fact in the Application Server Navigator i can undeploy Libra_Proyect1_Libra (this is ok, very fine) but then try to run the page and still gives me the same error.

    Log Remote: WLSDesarrollo
    [Running application Libra on Server Instance WLSDesarrollo...]
    [03:56:09 PM] Web Module ViewControllerWebApp.war recognized in project ViewController.jpr
    [03:56:09 PM] ---- Deployment started. ----
    [03:56:09 PM] Target platform is (Weblogic 10.3).
    [03:56:10 PM] Retrieving existing application information
    [03:56:10 PM] Running dependency analysis...
    [03:56:10 PM] Deploying 2 profiles...
    [03:56:10 PM] Wrote Web Application Module to /home/hernael/.jdeveloper/system11.1.2.3.39.62.76.1/o.j2ee/drs/Libra/ViewControllerWebApp.war
    [03:56:11 PM] Wrote Enterprise Application Module to /home/hernael/.jdeveloper/system11.1.2.3.39.62.76.1/o.j2ee/drs/Libra
    [03:56:11 PM] Deploying Application...
    #### Cannot run application Libra due to error deploying to WLSDesarrollo.
    [03:56:11 PM] Deployment cancelled.
    [03:56:11 PM] ---- Deployment incomplete ----.
    [03:56:11 PM] Remote deployment failed (oracle.jdevimpl.deploy.common.Jsr88RemoteDeployer)
    [Application Libra stopped and undeployed from Server Instance WLSDesarrollo]


    I have a headache with this (cry)

    Edited by: 967415 on 14/11/2012 06:07

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points