7 Replies Latest reply on Nov 16, 2012 8:16 PM by cheuyi

    No data in AWM viewer


      I am using Analytic Workspace Manager Version

      After updating the Workspace, when trying to view data with the Viewer, the model comes out quite fast but no data is showing.
      The Fact Table has more than 88 millions of rows.

      When using another Fact Table built on a sample of the big one, results are showing.

      How can this problem be solved ?

      Thank you very much for your help.
        • 1. Re: No data in AWM viewer
          nasar.ali-khan at -Oracle
          Are you sure that no records were rejected during your cube load? The total number of rejected records will show up in olapsys.XML_LOAD_LOG table.

          Check these three things:

          (1). Do the following type of query between your FACT table and each olap dimension to confirm that there are no "extra" dimension members (or keys) in fact table which are not present in your olap dimensions.

          select product_id
          from TABLE(OLAP_TABLE(
          *'SCHEMA.AWNAME DURATION QUERY',null,null,*
          *'DIMENSION product_id as varchar2(250) from PRODUCT'))*

          (2). Also check the number of dimension members for each dimension in the AW. Maybe one of the dimensions was not loaded properly and has less members in it.

          exec DBMS_AW.Execute('AW Attach schema.aw_name RO');
          exec DBMS_AW.Execute('SHOW OBJ(DIMMAX ''dim_name'')');  -- two single quotes
          *.... repeat for all dimensions in this AW*

          This will give you an idea, how many dimension values exist in your AW.

          (3). In the AWM cube viewer, make sure that you have selected the right dimension members.
          • 2. Re: No data in AWM viewer
            When I visualize dimensions individually in AWM, data are showing. So I guess, it means that data are loaded ?

            But when I execute : exec DBMS_AW.Execute('SHOW OBJ(DIMMAX ''dim_name'')');
            No rows are retourned. Does it mean that data are not loaded ?

            I'm a little confused as to whether data are loaded or not.

            When I compare with the example that works perfectly, dimensions, cube are all defined the same. The only difference when it worked perfectly, was that the fact table was just a few rows.

            Thank you for your help.
            • 3. Re: No data in AWM viewer
              Maintaining the cube is very slow too. Maybe I should wait until it's completely over.

              If data are not showing because the cube has not been "maintained", do you have any suggestions for improvement ?

              (i have taken all default parameters to construct dimensions and cube)

              Thank a lot...
              • 4. Re: No data in AWM viewer
                nasar.ali-khan at -Oracle
                Can you check if all the dimension members in FACT table (not olap cube) match the dimension members in olap?

                Use the query from (1) in my previous post.

                Do this kind of query between each dimension of the cube and the FACT table.

                Also, are there any rejected records in olapsys.XML_LOAD_LOG table?
                • 5. Re: No data in AWM viewer
                  The olapsys.XML_LOAD_LOG query shows only one entry that hasn't changed for a while. It doesn't update after each ''maintenance''.

                  The second part of the (1) query formats the results by concatenating with the level defined.

                  Example of results :


                  With a first part of the (1) query being :

                  MINUS will never give the expected results.

                  Is it correct to add "WITH HIERARCHY hierarchy_name FROM dimension_name" to your query 2 ?
                  • 6. Re: No data in AWM viewer
                    I managed to get results in the XML_LOAD_LOG. I couldn't see any logs because I was missing the OLAP_USER role.

                    After maintaining the cube, the log shows :
                    "Finished Load of Measures: [name_of_measure] from Cube [name_of_cube].CUBE. Processed 0 Records. Rejected 0 Records.
                    • 7. Re: No data in AWM viewer
                      The cube loading has been successful for a sample of the Fact Table.

                      Therefore, how can I measure the maximum number of rows allowed in loading data in a cube in AWM ?

                      Thank you for your help.