5 Replies Latest reply: Nov 19, 2012 11:45 AM by Sherry Lamonica-Oracle RSS

    Unable to use public-yum for R installation

    973686
      Dear experts,

      I am trying to install R-core for Oracle Enterprise Linux 5 update 6 in order to deploy a R server on it. According to the installation manual I should be using Oracle's public yum server to download and install R (http://docs.oracle.com/cd/E27988_01/doc/doc.112/e26499/install.htm#BABDFEDA).
      However following the guide, setting up yum repository and everything is working fine, when I key in "yum install R.x86_64" it returns there is no such package. I scanned the public yum folders and found no R rpms. May I know where should I get the rpms or where should I point the yum to look for the R packages?

      Thanks.

      Cheers,
      Philip
        • 1. Re: Unable to use public-yum for R installation
          Sherry Lamonica-Oracle
          The R-core RPM is located in http://public-yum.oracle.com/repo/EnterpriseLinux/EL5/addons/x86_64/.

          Go to http://public-yum.oracle.com/ and follow these steps to install R:

          Install the yum repos as follows:

          cd /etc/yum.repos.d
          wget http://public-yum.oracle.com/public-yum-el5.repo

          Open a text editor on the file just downloaded, /etc/yum.repos.d/public-yum-el5.repo, and set "enabled=1" for [ol5_u6_base] and [el5_addons].

          This step is optional.

          Type the following commands in a shell to check that your yum repository is configured correctly:

          sudo yum repolist

          The output should look like this:

          el5_addons | 951 B 00:00
          ol5_u6_base | 1.1 kB 00:00
          repo id repo name status
          base Red Hat Linux - Base enabled: 3,024
          el5_addons Enterprise Linux 5 - x86_64 - addons enabled: 93
          ol5_u6_base Oracle Linux 5 - U6 - x86_64 - base enabled: 4,551

          Make sure that both the el5_addons and ol5_u6_base repos are listed. The list of repos can be different depending on the Linux version and current user's configuration of yum.

          To install R, use the following command:

          sudo yum install R.x86_64
          • 2. Re: Unable to use public-yum for R installation
            973686
            Hi Thanks for the steps. However I followed through, wget the repo, edited el5_addons and ol5_u6_base to "enabled=1" and still the message "No package R.x86_64 available" exist.

            Repo list output
            =================================
            el5_addons | 1.2 kB 00:00
            el5_latest | 1.4 kB 00:00
            el5_latest/primary | 9.5 MB 00:38
            el5_latest 8204/8204
            ol5_u6_base | 1.1 kB 00:00
            repo id repo name status
            el5_addons Enterprise Linux 5 Add ons (i386) enabled: 168
            el5_latest Oracle Linux 5 Latest (i386) enabled: 8,204
            ol5_u6_base Oracle Linux 5 Update 6 installation media copy (i386 enabled: 3703
            repolist: 12,075

            =================================



            Did I miss anything?

            Thanks.
            • 3. Re: Unable to use public-yum for R installation
              Sherry Lamonica-Oracle
              What is the returned value of ls /etc/yum.repos.d/ ?

              You can also try:

              yum install R-core-2.13.2-5.el5.x86_64

              Sherry
              • 4. Re: Unable to use public-yum for R installation
                973686
                Hi,

                It still shows the No package found error.
                I ran yum list and there isn't any R/R-core packages available.

                Below is the output of ls /etc/yum.repos.d/ and yum list (I extract the el5_addons one to keep the post short as it seems unable to upload the entire list as attachment here)
                =================
                ls /etc/yum.repos.d/
                public-yum-el5.repo
                public-yum-el5.repo.old
                public-yum-el5.repo.old2

                The old and old2 files are just identical backup.
                =================
                root@localhost yum.repos.d>yum list | grep el5_addons

                Bad id for repo: EL5.6 DVD, byte = 5
                This system is not registered with ULN.
                ULN support will be disabled.

                Django.noarch 1.0.2-2.el5 el5_addons
                VirtualBox-3.2.i386 3.2.12_68302_rhel5-1 el5_addons
                VirtualBox-4.0.i386 4.0.16_75491_rhel5-1 el5_addons
                VirtualBox-4.1.i386 4.1.22_80657_el5-1 el5_addons
                VirtualBox-4.2.i386 4.2.4_81684_el5-1 el5_addons
                blocxx.i386 1.0.0-17.2 el5_addons
                hwinfo.i386 13.57-2 el5_addons
                jta.noarch 2.6-1 el5_addons
                kernel-uek-headers.i686 2.6.32-300.39.1.el5uek el5_addons
                kmod-ovmapi-uek.i686 1.0.0-27.300.uek5 el5_addons
                libovmapi.i386 3.0-6.el5 el5_addons
                libovmapi-devel.i386 3.0-6.el5 el5_addons
                libxcrypt.i386 2.4-12.2 el5_addons
                liby2util.i386 2.13.8-0.12 el5_addons
                libzypp.i386 2.15.10-0.4 el5_addons
                ol-template-config.noarch 1.1.0-9.el5 el5_addons
                ovm-template-config.noarch 3.0-68.el5 el5_addons
                ovm-template-config-authentication.noarch 3.0-68.el5 el5_addons
                ovm-template-config-datetime.noarch 3.0-68.el5 el5_addons
                ovm-template-config-firewall.noarch 3.0-68.el5 el5_addons
                ovm-template-config-network.noarch 3.0-68.el5 el5_addons
                ovm-template-config-selinux.noarch 3.0-68.el5 el5_addons
                ovm-template-config-ssh.noarch 3.0-68.el5 el5_addons
                ovm-template-config-system.noarch 3.0-68.el5 el5_addons
                ovm-template-config-user.noarch 3.0-68.el5 el5_addons
                ovmd.i386 3.0-27.el5 el5_addons
                perl-Parse-RecDescent.i386 1.80-259.2 el5_addons
                perl-X500-DN.i386 0.28-133.2 el5_addons
                perl-gettext.i386 1.05-13.2 el5_addons
                python-ZSI.noarch 2.1-a1.el5 el5_addons
                python-sqlite2.i386 1:2.3.3-2.el5 el5_addons
                testutf8.i386 1.0-1.2 el5_addons
                tightvnc-java.noarch 1.3.9-4 el5_addons
                uln-yum-proxy.noarch 0.0.3-1.el5 el5_addons
                xenstoreprovider.i386 3.0-9.el5 el5_addons
                yast2.i386 2.13.104-1.0 el5_addons
                yast2-EM.noarch 1.9.5-0.2 el5_addons
                yast2-all.noarch 2.0-1 el5_addons
                yast2-core.i386 2.13.39-0.3 el5_addons
                yast2-country.i386 2.13.52-0.9 el5_addons
                yast2-hardware-detection.i386 2.13.7-0.9 el5_addons
                yast2-installation.noarch 2.13.192-0.4 el5_addons
                yast2-ldap-client.noarch 2.13.27-0.11 el5_addons
                yast2-mail-aliases.noarch 2.13.8-0.11 el5_addons
                yast2-ncurses.i386 2.13.66-0.12 el5_addons
                yast2-network.i386 2.13.98-0.7 el5_addons
                yast2-nfs-client.noarch 2.13.4-0.11 el5_addons
                yast2-pam.noarch 2.13.5-0.11 el5_addons
                yast2-perl-bindings.i386 2.13.11-0.17 el5_addons
                yast2-pkg-bindings.i386 2.13.117-0.13 el5_addons
                yast2-runlevel.noarch 2.13.11-0.11 el5_addons
                yast2-security.noarch 2.13.7-0.11 el5_addons
                yast2-users.i386 2.13.55-0.4 el5_addons
                yum-arch.noarch 2.2.2-2.el5 el5_addons
                zend-server-repo.noarch 4.1-1.el5 el5_addons



                Does anything seem wrong in my process?
                Thanks.

                Cheers,
                Philip
                • 5. Re: Unable to use public-yum for R installation
                  Sherry Lamonica-Oracle
                  Philip,

                  What time zone are you in? Let's resolve this by web conference.
                  My email address is sherry.lamonica@oracle.com. Please
                  send me a message with your availability.

                  Thanks,

                  Sherry