This discussion is archived
3 Replies Latest reply: Nov 16, 2012 5:07 PM by Dude! RSS

kernel-devel different from kernel version.

pokharel Newbie
Currently Being Moderated
hello,
I was trying to install nvidia graphics driver but I am getting the error of kernel files. I suppose this is because of the vesion mismach of the kernel and kernel-devel.

#uname -mr
2.6.39-200.32.1.el6uek.x86_64 x86_64

whereas
[root@ntcpc Desktop]# rpm -qa kernel\* | sort
kernel-2.6.32-279.9.1.el6.x86_64
kernel-2.6.32-279.el6.x86_64
kernel-devel-2.6.32-279.9.1.el6.x86_64
kernel-firmware-2.6.32-279.9.1.el6.noarch
kernel-uek-2.6.39-200.24.1.el6uek.x86_64
kernel-uek-2.6.39-200.32.1.el6uek.x86_64
kernel-uek-firmware-2.6.39-200.24.1.el6uek.noarch
kernel-uek-firmware-2.6.39-200.32.1.el6uek.noarch
kernel-uek-headers-2.6.32-300.32.3.el6uek.x86_64


yum update kernel-devel won't help since it says it is up to date.

What can I do to match the kernel-devel to the kernel version?

Thank you

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points