This discussion is archived
2 Replies Latest reply: Nov 17, 2012 4:57 AM by joehoot RSS

non-dba sysadmin trying to get APEX 4.2 working

joehoot Newbie
Currently Being Moderated
Hi all,

I am a sysadmin who thinks APEX would do him good for various projects that I'm sick of relying on Excel for. So, I'm on my way to installing it. I've attempted a fresh install three times now by following the documentation. I've installed OL5.8 + UEK kernel, run all the prereqs for Oracle 11.2.0.3 Enterprise Edition database, run oracle-validated-verify (just to make sure), install 11.2.0.3 database. go through some steps to make sure I can connect to the database (btw, I never use Oracle.. I'm used to mysql from other LAMP stuff.. but since we have a show of about 10-15 Oracle DBA's, I'm guessing they can help me a bit more), I then proceed with the APEX documentation.

When I finish with the install and go to create my workspace by hitting http://localhost:8080/apex/apex_admin I get connected. I get some sort of unique id created and the url is now "http://localhost:8080/apex/f?p=4550:10:6151872728391". So something is answering and attempting to do something. The title of the browser is also now set to "Application Express Administration Services" but nothing shows up in the browser body (at list visibly). If I right click an view source, I can see lots of javascript and other code. So I know that it's attempting to do something.

The one thing I noticed that may not have worked correctly in the documentation is this step:

`@apex_epg_config.sql /tmp`

I ran that and saw the following error:

ERROR at line 1:
ORA-22288: file or LOB operation FILEOPEN failed
No such file or directory
ORA-06512: at "SYS.XMLTYPE", line 296
ORA-06512: at line 18

So then I reread the documentation and it says that "/tmp" should be where you unzipped apex to (for me this is /u01/stage/apex). So Then I tried the command above again with that instead, but received the same error about FILEOPEN failed. That is the only thing that I can think of that could be failing this.

Does anyone have an idea of where I might be failing with this installation? Do you know of which logfiles I can look at to see what's going wrong?

Thanks,
Joe
  • 1. Re: non-dba sysadmin trying to get APEX 4.2 working
    mobra Journeyer
    Currently Being Moderated
    So then I reread the documentation and it says that "/tmp" should be where you unzipped apex to (for me this is /u01/stage/apex). So Then I tried the command above again with that instead, but received the same error about FILEOPEN failed. That is the only thing that I can think of that could be failing this.
    The statement that the load image script is trying to run is this:
    create directory APEX_IMAGES as '&1/apex/images';
    So make sure that the argument you pass to the script will result in a correct path to the actual location of the unzipped files. So I think in your case the argument should be "/u01/stage" so that the full path will be expanded to "/u01/stage/apex/images" by the script.

    If you pass a wrong argument, the script won't find the specified folder, and no Javascript files get loaded into the database (EPG/XDB), which causes the problem with pages not working due to missing Javascript files.

    - Morten

    http://ora-00001.blogspot.com
  • 2. Re: non-dba sysadmin trying to get APEX 4.2 working
    joehoot Newbie
    Currently Being Moderated
    ahh... much better now. I see graphics!!!

    Most of the documentation refers to the root of the directory that you unzipped (/u01/stage/apex/, for example). But then that one SQL references /u01/stage. I can see now, after re-reading the documentation yet again, that it certainly does mean /u01/stage. But in any case, thank you for your help. I've changed my admin password and am now on my way to figuring out how to convert my spreadsheets to nice apex applications :)

    Thanks again for your help.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points