5 Replies Latest reply on Nov 23, 2012 1:21 AM by Stuart Fleming

    Issue with Packaged Jars added to project from resource Palette

    Stuart Fleming
      I am using Jdeveloper

      I started this post thinking there was an issue having to do with packaging jars that refer to other libraries (see post Are Libraries Required?

      Now I realize it is a different issue (although that other post is relevant).

      Issue: I create a package -- a template in this case.

      I deploy it in my file system and then load it into the resource palette as a file system connection.

      I create a new application. From the resource palette, I add the jar to the view controller project, and am able to use the template in jsf files. No problem. Runs fine.

      then I load the application into subversion or I move the whole application to another directory on my computer.

      When I open the moved application (or do a checkout from subversion), I open the jsf that contains a reference to the jar, the design view is completely blank. Going to the source, I see my original code, but there are red signals in the upper-right signifying an error.

      If I run the application without fixing it, I get an error saying the template cant be found, Also, when I deployed to a standalone weblogic server, I get the same error (see the post above for this error).

      I open the project properties. The ADF Library is in the "Libraries and Classpath" and pressing edit, I can see the correct reference to the path of the jar.

      To make the application work, I have to remove the ADF Library (or at least the reference when pressing edit) and then from the resource palette, add it again to the project.

      IS THIS NORMAL? Am I doing something wrong with the initial packaging of the jar? Should I change some setting somewhere?

      How am I supposed to deploy to weblogic?

      The other posting shows an error output if I try to run the application before fixing the jar reference. I got the same darn error when deploying to weblogic.

      Would appreciate any help!


      Edited by: Stuart Fleming on Nov 18, 2012 4:45 AM
        • 1. Re: Issue with Packaged Jars added to project from resource Palette
          Timo Hahn
          Stuart, interesting case...
          Can you try the following sequence (assuming you already have the template in an adf lib):
          1) build an application using the template from the adf lib.
          2) make sure it runs OK
          3) then copy the whole workspace (including all files and folders)
          4)check the app into SVN
          5) check it out into a different location which should produce the error you described
          6) Do a complete rebuild and try to run the app

          Q1) does it run or do you get an error?
          Q2) do you see the error you described in your post?

          Now, if you see the error you should compare the two workspaces (the one you save in step 3 with the current one).
          Q3) do you see any differences?

          • 2. Re: Issue with Packaged Jars added to project from resource Palette
            Stuart Fleming
            thank you for your reply. I actually created a youtube video on this, available here: http://youtu.be/ERyLngq9hlI

            Since the video might be a little tedious to view, Here are the details. You can jump to the exciting parts of the video, if you want:

            Here is what I did:

            1. I cleaned out my system directory and the temp directory on my computer.

            2. Opened the application containing my template. Deleted the existing jar file.

            3. Started taking video....

            4. (From 40 seconds into the video) Created the jar file again.

            5. (2:55 minuts into video) Closed template applcation and Created new fusion application.

            6. (4 minutes into the video) Created model

            7. (4:15 minutes into video) in view controller added template, created a jsf page.

            8. (5 minutes into the video) Created Security and users.

            9. (6:30 minutes into the video) Created a task flow, with jsff in it, with a form on the jsff. Assigned Security to objects.

            *10. (7 minutes into the video). Ran JSF successfully.*

            11. (7:40 minutes into the video). Closed application. Copied the entire application into two directories.

            12. (8 minutes into video) Opened the first copied video. You can see that the jsf page is not accessing the template. Reviewed the View Controller project Libraries and classpath. Removed the library, re-added the jar from the resource palette. Worked fine.

            13. (9:30 minutes into video). Opened the 2nd copy of the file I intend for subversion. Showed the jsf page and the error it displays when open (same as in first copied application).

            Load application into subversion.

            14. (10 minutes into video). Check out application

            15. (10:15 minutes into video). Open JSF file. The reference to the template jar file is reading properly.

            16. (11 minutes into video). Load the original working copy into subversion.

            17. (11:30 minutes into video). Check out from subverion, but the check out failed.

            18. (12 minutes into video). Check out, and look at the jsf.  The page shows fine.

            Timo, I think this might be reported as a bug. You ought to be able to move files around on your computer. Also, the first time I checked the application out from subversion, the jsf page did not read the template.

            ALSO, when I tried to deploy the application (that contained the reference to the template jar file to weblogic), I got the same error when I ran the jsf

            first lines of that error:
            Error 500--Internal Server Error

            java.io.FileNotFoundException: /WEB-INF/ssfTemplate/SSFTemplate.jsf Not Found in ExternalContext as a Resource
            at com.sun.faces.facelets.impl.DefaultFaceletFactory.resolveURL(DefaultFaceletFactory.java:224)

            Thank you for your time and commitment!

            Edited by: Stuart Fleming on Nov 18, 2012 10:13 AM
            • 3. Re: Issue with Packaged Jars added to project from resource Palette
              Hi Stuart,

              I will have a look at this tomorrow Monday. One thing though, after you check in the application. Does the ADF Lib files is there on the file system?

              Juan C.
              • 4. Re: Issue with Packaged Jars added to project from resource Palette
                Stuart Fleming
                Thank you for looking into this. I installed Jdeveloper and installed Jdeveloper this evening.

                I was able to copy and move around the application and place them on different places on the file system, and the jsf file showed the template on opening. I am not sure what happened to cause it, whether it was fixed, but I will close this.

                • 5. Re: Issue with Packaged Jars added to project from resource Palette
                  Stuart Fleming
                  Hi Timo,
                  It has happened again. I do believe this is a bug. I am not sure that anyone else has encountered the same issue, however. This time I checked out the version from subversion (in the video I made the checkout worked fine, although the first time I tested this, but a copy of the application to a different location AND the checkout from subversion failed.

                  Also, I am now on Jdeveloper

                  I am not sure if I should make a new post on this and mention it as a bug.

                  By the way, I deleted out the application and then checked it out again. This time it worked. NOT consistent! However, it would be best if this could be fixed (if it can be replicated!) because on a large project it could really mess things up.

                  Best Regards,

                  Edited by: Stuart Fleming on Nov 22, 2012 5:20 PM