5 Replies Latest reply: Nov 22, 2012 1:26 PM by 969358 RSS

    The server name osr_server1 is unknown to the administration server

    969358
      I have successfully installed OSR and created WLS Domain using config.cmd. But when I try to start by command line (startManagedWebLogic.cmd osr_server1) I got the error "server is unknown". I have no idea what could be wrong.

      Basically I followed http://niallcblogs.blogspot.com.br/2010/09/oracle-service-registry-and-osb11g.html.
      The complete command line is:

      C:\Oracle\Middleware\user_projects\domains\base_domain\bin>startManagedWebLogic.
      cmd osr_server1
      .
      .
      JAVA Memory arguments: -Xms256m -Xmx512m -XX:CompileThreshold=8000 -XX:PermSize=
      48m -XX:MaxPermSize=128m
      .
      WLS Start Mode=Development
      .
      CLASSPATH=C:\Oracle\MIDDLE~1\patch_wls1036\profiles\default\sys_manifest_classpa
      th\weblogic_patch.jar;C:\Oracle\MIDDLE~1\patch_oepe180\profiles\default\sys_mani
      fest_classpath\weblogic_patch.jar;C:\Oracle\MIDDLE~1\patch_ocp371\profiles\defau
      lt\sys_manifest_classpath\weblogic_patch.jar;C:\Oracle\MIDDLE~1\patch_adfr1111\p
      rofiles\default\sys_manifest_classpath\weblogic_patch.jar;C:\Oracle\MIDDLE~1\JDK
      160~1\lib\tools.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\lib\weblogic_sp.jar;C:\
      Oracle\MIDDLE~1\WLSERV~1.3\server\lib\weblogic.jar;C:\Oracle\MIDDLE~1\modules\fe
      atures\weblogic.server.modules_10.3.6.0.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\server
      \lib\webservices.jar;C:\Oracle\MIDDLE~1\modules\ORGAPA~1.1/lib/ant-all.jar;C:\Or
      acle\MIDDLE~1\modules\NETSFA~1.0_1/lib/ant-contrib.jar;C:\Oracle\MIDDLE~1\WLSERV
      ~1.3\common\derby\lib\derbyclient.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\lib\x
      qrl.jar;C:\Program Files\Java\jdk1.7.0_09\jre\lib
      .
      PATH=C:\Oracle\MIDDLE~1\patch_wls1036\profiles\default\native;C:\Oracle\MIDDLE~1
      \patch_oepe180\profiles\default\native;C:\Oracle\MIDDLE~1\patch_ocp371\profiles\
      default\native;C:\Oracle\MIDDLE~1\patch_adfr1111\profiles\default\native;C:\Orac
      le\MIDDLE~1\WLSERV~1.3\server\native\win\32;C:\Oracle\MIDDLE~1\WLSERV~1.3\server
      \bin;C:\Oracle\MIDDLE~1\modules\ORGAPA~1.1\bin;C:\Oracle\MIDDLE~1\JDK160~1\jre\b
      in;C:\Oracle\MIDDLE~1\JDK160~1\bin;C:\Oracle\product\11.1.0\client_1\bin;C:\Wind
      ows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowe
      rShell\v1.0\;C:\Program Files\Microsoft SQL Server\100\DTS\Binn\;C:\Program File
      s\Microsoft SQL Server\100\Tools\Binn\VSShell\Common7\IDE\;C:\Program Files\Micr
      osoft SQL Server\100\Tools\Binn\;C:\Program Files\Microsoft Visual Studio 9.0\Co
      mmon7\IDE\PrivateAssemblies\;c:\Program Files\Microsoft SQL Server\90\Tools\binn
      \;C:\Program Files\Java\jdk1.7.0_09\bin;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\nat
      ive\win\32\oci920_8
      .
      ***************************************************
      * To start WebLogic Server, use a username and *
      * password assigned to an admin-level user. For *
      * server administration, use the WebLogic Server *
      * console at http:\\hostname:port\console *
      ***************************************************
      starting weblogic with Java version:
      java version "1.6.0_29"
      Java(TM) SE Runtime Environment (build 1.6.0_29-b11)
      Java HotSpot(TM) Client VM (build 20.4-b02, mixed mode)
      Starting WLS with line:
      C:\Oracle\MIDDLE~1\JDK160~1\bin\java -client -Xms256m -Xmx512m -XX:CompileThre
      shold=8000 -XX:PermSize=48m -XX:MaxPermSize=128m -Dweblogic.Name=osr_server1 -D
      java.security.policy=C:\Oracle\MIDDLE~1\WLSERV~1.3\server\lib\weblogic.policy -D
      weblogic.security.SSL.trustedCAKeyStore="C:\Oracle\Middleware\wlserver_10.3\serv
      er\lib\cacerts" -Xverify:none -da -Dplatform.home=C:\Oracle\MIDDLE~1\WLSERV~1.
      3 -Dwls.home=C:\Oracle\MIDDLE~1\WLSERV~1.3\server -Dweblogic.home=C:\Oracle\MIDD
      LE~1\WLSERV~1.3\server -Dweblogic.management.discover=false -Dweblogic.managem
      ent.server=http://SISTEMA026:7001 -Dwlw.iterativeDev=false -Dwlw.testConsole=fa
      lse -Dwlw.logErrorsToConsole=false -Dweblogic.ext.dirs=C:\Oracle\MIDDLE~1\patch_
      wls1036\profiles\default\sysext_manifest_classpath;C:\Oracle\MIDDLE~1\patch_oepe
      180\profiles\default\sysext_manifest_classpath;C:\Oracle\MIDDLE~1\patch_ocp371\p
      rofiles\default\sysext_manifest_classpath;C:\Oracle\MIDDLE~1\patch_adfr1111\prof
      iles\default\sysext_manifest_classpath weblogic.Server
      <19/11/2012 18h40min53s BRST> <Info> <Security> <BEA-090905> <Disabling CryptoJ
      JCE Provider self-integrity check for better startup performance. To enable this
      check, specify -Dweblogic.security.allowCryptoJDefaultJCEVerification=true>
      <19/11/2012 18h40min53s BRST> <Info> <Security> <BEA-090906> <Changing the defau
      lt Random Number Generator in RSA CryptoJ from ECDRBG to FIPS186PRNG. To disable
      this change, specify -Dweblogic.security.allowCryptoJDefaultPRNG=true>
      <19/11/2012 18h40min53s BRST> <Info> <WebLogicServer> <BEA-000377> <Starting Web
      Logic Server with Java HotSpot(TM) Client VM Version 20.4-b02 from Sun Microsyst
      ems Inc.>
      <19/11/2012 18h40min53s BRST> <Info> <Security> <BEA-090065> <Getting boot ident
      ity from user.>
      Enter username to boot WebLogic server:weblogic_osr2
      Enter password to boot WebLogic server:
      <19/11/2012 18h41min23s BRST> <Info> <Management> <BEA-141107> <Version: WebLogi
      c Server 10.3.6.0 Tue Nov 15 08:52:36 PST 2011 1441050 >
      <19/11/2012 18h41min24s BRST> <Emergency> <Management> <BEA-141151> <The admin s
      erver could not be reached at http://SISTEMA026:7001.>
      <19/11/2012 18h41min24s BRST> <Critical> <WebLogicServer> <BEA-000362> <Server f
      ailed. Reason:

      There are 1 nested errors:

      weblogic.management.ManagementException: The server name osr_server1 is unknown
      to the administration server. Check if restart is required.
      at weblogic.management.provider.internal.RuntimeAccessImpl.initialize(Ru
      ntimeAccessImpl.java:447)
      at weblogic.management.provider.internal.RuntimeAccessService.start(Runt
      imeAccessService.java:49)
      at weblogic.t3.srvr.ServerServicesManager.startService(ServerServicesMan
      ager.java:461)
      at weblogic.t3.srvr.ServerServicesManager.startInStandbyState(ServerServ
      icesManager.java:166)
      at weblogic.t3.srvr.T3Srvr.initializeStandby(T3Srvr.java:881)
      at weblogic.t3.srvr.T3Srvr.startup(T3Srvr.java:568)
      at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:469)
      at weblogic.Server.main(Server.java:71)

      >
      <19/11/2012 18h41min24s BRST> <Notice> <WebLogicServer> <BEA-000365> <Server sta
      te changed to FAILED>
      <19/11/2012 18h41min24s BRST> <Error> <WebLogicServer> <BEA-000383> <A critical
      service failed. The server will shut itself down>
      <19/11/2012 18h41min24s BRST> <Notice> <WebLogicServer> <BEA-000365> <Server sta
      te changed to FORCE_SHUTTING_DOWN>
        • 1. Re: The server name osr_server1 is unknown to the administration server
          vladodias
          Hi,

          Go to C:\Oracle\Middleware\user_projects\domains\base_domain\config and have a look at the config xml file...

          Seach for <server> tags to see what servers you have configured...

          If you can't find something like the following then you may redo your domain creation steps...
          <server>
              <name>osr_server1</name>
          ....
          ....
          </server>
          Cheers,
          Vlad
          • 2. Re: The server name osr_server1 is unknown to the administration server
            969358
            Yes, there are the tags you have suggested. The complete config.xml is below.
            I tried:
            C:\Oracle\Middleware\user_projects\domains\base_domain\bin>startManagedWebLogic.
            cmd osr_server1
            When asked the user, I tried the node-manager-username weblogic_osr2 and the admin user but I always received the error: The server name osr_server1 is unknown to the administration server.

            <?xml version="1.0" encoding="UTF-8" ?>
            - <domain xsi:schemaLocation="http://xmlns.oracle.com/weblogic/security/wls http://xmlns.oracle.com/weblogic/security/wls/1.0/wls.xsd http://xmlns.oracle.com/weblogic/domain http://xmlns.oracle.com/weblogic/1.0/domain.xsd http://xmlns.oracle.com/weblogic/security http://xmlns.oracle.com/weblogic/1.0/security.xsd http://xmlns.oracle.com/weblogic/security/xacml http://xmlns.oracle.com/weblogic/security/xacml/1.0/xacml.xsd" xmlns="http://xmlns.oracle.com/weblogic/domain" xmlns:sec="http://xmlns.oracle.com/weblogic/security" xmlns:wls="http://xmlns.oracle.com/weblogic/security/wls" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <name>base_domain</name>
            <domain-version>10.3.6.0</domain-version>
            - <security-configuration>
            <name>base_domain</name>
            - <realm xmlns:pas="http://xmlns.oracle.com/weblogic/security/providers/passwordvalidator">
            <sec:authentication-provider xsi:type="wls:default-authenticatorType" />
            - <sec:authentication-provider xsi:type="wls:default-identity-asserterType">
            <sec:active-type>AuthenticatedUser</sec:active-type>
            </sec:authentication-provider>
            <sec:role-mapper xsi:type="wls:default-role-mapperType" />
            <sec:authorizer xsi:type="wls:default-authorizerType" />
            <sec:adjudicator xsi:type="wls:default-adjudicatorType" />
            <sec:credential-mapper xsi:type="wls:default-credential-mapperType" />
            <sec:cert-path-provider xsi:type="wls:web-logic-cert-path-providerType" />
            <sec:cert-path-builder>WebLogicCertPathProvider</sec:cert-path-builder>
            <sec:name>myrealm</sec:name>
            - <sec:password-validator xsi:type="pas:system-password-validatorType">
            <sec:name>systemPasswordValidator</sec:name>
            <pas:min-password-length>8</pas:min-password-length>
            <pas:min-numeric-or-special-characters>1</pas:min-numeric-or-special-characters>
            </sec:password-validator>
            </realm>
            <default-realm>myrealm</default-realm>
            <credential-encrypted>{AES}LArhcMlb7Jdt2zQbNnzLdi3luhgdNyPJS1JIVb9H+VWi5XcC9SP4SQa/8mp/SKI072DoA/sGnzvYDqpn3OxQl3pE0LxaXoOmYNnWsSv/keo8I0rMvrXWJXqn4fbSl9bd</credential-encrypted>
            *<node-manager-username>weblogic_osr2</node-manager-username>*
            <node-manager-password-encrypted>{AES}1SioVLWu3mu/u6y/You1ZGeBTXJHfUCq+loZSCVOdSE=</node-manager-password-encrypted>
            </security-configuration>
            - <server>
            <name>AdminServer</name>
            <listen-address />
            </server>
            - <server>
            *<name>osr_server1</name>*
            <listen-port>7101</listen-port>
            <listen-address>sistema026.br-lihi.libertyinternational.com</listen-address>
            </server>
            - <embedded-ldap>
            <name>base_domain</name>
            <credential-encrypted>{AES}C+0tyHN5wihXjDHQKdQt/5PvYpko8rS0PL6wSSvp3sHLZscRB1RjSNL8MXfHHjwW</credential-encrypted>
            </embedded-ldap>
            <configuration-version>10.3.6.0</configuration-version>
            - <app-deployment>
            <name>registry</name>
            <target>osr_server1</target>
            <module-type>war</module-type>
            <source-path>C:\Oracle\Middleware\registry111/conf/porting/weblogic/build/registry.war</source-path>
            <deployment-order>195</deployment-order>
            <security-dd-model>DDOnly</security-dd-model>
            </app-deployment>
            <admin-server-name>AdminServer</admin-server-name>
            - <jdbc-system-resource>
            <name>jdbc/registryDS</name>
            <target>osr_server1</target>
            <descriptor-file-name>jdbc/registry-20121119171422-jdbc.xml</descriptor-file-name>
            </jdbc-system-resource>
            </domain>
            • 3. Re: The server name osr_server1 is unknown to the administration server
              PrazzyJay
              it seems alright.
              Login to adminConsole and see if everything ok in the Servers page.
              Try assigning a machine name to it.
              Check if your logged in the right machine.
              Bring up the node managers and try to start it from adminconsole.


              --Prasanna

              Edited by: helloprasanna on Nov 21, 2012 2:13 PM
              • 4. Re: The server name osr_server1 is unknown to the administration server
                vladodias
                Is the AdminServer started? Have you done...
                startWebLogic.cmd
                Also, try passing the admin url when starting the managed server...
                startManagedWebLogic.cmd osr_server1 http://localhost:7001
                Cheers,
                Vlad
                • 5. Re: The server name osr_server1 is unknown to the administration server
                  969358
                  My mistake was very silly. I started the weblogic from a certain domain and the weblogicmanager from other domain. Thanks to everyone.