1 Reply Latest reply on Nov 20, 2012 1:11 PM by Stuart Fleming

    .jws default program is notepad, not jdeveloper

    Stuart Fleming
      I uninstalled jdeveloper the other day and installed the newest version I installed the new version in a different location on my computer. I am on windows 7, home version. I am an administrator on the computer.

      Today I tried to open a .jws file and it opened in notepad. I am not sure if this was an error on my part -- I accidentally chose "open with" and it stuck on notepad.

      At any rate, there are ways to change the file association, in control panel, default programs. Unfortunately, Jdeveloper does not show up on the list of programs listed. There is a browse button, and I used that and selected jdeveloper.exe, but that did not add the program to the list, and it is still listing notepad as the program to open it.

      I tried all of the steps on http://www.techbuzz.in/can-i-change-file-associations-in-windows-7-vista.php

      Would anyone have any ideas?

      Thank you,
        • 1. Re: .jws default program is notepad, not jdeveloper
          Stuart Fleming
          Finally found this: http://www.computerhope.com/ftype.htm

          By running ftype in a dos command window, I was able to see that my jws files etc were being opened by the older location of


          JDeveloper.jwsFile="C:\Oracle\Middleware\jdeveloper\jdeveloper.exe" "%1" %*
          JDeveloper.javaFile="C:\Oracle\Middleware\jdeveloper\jdeveloper.exe" "%1" %*
          JDeveloper.jprFile="C:\Oracle\Middleware\jdeveloper\jdeveloper.exe" "%1" %*
          JDeveloper.jspFile="C:\Oracle\Middleware\jdeveloper\jdeveloper.exe" "%1" %*

          ::*Open command prompt (right-click icon from start menu and select run as administrator).*

          ::run "assoc" and you will see if it is there on the list

          :: The output should be: .jws=JDeveloper.jwsFile

          ::If it is not there run this:
          ASSOC .jws=jwsFile

          ::Then run assoc again, see if it is on the list

          ::Next run this line, but change the location to your location
          ftype  JDeveloper.jwsFile="C:\Oracle\jdeveloper\jdeveloper.exe" "%1" %*

          By running this, it did not immediately make the association to Jdeveloper again, but when I right-clicked the .jws file and

          selected open with, then "choose default program" jdeveloper showed up on the list.