9 Replies Latest reply on Nov 30, 2012 6:45 PM by Cindys-Oracle

    "Unformatted" ZFS-managed disks

      I had three zpools in an Oracle/Sun 5220. Some hardware problems, unrelated to the HDDs, prompted me to abandon the server. I moved the eight drives to an identical server, but now the second and third drives for each original zpool appears to be unformatted. The rpool was a two-disk mirror, so it is degraded but still available. The other two zpools were raidz with three disks each. Since only one drive from each zpool is recognized, neither of the zpools is accessible.

      Am I missing something? Is there a way to get Solaris to recognize these disks without reformatting and losing the data?
        • 1. Re: "Unformatted" ZFS-managed disks
          have u tried the zpool import

          and verfied the pool names?
          • 2. Re: "Unformatted" ZFS-managed disks
            Thank you for your response. I have tried zpool import. I'm able to see the pools when I run zpool status, but both are unavailable because there are too few devices available.

            Edited by: user1462569 on Nov 20, 2012 12:40 AM
            • 3. Re: "Unformatted" ZFS-managed disks
              "Unformatted" can also show up when you can't read the disk at all.

              What happens if you try to read from the raw disks that show up unformatted?
              dd if=/dev/rdsk/c2t0d0 of=/dev/null bs=1024k
              Just be really careful that you use if=/dev/rdsk/... to make sure you're READING from the disk and not writing to it.

              That should tell you if you can actually access the disk.
              1 person found this helpful
              • 4. Re: "Unformatted" ZFS-managed disks
                Is the disk error message is something like the disk label is unrecognizable or something similar?
                If so, I would try to just relabel the disk. You should be prompted to do this when you access the
                disk with format-->disk. I would give that a try.

                I've clobbered a mirrored root pool disk label and this is how I was able to recover.

                Let us know.


                1 person found this helpful
                • 5. Re: "Unformatted" ZFS-managed disks
                  I ran the dd as you suggested. It returned an I/O error on the two disks in question. This prompted me to run iostat -eE, and it confirmed that there were hardware errors.
                  I guess I didn't want to believe that three of my eight disks would fail at once, so I ruled out hardware problems. Thanks for the tip.
                  • 6. Re: "Unformatted" ZFS-managed disks

                    As noted in the post above, it was a hardware problem that was preventing me from re-labeling. After replacing the disks, I ended up blowing away the pool and recreating it. Fortunately there was no user data on the pool, just zones that will have to be recreated. Thank you for your suggestion.

                    Edited by: Curmudgeon on Nov 21, 2012 4:51 PM
                    • 7. Re: "Unformatted" ZFS-managed disks
                      Okay, thanks for letting us know. I don't think I've seen an unformatted error message in a really long
                      time. If you have the exact error and can still provide it, I'd like to see it.

                      I keep some ZFS monitoring practices here to avoid being surprised by disk failures:


                      The above is the Solaris 10 version.

                      Unknown disk failures are a big problem so in the Solaris 11 version, I include a description
                      of the smtp-notify service, which can be set up to send disk failure notices, here:


                      Thanks, Cindy
                      • 8. Re: "Unformatted" ZFS-managed disks

                        I was getting the unformatted error when I accessed the disk through the format utility. It would let me select the disk, but it didn't have any of the disk information available. Then, when I tried to re-label, the utility would just respond with "(disk unformatted)".

                        I haven't completely given up on the hard-disks, though. I'm going to try and re-format them in another server. I'll keep you posted.

                        • 9. Re: "Unformatted" ZFS-managed disks
                          Hi Darren,

                          I did a bit of digging and I found this error and the likely scenario which is around using
                          SAN devices, MPxIO and there is a some kind of driver mismatch or moving LUNS around
                          from different systems with different numbering. In addition to seeing format messages
                          like this:

                          [disk unformatted]
                          Disk not labeled. Label it now?

                          If you enter "y" to label the disk it fails :

                          Warning: error writing EFI.
                          Write label failed

                          You might also look for /var/adm/messages like this:

                          Nov 14 13:49:42 kvsfs2 scsi: [ID 107833 kern.warning] WARNING:
                          /scsi_vhci/ssd@g600a0b800026b13400000f40461072f9 (ssd225):
                          Nov 14 13:49:42 kvsfs2 i/o to invalid geometry

                          I don't know if this is an exact match but the bugs look like 15528958 or 15543796,
                          particularly 15543796 since it involves moving LUNs around.

                          Thanks, Cindy