7 Replies Latest reply on Nov 20, 2012 5:34 PM by JohnGoodwin

    Planning Application Migration failing

    John M
      I am migrating a planning application from dev servers to test servers using Life Cycle Management, and am running into the same issues over and over, can't figure it out. The applications come over just fine, but the user permissions/settings fail. I get the following errors:

      Error in migrating artifact, "/Configuration/User Preferences".
      Import failed, total - 32, failed - 31. Error details - User <USER> does not exist for this application

      Error in migrating artifact, "/Security/Access Permissions/Users".
      Import failed, total - 12, failed - 12. Error details - Cannot import Access permission - User (<USER>) not found, error detail -(Invalid user name found in the file.)

      Error in migrating artifact, "/Security/Access Permissions/Groups/<GROUP>".
      Import failed, total - 38, failed - 38. Error details - Cannot import Access permission - Group (<GROUP>) not found, error detail -(Group <GROUP> does not exist for this application.)

      So, the weird thing is that all these users and groups exist, so I'm at a loss as to why the import is failing. I've looked at similar threads on this board, and tried a couple different solutions. There is one that I haven't tried, that recommended that each user should be provisioned before running this import, but to me that seemed to defeat the purpose of importing and exporting this information with LCM. If I have to go to that trouble for each user and group, not an insignificant number, that is a LOT of extra work, and again, I thought that was supposed to be the purpose of exporting/importing. Any thoughts?

      Edited by: 972098 on Nov 19, 2012 3:23 PM