2 Replies Latest reply: Jan 22, 2013 2:01 PM by BikashBagaria RSS

    How to increase or disable transaction timeout?

    madhatter
      Hi all,

      while debugging provisioning tasks OIM 11.1.1.5.0 get this exception if I pause program execution for some period of time:

      Caused by: weblogic.transaction.internal.TimedOutException: Transaction timed out after 600 seconds
      BEA1-4C7A1CAD60C71918D861
           at weblogic.transaction.internal.ServerTransactionImpl.wakeUp(ServerTransactionImpl.java:1748)
           at weblogic.transaction.internal.ServerTransactionManagerImpl.processTimedOutTransactions(ServerTransactionManagerImpl.java:1591)
           at weblogic.transaction.internal.TransactionManagerImpl.wakeUp(TransactionManagerImpl.java:1911)
           at weblogic.transaction.internal.ServerTransactionManagerImpl.wakeUp(ServerTransactionManagerImpl.java:1501)
           at weblogic.transaction.internal.WLSTimer.timerExpired(WLSTimer.java:35)
           at weblogic.timers.internal.TimerImpl.run(TimerImpl.java:273)
           at weblogic.work.SelfTuningWorkManagerImpl$WorkAdapterImpl.run(SelfTuningWorkManagerImpl.java:528)
           ... 2 more

      the server does not recover from this situation and has to be restarted.

      Is it possible to avoid this nuisance?

      Regards,
      Vladimir
        • 1. Re: How to increase or disable transaction timeout?
          981845
          Hi
          I faced a similar problem did u get a fix ???


          Thannx in Advance
          • 2. Re: How to increase or disable transaction timeout?
            BikashBagaria
            Article: 559850.1
            How To Change Transaction Timeout for WebLogic Application Server:
            
            Option 1:
            
            1. Edit the weblogic.profile file in the <xlhome>/Profiles directory. (For example /home/oracle/oim/xellerate/Profiles/weblogic.profile) 
            2. Change the weblogic.transaction.timeout value in the file to a large number. For example:  weblogic.transaction.timeout=1200
            
            
            Option 2: 
            
            After logging in Weblogic console, on the home page of the Server Console you should see 3 sections:
            
            * Information and Resources
            * Domain Configurations
            * Services Configurations
            
            Under Services Configurations there is subsection Other Services. Click the JTA Configuration link under Other Services. The transaction timeout should be the top setting on the page displayed, labelled Timeout Seconds.
            
            Note:  If one choose to use the Option 2, then they also update the the weblogic.properties with the same value. 
            -Bikash