This discussion is archived
9 Replies Latest reply: Nov 23, 2012 2:11 AM by 975865 RSS

[INS-08109] Unexpected ... at state 'nodeSelectionPage'

yeow Newbie
Currently Being Moderated
Trying to install oracle database software. The full message on the dialog box is

[INS-08109] Unexpected error occurred while validating inputs at state 'nodeSelectionPage'.

Are you sure you want to continue ?

If you click yes it goes back to where to started and the same error would occurs again if you try again. If you click no it will just exit the installer.

Any help is appreciated. Thanks.

(I am still trying to install a linux oracle cluster :( )

Edited by: kary on Nov 27, 2009 1:07 PM
  • 1. Re: [INS-08109] Unexpected ... at state 'nodeSelectionPage'
    475424 Newbie
    Currently Being Moderated
    i have the same problem.


    - 2 nodes,
    - SUSE Linux Enterprise Server 11 (x86_64)
    - 11gR2
    - grid software install successful



    ---# Begin Stacktrace #---------------------------
    ID: oracle.install.commons.util.exception.DefaultErrorAdvisor:1673
    oracle.install.commons.flow.FlowException: [INS-08109] Unexpected error occurred while validating inputs at state 'nodeSelectionPage'.
    at oracle.install.commons.flow.AbstractFlowExecutor.validate(
    at oracle.install.commons.flow.AbstractFlowExecutor.leaveVertex(
    at oracle.install.commons.flow.AbstractFlowExecutor.transition(
    at oracle.install.commons.flow.AbstractFlowExecutor.nextState(
    at oracle.install.commons.flow.AbstractFlowExecutor.nextViewState(
    at oracle.install.commons.flow.DefaultFlowNavigator.goForward(
    at oracle.install.commons.flow.jewt.FlowWizard$
    at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(
    at java.util.concurrent.ThreadPoolExecutor$
    Caused by: java.lang.IllegalArgumentException:
    at oracle.install.commons.util.Version.parseVersion(
    at oracle.install.ivw.db.validator.NodeSelectionValidator.validate(
    at oracle.install.commons.flow.validation.ValidationHelper.validateState(
    at oracle.install.commons.flow.AbstractFlowExecutor.validate(
    ... 9 more
    ---# End Stacktrace #-----------------------------


    INFO: Terminated all background operations
    WARNING: [WARNING] [INS-08109] Unexpected error occurred while validating inputs at state 'nodeSelectionPage'.
    CAUSE: No additional information available.
    ACTION: Contact Oracle Support Services or refer to the software manual.
    - .
    Refer associated stacktrace #oracle.install.commons.util.exception.DefaultErrorAdvisor:1673
    INFO: Advice is CONTINUE
    INFO: Pause Oracle Database 11g Release 2 Installer
    INFO: Resume Oracle Database 11g Release 2 Installer
    INFO: Exit Status is 0
    INFO: Shutdown Oracle Database 11g Release 2 Installer
    INFO: Unloading Setup Driver

    Any help is welcome. Thanks.
  • 2. Re: [INS-08109] Unexpected ... at state 'nodeSelectionPage'
    yeow Newbie
    Currently Being Moderated
    After successfully configure the LISTENER. This problem has gone away.
  • 3. Re: [INS-08109] Unexpected ... at state 'nodeSelectionPage'
    402451 Newbie
    Currently Being Moderated
    I also faced same issue. and checked solution with Oracle.

    Steps to resolve issue:

    1. Edit runInstaller script
    2. Comment line " unset LD_LIBRARY_PATH"
    3. export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:<grid_home>/lib
    4. rerun runInstaller.
  • 5. Re: [INS-08109] Unexpected ... at state 'nodeSelectionPage'
    831253 Newbie
    Currently Being Moderated
    I solved this on a Windows 7 Environment (64-bit) by right-clicking on the Oracle Setup as Administrator AND de-selecting the Run this program with restricted access.
  • 6. Re: [INS-08109] Unexpected ... at state 'nodeSelectionPage'
    798445 Newbie
    Currently Being Moderated
    Hi, does anyone have new suggestions? On Windows 2008 R2 and Oracle nothing of these workarounds work. The intstallation of the grid software went through, but the configuration skips after the checks of the nodes.
    Oracle Support gives a try to unset ORA_CRS_HOME, but this variable isn't set anywhere.

    I found a workaround: deinstall everything (clean properly !!!!) and install in 1 run (not first install and then configure).
    By Marion

    Edited by: 795442 on 26.01.2011 07:12
  • 7. Re: [INS-08109] Unexpected ... at state 'nodeSelectionPage'
    925030 Newbie
    Currently Being Moderated
    maybe the installation zip file is corrupted.check the checksum

    Edited by: user11876638 on 2012/03/20 18:49
  • 8. Re: [INS-08109] Unexpected ... at state 'nodeSelectionPage'
    932085 Newbie
    Currently Being Moderated
    for me this worked on rhel6
    (execute as root user)

    touch /etc/oraInst.loc
    echo inventory_loc=/opt/oracle/oraInventory/ >> /etc/oraInst.loc

    after that the INS-08109 disappeared
  • 9. Re: [INS-08109] Unexpected ... at state 'nodeSelectionPage'
    975865 Newbie
    Currently Being Moderated
    it was the same for me.
    thank you :)


  • Correct Answers - 10 points
  • Helpful Answers - 5 points