6 Replies Latest reply on Mar 6, 2013 3:19 PM by SPowell42

    Dynamic variable in 11g rpd - character 'd' got appended to default value

      Hi All,

      We have recently upgraded to version from obiee10g.

      We are facing an issue with default initializer in the dynamic variables in the RPD.

      For one of the dynamic variables XYZ_YEAR default value is '2013.0d' in 11g. In 10g for the same dynamic variable XYZ_YEAR default value is '2013'.

      As we are using this variable on the 11g dashboard the following error has been thrown -- A numeric value was expected (received "2013.0d")

      After the upgrade we are unable to do online changes to the RPD. That is another issue.
      So, coming back to the variable issue. I have taken a offline copy of the rpd and changed the default value of the variable to '2013.0'.

      And ported the offline rpd via EM. Initially, it seemed to be resolved. But, after sometime the dashboard got errored out with the same error.
      I went back to check the online rpd and saw the dynamic variable's default value as '2013.0d'

      I have tried making changes in offline rpd twice and ported the rpd via EM but the issue still persists.


      Edited by: obul on Nov 23, 2012 3:44 AM