3 Replies Latest reply: Nov 27, 2012 1:26 AM by HartmutStreppel RSS

    Solaris Cluster 4.1 installation error

    User368268
      Hi All,

      I am trying to install Solaris Cluster 4.1. When I execute the following command:

      # pkg install ha-cluster-full

      I get the following message:

      Creating Plan -
      pkg install: No solution was found to satisfy constraints

      maintained incorporations:

      pkg://solaris/consolidation/ldoms/ldoms-incorporation@0.5.11,5.11-0.175.0.0.0.1.0:20111012T230609Z
      pkg://solaris/consolidation/gfx/gfx-incorporation@0.5.11,5.11-0.175.0.0.0.2.0:20111019T144752Z
      pkg://solaris/consolidation/vpanels/vpanels-incorporation@0.5.11,5.11-0.175.0.0.0.1.778:20111012T230640Z
      pkg://solaris/consolidation/admin/admin-incorporation@0.5.11,5.11-0.175.0.0.0.2.0:20111019T144751Z
      pkg://solaris/consolidation/SunVTS/SunVTS-incorporation@0.5.11,5.11-0.172.0.0.0.0.0:20110816T071310Z
      pkg://solaris/consolidation/ub_javavm/ub_javavm-incorporation@0.5.11,5.11-0.175.0.0.0.2.0:20111019T144756Z
      pkg://solaris/consolidation/solaris_re/solaris_re-incorporation@0.5.11,5.11-0.175.0.0.0.2.0:20111019T122734Z
      pkg://solaris/consolidation/cacao/cacao-incorporation@0.5.11,5.11-0.174.0.0.0.0.0:20110921T190516Z
      pkg://solaris/consolidation/jdmk/jdmk-incorporation@0.5.11,5.11-0.173.0.0.0.0.0:20110828T210111Z
      pkg://solaris/consolidation/nvidia/nvidia-incorporation@0.5.11,5.11-0.175.0.0.0.0.0:20110927T192422Z
      pkg://solaris/consolidation/dbtg/dbtg-incorporation@0.5.11,5.11-0.175.0.0.0.2.0:20111019T144751Z
      pkg://solaris/consolidation/ips/ips-incorporation@0.5.11,5.11-0.175.0.0.0.2.2576:20111020T063559Z
      pkg://solaris/consolidation/cde/cde-incorporation@0.5.11,5.11-0.175.0.0.0.0.0:20110927T191905Z
      pkg://solaris/consolidation/osnet/osnet-incorporation@0.5.11,5.11-0.175.0.0.0.2.1:20111019T053010Z
      pkg://solaris/consolidation/man/man-incorporation@0.5.11,5.11-0.175.0.0.0.0.0:20110927T192523Z
      pkg://solaris/consolidation/desktop/desktop-incorporation@0.5.11,5.11-0.175.0.0.0.2.0:20111019T132128Z
      pkg://solaris/consolidation/l10n/l10n-incorporation@0.5.11,5.11-0.175.0.0.0.1.765:20111012T043917Z
      pkg://solaris/consolidation/X/X-incorporation@0.5.11,5.11-0.175.0.0.0.0.1215:20110927T121319Z
      pkg://solaris/consolidation/sic_team/sic_team-incorporation@0.5.11,5.11-0.172.0.0.0.0.0:20110816T070737Z
      pkg://solaris/consolidation/userland/userland-incorporation@0.5.11,5.11-0.175.0.0.0.2.537:20111019T091357Z
      pkg://solaris/consolidation/sunpro/sunpro-incorporation@0.5.11,5.11-0.174.0.0.0.0.0:20110921T184135Z
      pkg://solaris/entire@0.5.11,5.11-0.175.0.0.0.2.0:20111020T143822Z
      pkg://solaris/consolidation/cns/cns-incorporation@0.5.11,5.11-0.175.0.0.0.1.0:20111012T230319Z
      pkg://solaris/consolidation/nspg/nspg-incorporation@0.5.11,5.11-0.175.0.0.0.2.0:20111019T144753Z
      pkg://solaris/consolidation/install/install-incorporation@0.5.11,5.11-0.175.0.0.0.2.1482:20111019T122620Z
      pkg://solaris/consolidation/xvm/xvm-incorporation@0.5.11,5.11-0.175.0.0.0.2.0:20111019T144757Z
      pkg://solaris/consolidation/desktop/gnome-incorporation@0.5.11,5.11-0.175.0.0.0.2.0:20111019T132130Z
      pkg://solaris/consolidation/sfw/sfw-incorporation@0.5.11,5.11-0.175.0.0.0.2.0:20111019T144754Z

      Plan Creation: dependency error(s) in proposed packages:

      No suitable version of required package pkg://ha-cluster/ha-cluster/group-package/ha-cluster-full@4.1,5.11-0.18.2:20121001T203917Z found:
      Reject: pkg://ha-cluster/ha-cluster/group-package/ha-cluster-full@4.1,5.11-0.18.2:20121001T203917Z
      Reason: All versions matching 'require' dependency pkg:/ha-cluster/group-package/ha-cluster-minimal are rejected
      Reject: pkg://ha-cluster/ha-cluster/group-package/ha-cluster-minimal@4.1,5.11-0.18.2:20121001T203920Z
      Reason: All versions matching 'require' dependency pkg:/ha-cluster/group-package/ha-cluster-incorporation are rejected
      Reject: pkg://ha-cluster/ha-cluster/group-package/ha-cluster-incorporation@4.1,5.11-0.18.2:20121001T203920Z
      Reason: All versions matching 'require' dependency pkg:/system/core-os@0.5.11,5.11-0.175.1 are rejected
      Reject: pkg://solaris/system/core-os@0.5.11,5.11-0.175.1.0.0.24.2:20120919T184646Z
      Reason: This version is excluded by installed incorporation pkg://solaris/consolidation/osnet/osnet-incorporation@0.5.11,5.11-0.175.0.0.0.2.1:20111019T053010Z

      Has anyone come across this error?
      Regards,
        • 1. Re: Solaris Cluster 4.1 installation error
          T.F.
          It looks like the system is installed with Solaris 11. But in order to install Oracle Solaris Cluster 4.1, you need to update to Solaris 11.1 first.

          Regards
          Thorsten
          • 2. Re: Solaris Cluster 4.1 installation error
            User368268
            Hi,

            Thanks for the reply. I have applied the latest SRU. Details are:

            root@solaris:~# pkg info entire
            Name: entire
            Summary: entire incorporation including Support Repository Update (Oracle Solaris 11 11/11 SRU 13.4).
            Description: This package constrains system package versions to the same
            build. WARNING: Proper system update and correct package
            selection depend on the presence of this incorporation.
            Removing this package will result in an unsupported system. For
            more information see https://support.oracle.com/CSP/main/article
            ?cmd=show&type=NOT&doctype=REFERENCE&id=1372094.1.
            Category: Meta Packages/Incorporations
            State: Installed
            Publisher: solaris
            Version: 0.5.11 (Oracle Solaris 11 SRU 13.4)
            Build Release: 5.11
            Branch: 0.175.0.13.0.4.0
            Packaging Date: Tue Nov 06 19:46:23 2012
            Size: 5.45 kB
            FMRI: pkg://solaris/entire@0.5.11,5.11-0.175.0.13.0.4.0:20121106T194623Z


            root@solaris:~# pkg set-publisher -G '*' -g file:///screpo ha-cluster

            root@solaris:~# beadm list
            BE Active Mountpoint Space Policy Created
            -- ------ ---------- ----- ------ -------
            solaris - - 35.14M static 2011-11-03 18:15
            solaris-1 NR / 6.68G static 2012-11-27 07:26

            root@solaris:~# pkg publisher
            PUBLISHER TYPE STATUS URI
            solaris origin online file:///export/repoSolaris11/
            ha-cluster origin online file:///screpo/

            The error persists:

            root@solaris:~# pkg install ha-cluster-framework-full
            Creating Plan -
            pkg install: No solution was found to satisfy constraints

            maintained incorporations:

            pkg://solaris/consolidation/gfx/gfx-incorporation@0.5.11,5.11-0.175.0.0.0.2.0:20111019T144752Z
            pkg://solaris/consolidation/man/man-incorporation@0.5.11,5.11-0.175.0.0.0.0.0:20110927T192523Z
            pkg://solaris/consolidation/admin/admin-incorporation@0.5.11,5.11-0.175.0.0.0.2.0:20111019T144751Z
            pkg://solaris/consolidation/SunVTS/SunVTS-incorporation@0.5.11,5.11-0.175.0.7.0.3.0:20120421T004225Z
            pkg://solaris/consolidation/solaris_re/solaris_re-incorporation@0.5.11,5.11-0.175.0.0.0.2.0:20111019T122734Z
            pkg://solaris/consolidation/cacao/cacao-incorporation@0.5.11,5.11-0.175.0.6.0.1.0:20120323T204721Z
            pkg://solaris/consolidation/jdmk/jdmk-incorporation@0.5.11,5.11-0.173.0.0.0.0.0:20110828T210111Z
            pkg://solaris/consolidation/nvidia/nvidia-incorporation@0.5.11,5.11-0.175.0.0.0.0.0:20110927T192422Z
            pkg://solaris/consolidation/dbtg/dbtg-incorporation@0.5.11,5.11-0.175.0.0.0.2.0:20111019T144751Z
            pkg://solaris/consolidation/ips/ips-incorporation@0.5.11,5.11-0.175.0.11.0.4.0:20120830T143219Z
            pkg://solaris/consolidation/cde/cde-incorporation@0.5.11,5.11-0.175.0.0.0.0.0:20110927T191905Z
            pkg://solaris/consolidation/osnet/osnet-incorporation@0.5.11,5.11-0.175.0.13.0.4.1:20121106T193122Z
            pkg://solaris/consolidation/vpanels/vpanels-incorporation@0.5.11,5.11-0.175.0.0.0.1.778:20111012T230640Z
            pkg://solaris/consolidation/desktop/desktop-incorporation@0.5.11,5.11-0.175.0.12.0.4.0:20121002T161024Z
            pkg://solaris/consolidation/l10n/l10n-incorporation@0.5.11,5.11-0.175.0.12.0.2.110:20120914T170159Z
            pkg://solaris/consolidation/X/X-incorporation@0.5.11,5.11-0.175.0.12.0.2.1233:20120914T170555Z
            pkg://solaris/consolidation/sic_team/sic_team-incorporation@0.5.11,5.11-0.172.0.0.0.0.0:20110816T070737Z
            pkg://solaris/consolidation/userland/userland-incorporation@0.5.11,5.11-0.175.0.13.0.4.0:20121106T193940Z
            pkg://solaris/consolidation/sunpro/sunpro-incorporation@0.5.11,5.11-0.175.0.11.0.3.0:20120824T162258Z
            pkg://solaris/entire@0.5.11,5.11-0.175.0.13.0.4.0:20121106T194623Z
            pkg://solaris/consolidation/cns/cns-incorporation@0.5.11,5.11-0.175.0.10.0.4.0:20120731T142644Z
            pkg://solaris/consolidation/nspg/nspg-incorporation@0.5.11,5.11-0.175.0.0.0.2.0:20111019T144753Z
            pkg://solaris/consolidation/install/install-incorporation@0.5.11,5.11-0.175.0.13.0.3.0:20121026T213105Z
            pkg://solaris/consolidation/xvm/xvm-incorporation@0.5.11,5.11-0.175.0.0.0.2.0:20111019T144757Z
            pkg://solaris/consolidation/desktop/gnome-incorporation@0.5.11,5.11-0.175.0.12.0.4.0:20121002T161026Z
            pkg://solaris/consolidation/sfw/sfw-incorporation@0.5.11,5.11-0.175.0.0.0.2.0:20111019T144754Z

            Plan Creation: dependency error(s) in proposed packages:

            No suitable version of required package pkg://ha-cluster/ha-cluster/group-package/ha-cluster-framework-full@4.1,5.11-0.18.2:20121001T203914Z found:
            Reject: pkg://ha-cluster/ha-cluster/group-package/ha-cluster-framework-full@4.1,5.11-0.18.2:20121001T203914Z
            Reason: All versions matching 'require' dependency pkg:/ha-cluster/library/ucmm are rejected
            Reject: pkg://ha-cluster/ha-cluster/library/ucmm@4.1,5.11-0.18.2:20121001T203928Z
            Reason: All versions matching 'require' dependency pkg:/ha-cluster/group-package/ha-cluster-incorporation are rejected
            Reject: pkg://ha-cluster/ha-cluster/group-package/ha-cluster-incorporation@4.1,5.11-0.18.2:20121001T203920Z
            Reason: A version for 'require' dependency on pkg:/system/core-os@0.5.11,5.11-0.175.1 cannot be found
            • 3. Re: Solaris Cluster 4.1 installation error
              HartmutStreppel
              Hi,
              Solaris 11 11/11 with SRU13 is not Solaris 11.1, but this is what Solaris Cluster 4.1 needs. One of the last lines below:

              Reject: pkg://solaris/system/core-os@0.5.11,5.11-0.175.1.0.0.24.2:20120919T184646Z

              points to Solaris 11.1 (0.175.1.0.0.24.2).

              And I must admit that the IPS error messages are not really helpful.
              Hartmut