5 Replies Latest reply: Dec 7, 2012 6:58 AM by skulll.r RSS

    Topology problem


      I have error I think relative to Topology.
      Semulation does not even pass, the same error.
      This is Interfese between two DB.

      com.sunopsis.tools.core.exception.SnpsSimpleMessageException: ODI-17517: Error during task interpretation.
      Task: 4
      java.lang.Exception: BeanShell script error: Sourced file: inline evaluation of: ``out.print("drop synonym DOC_LOAD.\"C$_") ; out.print(vPref) ; out.print("_0SRC_D . . . '' : Undefined argument: vPref : at Line: 2 : in file: inline evaluation of: ``out.print("drop synonym DOC_LOAD.\"C$_") ; out.print(vPref) ; out.print("_0SRC_D . . . '' : ( vPref )
      BSF info: Drop synonym on target at line: 0 column: columnNo
           at com.sunopsis.dwg.codeinterpretor.SnpCodeInterpretor.transform(SnpCodeInterpretor.java:485)

      Any ideas?
        • 1. Re: Topology problem
          A. Drieux

          Can you provide us more details ?

          Which DB exactly ? (oracle, SQL Server, DB2...)
          Which LKM and IKM do you use in your interface ?

          When this errors occurs ? Just after clicking on "execute" ? Or during a step of the session ?
          • 2. Re: Topology problem
            I use two Oracle 11.2 DB on Solaris.
            I use standart LKM Oracle to Oracle and IKM Oracle Increment Update (Merge).

            It occurs just before first on step Flow (Interface) Order number: 0
            • 3. Re: Topology problem
              Bhabani Ranjan
              I guess there is some modification in your KM. If it is not delete the existing km and import fresh KM. Check it now.
              • 4. Re: Topology problem
                Deleted and imported KMs onemore time and the same error.

                My build is ODI_11. Maybe it's time to update.

                I have 2 of all topology, 2 logical and physical schemas because of 2 developers groups. If I use our topology I have error If I chenge another topology as I need it works. But I cannot use another topology though our topology is absolutely the same just have another name, but it doesn't work!
                • 5. Re: Topology problem
                  I solved the problem.

                  I've just recreated the Interface.
                  I noticed that if you have changed something in topoloty and your have smtrange error in your interface, the only way is recreate interface, any other things don't work!