2 Replies Latest reply: Nov 26, 2012 4:01 PM by NorbertB RSS

    Event sounds missing after upgrading from Solaris 11 to Solaris 11.1

    NorbertB
      "Sound Preferences" = "Volume Control", i.e. Playback, Recording, Options, "Sound Theme" is unchanged since Solaris 11.
      I can play back all the sounds in the /usr/share/sounds sub-directories with "play".
      Sound itself (e.g. playing back external sources from Browser) works fine.

      In "Sound Theme", whatever combination I choose under "Sound theme", alert sound, "Enable window and button sounds": There are no event sounds.
      The only thing I can get is a "Keyboard Beep" if I activate it in "Volume Control"-->"Options".
      Because I don't like the quacking sound of that, and want a reasonable alert sound at least, I turned on the good old X11 bell with: xset b 100 3200 50.

      I was surprised, when I discovered, that the volume of the X11 beep can be controlled now by the "Keyboard Beep" slider in "Volume Control". In former versions of Solaris I could hear all three sounds at the same time, when all three were turned on. After having played some arbitrary sound from an external source, the beep seems to be twofold too, for a while or a number of beeps. It sounds, as if there is the X11 beep and the "drip", chosen as event sound, but impacted by the frequency choice of X11 beep.
      Any ideas, what's going on?

      Edited by: 951921 on Nov 7, 2012 2:20 PM

      Edited by: 951921 on Nov 8, 2012 6:55 AM
        • 1. Re: Event sounds missing after upgrading from Solaris 11 to Solaris 11.1
          NorbertB
          I solved the problem as follows:
          1. In my home directory i removed all resource files (dot-files, xml-files in dot-directories), having to do with sound (ls, grep), except those in application-directories (like ".mozilla"), and except the file ".pulse-cookie".
          2. I logged out and in again.
          3. In "Volume Control" (sound preferences) I newly set alert sound (sound theme) and keyboard beep (options).
          3a. There are three alert sounds at the same time after this.
          4. I muted keyboard beep in "Volume Control" (two sounds remain).
          5. In .bash_profile I included the following:
          if [ $TERM = xterm ]; then
          xset b off
          fi
          The chosen alert sound remains.

          Edited by: 951921 on Nov 18, 2012 5:25 PM
          • 2. Re: Event sounds missing after upgrading from Solaris 11 to Solaris 11.1
            NorbertB
            The problem came back after plugging a stereo sound recording webcam (Logitech C910) into an usb socket and playing around with "volume control" to make it record sound (which did not work).
            Therefore (though still not completely sure) I can state more precisely the first step of my recent post:
            rm -r .gconf/desktop/gnome/sound .gconf/apps/gnome-volume-control .pulse
            I also booted between steps 1. and 2., but think, this is not necessary.