1 2 Previous Next 19 Replies Latest reply on Nov 27, 2012 7:58 PM by 578233 Go to original post
      • 15. Re: MDS NameError: sca_removeSharedData
        The offline function sca_removeSharedData() removes folders under /apps
        The online function deleteMetadata() removes files under folders.

        Inorder to remove the root folders, you can login to MDS schema and in MDS_PATHS find your folder path '/xsd' and delete that entry from that table.
        Then refresh your MDS to check whether the folder still available or not.
        I hope it should not be there.

        It is considered good etiquette to reward answerers with points (as "helpful" - 5 pts - or "correct" - 10pts).

        • 16. Re: MDS NameError: sca_removeSharedData
          Hi Vijay,

          Finally i am able to delete the folder xsd from back end. i feel it is good to do this one with out touching database.

          Thanks for the support.

          • 17. Re: MDS NameError: sca_removeSharedData
            Hi Tarak,
            Can you please share how did you remove root level folder from MDS without touching database.

            thanks in advace...
            • 18. Re: MDS NameError: sca_removeSharedData
              Hi Hakim,

              I feel Without touch the database i think i we cannot do it. As i at last ended with going to database

              For example in my case my root folder is apps. And this one i am not able to remove through weblogic command but if i remove it from backend then it is gone.

              Apart of this subfolders your want to remove it then you can use below one. I know this is not exactly you looking for but still i feel like it may help to you.

              Got to:- /u01/app/soadev/product/fmw11/middleware/Oracle_SOA1/common/bin

              And run wlst.sh file then connect as below


              to delete only file inside the folder then deleteMetadata(application='soa-infra',server='soa_server1',docs='/apps/MDS/XSD/ItemDesc.xsd')

              This is for offline command how ever it worked online also be me.. Strange

              sca_removeSharedData('hostname:port','xsd','weblogic','Soa_s132')----------- this removes xsd folder under apps folder. But default this function considers apps as a root directory.

              Let me know if need any information from my side

              • 19. Re: MDS NameError: sca_removeSharedData
                Thanks Tarak...I tried database trick and it worked.

                However your reply was very helpful..good luck.
                1 2 Previous Next