4 Replies Latest reply: Nov 29, 2012 2:05 AM by JaydeepNandy RSS

    Not able to install 11.2.0.3 on OEL 6.3 x86_64

    JaydeepNandy
      Hi,
      I originally hijacked another forum thread that was vaguely similar toy what I seem to be experiencing. A kind forum moderator has split my post away and put a more descriptive title to it, to let it stand on its own. (... and moved it from the Oracle Linux forum to the Database Installation forum for closer topic alignment)

      Here's my post:


      .
      I'm trying to install 11.2.0.3 on OEL 6.3 x86_64. But, getting error:

      [root@ecsrac2 Packages]# rpm -ivh glibc-2.12-1.80.el6.i686.rpm
      warning: glibc-2.12-1.80.el6.i686.rpm: Header V3 RSA/SHA256 Signature, key ID ec551f03: NOKEY
      error: Failed dependencies:
      libfreebl3.so is needed by glibc-2.12-1.80.el6.i686
      libfreebl3.so(NSSRAWHASH_3.12.3) is needed by glibc-2.12-1.80.el6.i686
      [root@ecsrac2 Packages]# uname -a
      Linux ecsrac2.ecsims.com 2.6.39-200.24.1.el6uek.x86_64 #1 SMP Sat Jun 23 02:39:07 EDT 2012 x86_64 x86_64 x86_64 GNU/Linux

      Any help will be appreciated.

      Thanks.
        • 1. Re: Not able to install 11.2.0.3 on OEL 6.3 x86_64
          sb92075
          user1225187 wrote:
          Hi,
          I originally hijacked another forum thread that was vaguely similar toy what I seem to be experiencing. A kind forum moderator has split my post away and put a more descriptive title to it, to let it stand on its own. (... and moved it from the Oracle Linux forum to the Database Installation forum for closer topic alignment)

          Here's my post:


          .
          I'm trying to install 11.2.0.3 on OEL 6.3 x86_64. But, getting error:

          [root@ecsrac2 Packages]# rpm -ivh glibc-2.12-1.80.el6.i686.rpm
          warning: glibc-2.12-1.80.el6.i686.rpm: Header V3 RSA/SHA256 Signature, key ID ec551f03: NOKEY
          error: Failed dependencies:
          libfreebl3.so is needed by glibc-2.12-1.80.el6.i686
          libfreebl3.so(NSSRAWHASH_3.12.3) is needed by glibc-2.12-1.80.el6.i686
          [root@ecsrac2 Packages]# uname -a
          Linux ecsrac2.ecsims.com 2.6.39-200.24.1.el6uek.x86_64 #1 SMP Sat Jun 23 02:39:07 EDT 2012 x86_64 x86_64 x86_64 GNU/Linux

          Any help will be appreciated.

          Thanks.
          find / -name libfree\* -print 2>/dev/null

          post results from OS command above that can take many minutes to complete
          • 2. Re: Not able to install 11.2.0.3 on OEL 6.3 x86_64
            Avi Miller-Oracle
            user1225187 wrote:
            I'm trying to install 11.2.0.3 on OEL 6.3 x86_64. But, getting error:
            Don't use RPM to install packages, use yum. It'll solve the dependency issues you're seeing. Also, the thread that you hijacked actually had the correct answer in it, which you seem to have ignored in your haste to post:
            # yum install oracle-rdbms-server-11gR2-preinstall
            If you are subscribed to ULN or public-yum.oracle.com (which OL6U3 is by default), this will automatically install the pre-requisite RPMs for Oracle Database 11.2.0.3 and configure all the user and sysctl.conf settings required for the OUI:

            http://www.oracle.com/technetwork/articles/servers-storage-admin/ginnydbinstallonlinux6-1845247.html
            https://blogs.oracle.com/linux/entry/oracle_rdbms_server_11gr2_pre
            • 3. Re: Not able to install 11.2.0.3 on OEL 6.3 x86_64
              JaydeepNandy
              Please find it below the result. Is it the missing i686 version? Please guide me to find the appropriate RPMs for it.


              [root@ecsrac1 ~]# find / -name libfree\* -print 2>/dev/null
              /usr/lib64/libfreebl3.chk
              /usr/lib64/libfreebl.a
              /usr/lib64/libfreetype.so.6.3.22
              /usr/lib64/libfreetype.so
              /usr/lib64/libfreebl3.so
              /usr/lib64/libfreetype.so.6
              /lib64/libfreebl3.chk
              /lib64/libfreebl3.so


              Thanks.
              • 4. Re: Not able to install 11.2.0.3 on OEL 6.3 x86_64
                JaydeepNandy
                Hi "sb92075",

                Thanks for the pointer. Issue got resolved - I could find and install both RPMs together to avoid deadlock in dependency...

                [root@labrac1 Packages]# rpm -ivh nss-softokn-freebl-3.12.9-11.el6.i686.rpm glibc-2.12-1.80.el6.i686.rpm
                warning: nss-softokn-freebl-3.12.9-11.el6.i686.rpm: Header V3 RSA/SHA256 Signature, key ID ec551f03: NOKEY
                Preparing... ########################################### [100%]
                1:glibc ########################################### [ 50%]
                2:nss-softokn-freebl ########################################### [100%]

                Thank you Avi for your suggestion on YUM - being a test setup, this box is not yet exposed to Internet.

                Thanks.