3 Replies Latest reply on Dec 3, 2012 9:20 AM by khash

    grub prompt after reboot Solaris 11.1

      I installed Solaris 11.1 (text install) the other day. Everything appeared to go well until I rebooted the system. Instead of getting the grub menu I got the grub prompt. Can't get past it. I thought I did something wrong during the install so I installed again, got the same results. Perhaps someone can tell me what I'm doing wrong? Details of how I installed below:

      Before entering the text installer I dropped to a command prompt, and using fdisk setup a single partition on the drive. Then using format I allocated 32gig to slice 0 (this will be the rpool). Left the remaining space unallocated and didn't change any of the other slices. Then I proceeded with the text installer, making sure to select slice 0 for the rpool. Installation proceeded fine, and the initial fast reboot after install went fine. Its not until I do a full reboot that I get the grub prompt - but I can't get past it once I do.

      I eventually decided to allocate the entire disk to the rpool. Everything works fine if I do that. But I don't want a 1 gig rpool. I'd prefer to have a 32 gig rpool and use the remaining disk space for a send pool. Perhaps this isn't possible using a single disk and the entire disk should be allocated to the rpool?
        • 1. Re: grub prompt after reboot Solaris 11.1
          So I tried on a different PC and using the same install procedure worked as expected. Comparing the slice's the only difference I see is that on the failing PC slice 9 is allocated with 2 cylinders - 1 and 2 and slice 0 starts on cylinder 3. On the working PC, slice 9 is unassigned and slice 0 starts at cylinder 1.
          • 2. Re: grub prompt after reboot Solaris 11.1
            In desparation I overwrote the entire hard drive with zero's using DD from a Linux rescue disk. Re-installed Solaris 11.1, everything is fine. No idea what happened.
            • 3. Re: grub prompt after reboot Solaris 11.1
              (this has been edited several times since I was quite unhappy with my wording, also I did not find the time to verify everything exactly, so I just leave here what I think is true)

              The 11.1 format command, which is installed on disk now displays disk sectors instead of cylinders.

              What more has changed:

              In 11.0 and previous versions slice #0 is tagged as "root", started from cylinder 1 and it contains the rpool. <=> In 11.1 slice 0 it is tagged as "system" and is only 256MB large.
              In 11.0 and previous the next assigned slice was slice #2, the backup slice which comprised the whole disk (slice #1 was unassigned) <=> In 11.1 the next assigned slice is slice #1 which is tagged usr.
              In 11.0 and previous slice #8 was tagged "boot" and used cylinder 0 of the disk <=> in 11.1 slice 8 is tagged "reserved" and uses the last 8MB at the tail of the disk.

              Now where is the rpool in 11.1 ? In my case zpool status shows, that rpool is using device c8t0d0 and not anymore c8t0d0s0.

              So what do we learn: the intention to resize rpool does not make sense, it is already using the whole disk.
              It is not identical to the size of slice #0 anymore.

              The format command should take care of these new disk areas, but if formatting the disk with an old version
              (probably an old version shipped erroneously on installation media) you can destroy these disk areas.

              But what happens to the disk if someone upgrades from 11.0 to 11.1 ?

              This is a disk that was used by 11.0 and was upgraded to 11.1, the disk layout still matches that of 11.0
              but the last 2 cylinders of the disk are not anymore assigned to the root slice.

              Part Tag Flag Cylinders Size Blocks
              0 root wm 1 - 60797 465.73GB (60797/0/0) 976703805
              1 unassigned wm 0 0 (0/0/0) 0
              2 backup wu 0 - 60799 465.75GB (60800/0/0) 976752000
              3 unassigned wm 0 0 (0/0/0) 0
              4 unassigned wm 0 0 (0/0/0) 0
              5 unassigned wm 0 0 (0/0/0) 0
              6 unassigned wm 0 0 (0/0/0) 0
              7 unassigned wm 0 0 (0/0/0) 0
              8 boot wu 0 - 0 7.84MB (1/0/0) 16065
              9 unassigned wm 0 0 (0/0/0) 0

              As I said, this disk is the result of a 11.0 installation and displays the state after an upgrade.
              It looks different if one installs 11.1 from scratch.
              But obviously there are several ways to install 11.1 on disk, the new disk layout or the old slightly
              changed disk layout, both work and are used. The old layout is obviously easier to comprehend to
              Solaris admins.