This discussion is archived
3 Replies Latest reply: Dec 11, 2012 1:11 AM by moslee RSS

ORA-00979: not a GROUP BY expression after migrate from to

moslee Newbie
Currently Being Moderated
Hi to all

I have several View object in oracle and they worked fine. After doing a full import into Oracle, these views objects encountered "ORA-00979: not a GROUP BY expression". Tried recompiling all dependencies successfully but these views just couldn't do likewise.

I have refer to Oracle document ID 814423.1 and 8260094. I have tried the workaround as suggested:

1. Set replacevirtual_columns to false.

2. If the same problem still reports then, Set optimizergroup_by_placement to false instead of replacevirtual_columns.

However, these views are still having the error. Does anybody know what's the next step for me?

I can post the View scripts here, but there are several of them and I seriously don't think it is a PL/SQL issue (that explains why I post it as a Database - Upgrade thread). Thanks.


  • Correct Answers - 10 points
  • Helpful Answers - 5 points