1 Reply Latest reply: Apr 12, 2013 9:52 AM by Kirill Loifman RSS

    TNS-1190 despite listener password


      we are migrating from em 11g to em 12c. Now we are getting listener error TNS-1190 "trc_directory (TNS-1190),. Please check log for details. ". As per note 1399060.1 I set listener password and changed "Monitoring Configuration" in oms but the same error still occurs.

      When I execute "show trc_directory" from shell everything works fine:
      oracle@orarac11g:~ $ lsnrctl
      LSNRCTL for Solaris: Version - Production on 03-DEC-2012 09:48:37
      Copyright (c) 1991, 2011, Oracle.  All rights reserved.
      Welcome to LSNRCTL, type "help" for information.
      LSNRCTL> show trc_directory
      Connecting to (ADDRESS=(PROTOCOL=tcp)(HOST=)(PORT=1521))
      TNS-01190: The user is not authorized to execute the requested listener command
      LSNRCTL> set password
      The command completed successfully
      LSNRCTL> show trc_directory
      Connecting to (ADDRESS=(PROTOCOL=tcp)(HOST=)(PORT=1521))
      LISTENER parameter "trc_directory" set to /oraclebin/app/gridbase11.2/diag/tnslsnr/orarac11g/listener/trace
      The command completed successfully
      Does anybody have the same error?

      Thanks in advance
        • 1. Re: TNS-1190 despite listener password
          Kirill Loifman
          I suggest first check you listener log. If you still see messages "trc_directory * 1190", you have not fixed the problem with your listener password.
          If you setup the listener password properly on the server, you need then to place it in the listener config on OEM side.
          Go to Listener Menu ->Target Setup -> Monitoring Configuration and place the password in "Listener Password" field. Then save the config.
          and see again. if it does not help try to reboot the agent.

          Kirill Loifman, dadbm.com

          Edited by: Kirill Loifman on Jan 14, 2013 1:40 AM

          Edited by: Kirill Loifman on Apr 12, 2013 7:51 AM