This discussion is archived
10 Replies Latest reply: Dec 12, 2012 8:00 AM by IHodgetts RSS

Problems with OATS Upgrade (to v12.2.0.1.223)

IHodgetts Explorer
Currently Being Moderated
Has anyone else had issues with the latest update (v12.2.0.1.223)?

My initial attempts at upgrading resulted in being unable to start OpenScript (apparently due to some issue with Eclipse?) and the OLT agent failing to start.

I've ended up trying a "clean uninstall" (the irony of recently posting on this subject to help someone else isn't lost on me) and now at least have OpenScript working, but the OLT agent is still failing to start.

The logs point to issues with Eclipse again:

e.g. in the process_console log

Configuration location:
file:/C:/WINDOWS/TEMP/tmpdir2240542030259414885/
Configuration file:
file:/C:/WINDOWS/TEMP/tmpdir2240542030259414885/config.ini loaded
Install location:
file:/C:/OracleATS/agent/
Framework located:
file:/C:/OracleATS/agent/plugins/org.eclipse.osgi_3.4.3.R34x_v20081215-ospatch120211.jar
Loading extension: oracle.oats.jagent.osgi.adapters
     eclipse.properties not found
Framework classpath:
file:/C:/OracleATS/agent/plugins/org.eclipse.osgi_3.4.3.R34x_v20081215-ospatch120211.jar
file:/C:/OracleATS/agent/plugins/
file:/C:/OracleATS/agent/plugins/oracle.oats.jagent.osgi.adapters_2.8.0.223.jar
Debug options:
file:/C:/OracleATS/agent/.options not found
Time to load bundles: 359
Starting application: 23750
Agent shutting down


e.g. in the java_agent.log

2012-11-27 10:10:27,312 ERROR [Main Thread][oracle.oats.jagent.applications.eload.Application] Error
java.lang.NoClassDefFoundError: oracle/oats/common/estimation/monitoring/listener/HardwareEstimationMonitorListener
     at oracle.oats.jagent.EntryPoint.start(EntryPoint.java:144)
     at oracle.oats.jagent.EntryPoint.main(EntryPoint.java:181)
     at oracle.oats.jagent.applications.eload.Application.runMain(Application.java:40)
     at oracle.oats.jagent.applications.common.JAgentApplication.run(JAgentApplication.java:26)
     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
     at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
     at java.lang.reflect.Method.invoke(Method.java:597)
     at org.eclipse.equinox.internal.app.EclipseAppContainer.callMethodWithException(EclipseAppContainer.java:574)
     at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:195)
     at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
     at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
     at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:386)
     at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
     at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
     at java.lang.reflect.Method.invoke(Method.java:597)
     at org.eclipse.core.launcher.Main.invokeFramework(Main.java:336)
     at org.eclipse.core.launcher.Main.basicRun(Main.java:280)
     at org.eclipse.core.launcher.Main.run(Main.java:977)
     at org.eclipse.core.launcher.Main.main(Main.java:952)
     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
     at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
     at java.lang.reflect.Method.invoke(Method.java:597)
     at oracle.oats.jagent.EntryPointWrapper.main(Unknown Source)
  • 1. Re: Problems with OATS Upgrade (to v12.2.0.1.223)
    Anuj Khattri Newbie
    Currently Being Moderated
    Hello,
    I am also facing a similar kind of issue after installing the v12.2.0.1.223.

    I have tried making a clean installation, but still facing the same error while running any load test.

    *"Error communicating with Oracle Load Testing Agent Manager on oats-am://localhost:9001"*

    agentmanager_auth.log

    2012-12-03 11:28:58,084 INFO [URL:t3://ESP50WS19548.crb.apmoller.net:8088;Requestor Username: oats-agent;Requestor Key:88c37e8b-4b51-4777-9ded-fa1b734d4335;Requestor Queue:oracle/oats/queue/AgentPoolNotificationQueue;Request ID:4;Request:stopagent;] - authentication successful

    wls_oats.log

    2012-12-03 11:18:13,439 WARN [OracleActionBase] Starting autopilot
    2012-12-03 11:18:13,595 WARN [OracleActionBase] Started autopilot
    2012-12-03 11:19:45,421 WARN [AgentPoolCont] Orphaning agent agId2_rndb9c30065-0302-4f12-b8b1-a7806379cb74: Error communicating with Oracle Load Testing Agent Manager on oats-am://localhost:9001: Timed out after 90 seconds.
    2012-12-03 11:19:45,421 WARN [AgentPoolCont] Issuing a forced stop for agentagId2_rndb9c30065-0302-4f12-b8b1-a7806379cb74
    2012-12-03 11:19:46,421 ERROR [ConsoleEngine] java.io.FileNotFoundException: C:\OracleATS\oats\..\config\session-configs.properties (The system cannot find the file specified)
    2012-12-03 11:27:27,726 WARN [OracleActionBase] Starting autopilot
    2012-12-03 11:27:27,726 WARN [OracleActionBase] Started autopilot
    2012-12-03 11:28:58,037 WARN [AgentPoolCont] Orphaning agent agId12_rnd8e44c8bc-63f0-4c31-8681-d91936639c77: Error communicating with Oracle Load Testing Agent Manager on oats-am://localhost:9001: Timed out after 90 seconds.
    2012-12-03 11:28:58,037 WARN [AgentPoolCont] Issuing a forced stop for agentagId12_rnd8e44c8bc-63f0-4c31-8681-d91936639c7*7*

    agentmanger.log

    Queue:oracle/oats/queue/AgentPoolNotificationQueue;Request ID:2;Request:stopagent;] - authentication successful
    11:19:45,593 ERROR [EmpStartMain] Unknown agent ID: agId2_rndb9c30065-0302-4f12-b8b1-a7806379cb74
    11:27:28,023 INFO [Messenger] Try server=t3://ESP50WS19548.crb.apmoller.net:8088 destination=oracle/oats/queue/AgentPoolNotificationQueue
    11:27:28,038 INFO [Messenger] Got ConnectionFactory
    11:27:28,038 INFO [Messenger] Got destination oracle/oats/queue/AgentPoolNotificationQueue
    11:27:28,038 INFO [Messenger] Created connection.
    11:27:28,038 INFO [Messenger] Created queue session.
    11:27:28,038 INFO [Messenger] Connected to server=t3://ESP50WS19548.crb.apmoller.net:8088 destination=oracle/oats/queue/AgentPoolNotificationQueue
    11:27:28,038 INFO [Request] [URL:t3://ESP50WS19548.crb.apmoller.net:8088;Requestor Username: oats-agent;Requestor Key:88c37e8b-4b51-4777-9ded-fa1b734d4335;Requestor Queue:oracle/oats/queue/AgentPoolNotificationQueue;Request ID:3;Request:startagent;] - authentication successful
    11:27:28,038 INFO [EmpStartMain] handleStartAgentRequestRequest ID: 3, RKey: 88c37e8b-4b51-4777-9ded-fa1b734d4335, RUrl: t3://ESP50WS19548.crb.apmoller.net:8088, RUsername: oats-agent, RQueue : oracle/oats/queue/AgentPoolNotificationQueue, Request: startagent, Agent Type: empJAgent.exe, Agent ID: agId12_rnd8e44c8bc-63f0-4c31-8681-d91936639c77, Agent Cmd : empJAgent.exe -classpath determinedAtRunTime oracle.oats.jagent.EntryPoint jms /token: /id:agId12_rnd8e44c8bc-63f0-4c31-8681-d91936639c77 /version:12.2.0.1.223 /clusterurl:t3://ESP50WS19548.crb.apmoller.net:8088 /clusterhttpurl:http://ESP50WS19548.crb.apmoller.net:8088 /pooltopic:oracle/oats/topic/AgentPoolControlTopic /poolqueue:oracle/oats/queue/AgentPoolNotificationQueue, Agent Checksum: [], Agent Credential Type: default, Version: 12.2.0.1.223
    11:27:28,038 INFO [SettingsHandler] extracted 'debug' command line params for null:
    11:27:28,038 INFO [ProcessRunner]
    startAgent(
    pathToExe=C:\OracleATS\jdk\jre\bin\olt-agent.exe
    cmdLineArgs= -XX:+HeapDumpOnOutOfMemoryError -jrockit -Xrs -XgcPrio:deterministic -XpauseTarget=50ms -XX:+UseCallProfiling -XX:+UseAdaptiveFatSpin -XX:+ExitOnOutOfMemoryError -XXnoSystemGC -XX:+UseFastTime -classpath ;C:\OracleATS\agent\jars\EntryPointWrapper.jar;C:\OracleATS\agent\jars\Framework.jar oracle.oats.jagent.EntryPointWrapper oracle.oats.jagent.EntryPoint -installdir C:\OracleATS\jdk\jre\..\.. jms /token: /id:agId12_rnd8e44c8bc-63f0-4c31-8681-d91936639c77 /version:12.2.0.1.223 /clusterurl:t3://ESP50WS19548.crb.apmoller.net:8088 /clusterhttpurl:http://ESP50WS19548.crb.apmoller.net:8088 /pooltopic:oracle/oats/topic/AgentPoolControlTopic /poolqueue:oracle/oats/queue/AgentPoolNotificationQueue
    workingDir=C:\OracleATS\agent
    agentId=agId12_rnd8e44c8bc-63f0-4c31-8681-d91936639c77
    requestor=88c37e8b-4b51-4777-9ded-fa1b734d4335), returning ID 1)
    11:27:28,038 INFO [EmpStartMain] Exception while starting agent
    java.lang.NoClassDefFoundError: oracle/oats/empstart/processrunner/windows/WindowsAgentProcess
         at oracle.oats.empstart.processrunner.solaris.AgentProcessFactory.newAgentProcess(AgentProcessFactory.java:13)
         at oracle.oats.empstart.processrunner.solaris.ProcessRunner.launchAgent(ProcessRunner.java:146)
         at oracle.oats.empstart.EmpStartMain.handleStartAgentRequest(EmpStartMain.java:712)
         at oracle.oats.empstart.EmpStartMain.handleRequest(EmpStartMain.java:1111)
         at oracle.oats.empstart.EmpStartMain.<init>(EmpStartMain.java:509)
         at oracle.oats.empstart.EmpStartMain.main(EmpStartMain.java:393)
         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
         at java.lang.reflect.Method.invoke(Method.java:597)
         at org.tanukisoftware.wrapper.WrapperSimpleApp.run(WrapperSimpleApp.java:105)
         at java.lang.Thread.run(Thread.java:662)
    11:28:58,069 INFO [Messenger] Try server=t3://ESP50WS19548.crb.apmoller.net:8088 destination=oracle/oats/queue/AgentPoolNotificationQueue
    11:28:58,069 INFO [Messenger] Got ConnectionFactory
    11:28:58,069 INFO [Messenger] Got destination oracle/oats/queue/AgentPoolNotificationQueue
    11:28:58,069 INFO [Messenger] Created connection.
    11:28:58,084 INFO [Messenger] Created queue session.
    11:28:58,084 INFO [Messenger] Connected to server=t3://ESP50WS19548.crb.apmoller.net:8088 destination=oracle/oats/queue/AgentPoolNotificationQueue
    11:28:58,084 INFO [Request] [URL:t3://ESP50WS19548.crb.apmoller.net:8088;Requestor Username: oats-agent;Requestor Key:88c37e8b-4b51-4777-9ded-fa1b734d4335;Requestor Queue:oracle/oats/queue/AgentPoolNotificationQueue;Request ID:4;Request:stopagent;] - authentication successful
    11:28:58,084 ERROR [EmpStartMain] Unknown agent ID: agId12_rnd8e44c8bc-63f0-4c31-8681-d91936639c77

    Any help is much appreciated.

    Regards
  • 2. Re: Problems with OATS Upgrade (to v12.2.0.1.223)
    IHodgetts Explorer
    Currently Being Moderated
    What OS is this on? Mine is on Windows Server 2003 (R2).

    I know that the downloaded install file itself is OK as I've got it working locally on my laptop (Windows 7). Unfortunately I need it working on our dedicated server. I'm currently in the process of attempting a fresh installation after following suggestions from Oracle Support to do clean un-installs of both Oracle 11g (EE) database and OATS itself.

    Have you tried following the "clean un-install" instructions in the release notes (section 4)?

    The other document that was suggested by Oracle Support was the following:

    https://support.oracle.com/epmos/faces/ui/km/SearchDocDisplay.jspx?_afrLoop=5432877241186&type=DOCUMENT&id=1470689.1&displayIndex=2&_afrWindowMode=0&_adf.ctrl-state=1de3xap7vu_149

    (this took longer than I anticipated)

    Hopefully I'll have some good news on this later on today...
  • 3. Re: Problems with OATS Upgrade (to v12.2.0.1.223)
    Anuj Khattri Newbie
    Currently Being Moderated
    Hello,
    I have tried it both on a Win7 machine and Win XP Laptop.
    Experiencing the same issue on both the machines.

    Yes, I have tried a clean un-install but no help.

    Regards
  • 4. Re: Problems with OATS Upgrade (to v12.2.0.1.223)
    IHodgetts Explorer
    Currently Being Moderated
    Unfortunately it's bad news all round. Having completed a fresh install of both OATS and Oracle11gEE I'm back to my original problem.

    Although OpenScript and OLT loads, I am unable to start a single VU as the OLT agent fails with the "Unexpected Agent exit. Code = 0".
  • 5. Re: Problems with OATS Upgrade (to v12.2.0.1.223)
    IHodgetts Explorer
    Currently Being Moderated
    Just an update for AnujK really:

    There is a patch available (v12.2.0.1.238) which should address this issue. However, during the installation I encountered an error (looks like a password has expired somewhere?). The install completed "successfully" but I appear to now have a different issue (presumably due to the error indicated). I'm not sure what password is being referred to (as the DB shouldn't have changed). I can only assume it's the Windows account (which was refreshed recently) and possibly there was as issue (re-)starting a service?

    It may be worth trying downloading the latest release yourself (hopefully you won't have the same issue I have)?
  • 6. Re: Problems with OATS Upgrade (to v12.2.0.1.223)
    Neil S Newbie
    Currently Being Moderated
    Ian,

    Did you look at the account under which the agent service (Windows Services) runs?
    Might have the run the OLT Agent Authentication Manager to re-set the password?
    Or I don't understand your problem properly.

    Anyhow, please keep us updated.

    Regards,
    Neil
  • 7. Re: Problems with OATS Upgrade (to v12.2.0.1.223)
    Anuj Khattri Newbie
    Currently Being Moderated
    Thanks IHodgetts,
    I will try this today itself and will update you with the results.

    Regards
  • 8. Re: Problems with OATS Upgrade (to v12.2.0.1.223)
    Anuj Khattri Newbie
    Currently Being Moderated
    Thanks IHodgetts,
    I have updated OATS and its working fine.

    Regards
  • 9. Re: Problems with OATS Upgrade (to v12.2.0.1.223)
    IHodgetts Explorer
    Currently Being Moderated
    Glad to hear you didn't have the problems I did! ;-)

    I've resorted to a "clean" un-install/re-install of both OATS and Oracle11gEE again. This time it appear to be working! This is DESPITE an error that popped up (behind other windows) during the early parts of the install.

    "OUI-10021: The target area C:\Program Files\Oracle\Inventory is being written to by another session. A read lock cannot be obtained. [OK]"

    The installer continued regardless and claims to have completed successfully. I've been into both OpenScript and OLT. I'm currently testing some of my old scripts to ensure they still work with the olt-agent (looking good so far).

    I'm guessing the error above is purely the "Oracle Universal Installer" (not the OATS install itself).
  • 10. Re: Problems with OATS Upgrade (to v12.2.0.1.223)
    IHodgetts Explorer
    Currently Being Moderated
    Apparently the OUI error is "a fake" (as in it doesn't matter as far as the OATS install goes).

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points