0 Replies Latest reply: Dec 4, 2012 3:11 AM by 977813 RSS

    Using Java Access bridge (Accessibility) with oracle forms 6.0 client

      I'm trying to use JAB (java Access bridge ) to capture events in oracle forms 6.0 client .
      I've a Jinitiator 1.1.8 and JRE version 1.4x
      I've configured JAB as per the installation guide . However the events don't surface in Java Monkey .
      Has anybody encountered similar issue ? what is the solution for the issue ??

      Also on one of the forums I read Jinitiator 1.3x and above is automatically recognised by Java Access bridge .
      For jinitiator version less than 1.3 manual configuration is required . however I haven;'t been able to find any on the oracle forms KB

      Also here is the excerpt from the link http://www.oracle.com/us/corporate/accessibility/faqs/index.html

      Q: Are there special steps for using Java-based applications with assistive technology?
      A: If the Oracle application is written in Java, such as JDeveloper or Oracle Forms (runtime), customers must first install the latest version of Sun's Java Access Bridge. The Java Access Bridge provides the integration with screen readers such as JAWS or SuperNova that support Java. You just download the Access Bridge and install it. Sun's AccessBridge 2.0x recognizes Oracle's JInitiator 1.3x and above so no manual configuration steps are necessary. The Access Bridge is available from: http://java.sun.com/products/accessbridge. At the time this document was written, Access Bridge 2.0.1 is the most current publicly available production release; Oracle recommends upgrading to this version. Sun's AccessBridge is bundled with Oracle Universal Installer (OUI) and can be found in the Java Runtime Engine (JRE). More information for configuring such products is in the respective product documentation, or on http://www.oracle.com/us/corporate/accessibility/products/index.html.

      Edited by: 974810 on 4 Dec, 2012 1:10 AM