This discussion is archived
3 Replies Latest reply: Dec 4, 2012 5:41 AM by ShishirTekadeR RSS

SP2-1503: Unable to initialize Oracle call interface  SP2-0152: ORACLE may

user11979518 Newbie
Currently Being Moderated
Hi Guys,

I am using Snap Manager for Oracle and I am trying to create a database clone using flexclone.

Now I get these errors:

--[ERROR] SMO-13032: Cannot perform operation: Clone Create. Root cause: ORACLE-00001: Error executing SQL: []. The command returned: SP2-1503: Unable to initialize Oracle call interface

I tried to access the sqlplus manually on the target server and I found these:

SunOS:oracle:DB /u01>sqlplus "/as sysdba"

SP2-1503: Unable to initialize Oracle call interface
SP2-0152: ORACLE may not be functioning properly

Then I did these:

export LD_LIBRARY_PATH=$ORACLE_HOME/lib

Then:

SunOS:oracle:DB /u01>sqlplus "/as sysdba";

SQL*Plus: Release 11.2.0.3.0 Production on Tue Dec 4 14:00:32 2012

Copyright (c) 1982, 2011, Oracle. All rights reserved.

Connected to an idle instance.

SQL>


But still the SMO flexclone fails with the same error.

Where do one change the environment variable for the SMO?

Thanks in advance...

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points