5 Replies Latest reply: Dec 5, 2012 1:58 AM by A. Drieux RSS

    Removed LKM, but LKM says still in use

    RG 007
      Hi Friends,

      I am moving data within same oracle database, but from one schema to another schema.
      Initially, I had created two data servers for each schema, so I was using SQL to SQL LKM.

      But with the advice of you guys, I have modified to have both schemas with in same data server.
      Thanks for that.

      Now, when I go to LKM SQL to SQL it's still showing that interfaces still using that LKM, but when i got to interface I don't
      see any LKM.

      Please advice what is reason for that, how to refresh LKM's uses list.

      Thanks in advance
        • 1. Re: Removed LKM, but LKM says still in use
          Bhabani Ranjan
          Expand your LKM SQL to SQL. You will see one option uses
          If you expand this you can see where this km is used. If you wont find anything then save opened interfaces/packages etc, close odi studio and start it again. Now you should be able to delete it.

          Thanks
          Bhabani
          http://dwteam.in
          • 2. Re: Removed LKM, but LKM says still in use
            RG 007
            "Expand your LKM SQL to SQL. You will see one option uses
            If you expand this you can see where this km is used. If you wont find anything then save opened interfaces/packages etc, close odi studio and start it again. Now you should be able to delete it."

            Yes, this is where I saw that LKM is still in use.
            I closed ODI and restarted it , it still says that same interface still using them.
            But when I open interface , I don't see any LKM mentioned there.

            Thanks
            • 3. Re: Removed LKM, but LKM says still in use
              958953
              This is a bit weird. Try to duplicate the interface and check whether the duplicate interface is also pointing to the LKM.

              Check the flow tab again and see if you missed something.
              • 4. Re: Removed LKM, but LKM says still in use
                Bhabani Ranjan
                Then what is the actual LKM you have selected for that interface. If in the flow tab it is blank then select some different LKM other than the used LKM you are facing issue.
                Now save the interface and close it. After opening the interface again, I don't think you will face any issues.

                But if you have done above thing already then I guess there something serious issue. Lets wait for suggestion from other experts.

                Thanks
                Bhabani
                http://dwteam.in
                • 5. Re: Removed LKM, but LKM says still in use
                  A. Drieux
                  If you don't have any other interface (really) using this LKM, you could try to delete it and re-import it in the list of KM.