This discussion is archived
11 Replies Latest reply: Dec 14, 2012 5:24 AM by Udo RSS

http://localhost:8080/apex/listenerConfigure page not found

kkrm333 Newbie
Currently Being Moderated
Hi,

I have downloaded apex listener apex_listener.1.1.4.195.00.12.zip and started the listener using below command.


/usr/java/jre1.6.0_37/bin/java -Dapex.images='/home/oracle/apex/apex/images/' -Dapex.port=8080 -jar /home/oracle/apex.war


After asking passwords it has prompted for INFO: Please complete configuration at: http://localhost:8080/apex/listenerConfigure

But i am getting "Internet Explorer cannot display the webpage" error.

Please help.

Thanks,
  • 1. Re: http://localhost:8080/apex/listenerConfigure page not found
    912156 Newbie
    Currently Being Moderated
    please Ignore this reply

    Edited by: user11109786 on Dec 3, 2012 10:58 AM
  • 2. Re: http://localhost:8080/apex/listenerConfigure page not found
    Udo Guru
    Currently Being Moderated
    Hi,

    do you have another service running on port 8080 on that machine? A common fault is to run APEX Listener on the same machine with the database without disabling its internal HTTP Server (XDB HTTP Server) that uses port 8080 as well, or having some JEE container (e.g. Tomcat) on that machine, that would use port 8080 per default as well...

    Could you try
    /usr/java/jre1.6.0_37/bin/java -Dapex.images='/home/oracle/apex/apex/images/' -Dapex.port=9080 -jar /home/oracle/apex.war
    instead? This would use port 9080 for your APEX Listener, so you would access listenerConfigure via http://localhost:8080/apex/listenerConfigure afterwards.
    If this doesn't work, could you please post the complete console output of the startup up to the point when you tried to open listenerConfigure ?

    -Udo
  • 3. Re: http://localhost:8080/apex/listenerConfigure page not found
    kkrm333 Newbie
    Currently Being Moderated
    Thank you so much Udo.

    Now i am able to configure the listener with 9080 port.

    then i tried to login at http://localhost:8080/apex/apex_admin with ADMIN user and password that was set by apxchpwd command.

    But getting invalid username/password error. Please help.

    Thanks,
  • 4. Re: http://localhost:8080/apex/listenerConfigure page not found
    Udo Guru
    Currently Being Moderated
    http://localhost:8080/apex/apex_admin
    Is that the actual URL you've called?
    It should be http://localhost:9080/apex/apex_admin because of the port change... If you actually called that URL and just mistyped it here, could you please describe the kind of login screen you get, i. e. do you get a HTML login form with Oracle logo entitled "Application Express Administration Services" or do you get something like a HTTP authentication asking just for username and password?
    If it's actually the APEX admin login form, then you've not performed the apxchpwd script on the database instance your APEX Listener is pointing at or you've not changed the password to the value you've entered in the login form.

    -Udo
  • 5. Re: http://localhost:8080/apex/listenerConfigure page not found
    kkrm333 Newbie
    Currently Being Moderated
    Hi,

    It was a type mistake, the url is http://localhost:9080/apex/apex_admin, then it is redirecting to
    http://localhost:9080/apex/f?p=4550:10:14223785403507.

    I got the Application Express Administration Services page asking for username and password.

    I gave ADMIN and the reset password, but getting invalid credentials.


    Thanks,
  • 6. Re: http://localhost:8080/apex/listenerConfigure page not found
    Udo Guru
    Currently Being Moderated
    Hi,
    I gave ADMIN and the reset password, but getting invalid credentials.
    And you are sure your APEX Listener points to the same database you've run the reset script on? Please don't take this question as an offence, but the script really works unless you get an error message. The only other issue that comes to my mind would be that you managed to enter some kind of invalid password... The way to get around this would be to use a simple password (containing only a-z, A-Z and 0-9) to make sure it's not a charset-related issue.

    -Udo
  • 7. Re: http://localhost:8080/apex/listenerConfigure page not found
    520377 Explorer
    Currently Being Moderated
    Udo wrote:
    Hi,
    I gave ADMIN and the reset password, but getting invalid credentials.
    And you are sure your APEX Listener points to the same database you've run the reset script on?
    And also make sure that you are running the apxchpwd for the correct version of APEX... I spent a long time changing my 3.1 password when I was running 4.0... very embarrassing!
  • 8. Re: http://localhost:8080/apex/listenerConfigure page not found
    kkrm333 Newbie
    Currently Being Moderated
    Thanks you for the reply.

    I have only Apex 4.2 installed.

    Hi Udo,

    I have checked apex-config.xml, it is pointing to correct database.

    And I changed the password to Vis_123. The chpwd procedure completed successfully also.

    Thanks,
  • 9. Re: http://localhost:8080/apex/listenerConfigure page not found
    kkrm333 Newbie
    Currently Being Moderated
    Hi,

    Can we check any log file?

    I have started the apex listener using

    nohup /usr/java/jre1.6.0_37/bin/java -Dapex.images=/home/oracle/apex/apex/images/ -Dapex.port=9080 -jar /home/oracle/apex/apex.war &


    The nohup.out showing

    INFO: Starting Embedded Web Container in: /tmp/apex
    Dec 5, 2012 8:06:26 AM ____bootstrap.Deployer deploy
    INFO: Will deploy application path=/tmp/apex/apex/WEB-INF/web.xml
    Dec 5, 2012 8:06:27 AM ____bootstrap.Deployer deploy
    INFO: deployed application path=/tmp/apex/apex/WEB-INF/web.xml
    Using config file: /home/oracle/apex/apex-config.xml
    -- listing properties --
    PropertyCheckInterval=60
    ValidateConnection=true
    MinLimit=1
    MaxLimit=10
    InitialLimit=3
    AbandonedConnectionTimeout=900
    MaxStatementsLimit=10
    InactivityTimeout=1800
    MaxConnectionReuseCount=1000
    APEX Listener version : 1.1.4.195.00.12
    APEX Listener server info: Grizzly/1.9.18-o
    Dec 5, 2012 8:06:30 AM com.sun.grizzly.Controller logVersion
    INFO: Starting Grizzly Framework 1.9.18-o - Wed Dec 05 08:06:30 EST 2012
    INFO: http://localhost:9080/apex started.
    Using JDBC driver: Oracle JDBC driver version: 11.2.0.2.0
    ======================================

    Here the end line is showing using JDBC driver., is it the normal way?

    Thanks,
  • 10. Re: http://localhost:8080/apex/listenerConfigure page not found
    CarlosAndr├ęsMorales Newbie
    Currently Being Moderated
    Hello

    I put in the browser to configure Oracle APEX Listener http://localhost:8080/apex/listenerConfigure but redirect to http://localhost:8080/apex/not-yet-configured. I used Glassfish 3.0.1 (BUILD22). I downloaded Oracle APEX Listener 2.0 Early Adopter 2_

    How I can configure it?

    Thanks
  • 11. Re: http://localhost:8080/apex/listenerConfigure page not found
    Udo Guru
    Currently Being Moderated
    Hi,

    sorry for the delay in my response - I've been quite busy the last days...

    So...
    The nohup.out showing
    this will be the actual log file your APEX Listener, which means you've provided all the content we need.
    Here the end line is showing using JDBC driver., is it the normal way?
    Yes, this means that the driver has been loaded successfully when APEX Listener created the connection.
    So your database access is working (as expected, you wouldn't see any login screen otherwhise).
    And I changed the password to Vis_123. The chpwd procedure completed successfully also.
    If you can't login to the internal administration of APEX with that password afterwards, I'm really out of options here. This is definetly no issue with APEX Listener. I didn't see the reset script itself to fail ever... If your issue hasn't been resolved yet, perhaps someone in the forum {forum:id=137} can you give further advice (e. g. a hint on some known issue, or something similar).

    Sorry for not being able to provide more help...

    -Udo

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points