This discussion is archived
1 2 Previous Next 16 Replies Latest reply: Mar 5, 2013 11:14 PM by vlsn RSS

Unable to run adf application in dev 11.1.2.2

vlsn Newbie
Currently Being Moderated
Hi,

i am writing my first adf application.when iam running the page it is showing the below error regarding connection pool creation. iam using jdev 11.1.2.2 and oracle 11g XE databse. However i am able to run Applicaiton module alone(Business Components test). Please suggest what is going wrong with my configuration.

<Dec 4, 2012 12:30:48 AM IST> <Error> <Deployer> <BEA-149265> <Failure occurred in the execution of deployment request with ID '1354561237538' for task '0'. Error is: 'weblogic.application.ModuleException: '
weblogic.application.ModuleException:
     at weblogic.jdbc.module.JDBCModule.prepare(JDBCModule.java:302)
     at weblogic.application.internal.flow.ModuleListenerInvoker.prepare(ModuleListenerInvoker.java:199)
     at weblogic.application.internal.flow.DeploymentCallbackFlow$1.next(DeploymentCallbackFlow.java:517)
     at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:52)
     at weblogic.application.internal.flow.DeploymentCallbackFlow.prepare(DeploymentCallbackFlow.java:159)
     Truncated. see log file for complete stacktrace
Caused By: weblogic.common.ResourceException: weblogic.common.ResourceException: Could not create pool connection. The DBMS driver exception was: null
     at weblogic.jdbc.common.internal.ConnectionEnvFactory.createResource(ConnectionEnvFactory.java:276)
     at weblogic.common.resourcepool.ResourcePoolImpl.makeResources(ResourcePoolImpl.java:1249)
     at weblogic.common.resourcepool.ResourcePoolImpl.makeResources(ResourcePoolImpl.java:1166)
     at weblogic.common.resourcepool.ResourcePoolImpl.start(ResourcePoolImpl.java:249)
     at weblogic.jdbc.common.internal.ConnectionPool.doStart(ConnectionPool.java:1154)
     Truncated. see log file for complete stacktrace
>
<Dec 4, 2012 12:30:48 AM IST> <Warning> <Deployer> <BEA-149004> <Failures were detected while initiating deploy task for application 'HelloWorldApp'.>
<Dec 4, 2012 12:30:48 AM IST> <Warning> <Deployer> <BEA-149078> <Stack trace for message 149004
weblogic.application.ModuleException:
     at weblogic.jdbc.module.JDBCModule.prepare(JDBCModule.java:302)
     at weblogic.application.internal.flow.ModuleListenerInvoker.prepare(ModuleListenerInvoker.java:199)
     at weblogic.application.internal.flow.DeploymentCallbackFlow$1.next(DeploymentCallbackFlow.java:517)
     at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:52)
     at weblogic.application.internal.flow.DeploymentCallbackFlow.prepare(DeploymentCallbackFlow.java:159)
     Truncated. see log file for complete stacktrace
Caused By: weblogic.common.ResourceException: weblogic.common.ResourceException: Could not create pool connection. The DBMS driver exception was: null
     at weblogic.jdbc.common.internal.ConnectionEnvFactory.createResource(ConnectionEnvFactory.java:276)
     at weblogic.common.resourcepool.ResourcePoolImpl.makeResources(ResourcePoolImpl.java:1249)
     at weblogic.common.resourcepool.ResourcePoolImpl.makeResources(ResourcePoolImpl.java:1166)
     at weblogic.common.resourcepool.ResourcePoolImpl.start(ResourcePoolImpl.java:249)
     at weblogic.jdbc.common.internal.ConnectionPool.doStart(ConnectionPool.java:1154)
     Truncated. see log file for complete stacktrace
>
[12:30:48 AM] Deployment cancelled.
[12:30:48 AM] ---- Deployment incomplete ----.
[12:30:48 AM] Remote deployment failed (oracle.jdevimpl.deploy.common.Jsr88RemoteDeployer)
#### Cannot run application HelloWorldApp due to error deploying to IntegratedWebLogicServer.
[Application HelloWorldApp stopped and undeployed from Server Instance IntegratedWebLogicServer]


Thanks
Satya
  • 1. Re: Unable to run adf application in dev 11.1.2.2
    Shay Shmeltzer Employee ACE
    Currently Being Moderated
    Can you try redefining your database connection for the application?
    Also check that under your application properties-> Deployment->WebLogic the checkbox is checked for "auto generate and synchronize WebLogic JDBC Descriptors during deployment"
  • 2. Re: Unable to run adf application in dev 11.1.2.2
    vlsn Newbie
    Currently Being Moderated
    I have verified that the auto generate and synchronize WebLogic JDBC Descriptors during deployment check box has already been checked and i tried to redefine the connection properties.Previously i was specified XE as database SID. Now i thought that is the service name so i changed it to the service name field in the connection properties window. But still it is showing the same issue. for redefining the database properties i did the modifications in .jpx file. Is it the right file iam referring to?

    Thanks
    Satya

    Edited by: vlsn on Dec 4, 2012 7:37 AM
  • 3. Re: Unable to run adf application in dev 11.1.2.2
    vlsn Newbie
    Currently Being Moderated
    can some one please help me in this . iam unable to proceed further
    thanks
  • 4. Re: Unable to run adf application in dev 11.1.2.2
    Shay Shmeltzer Employee ACE
    Currently Being Moderated
    Can you try creating a new application and see if you run into the same problem there?
  • 5. Re: Unable to run adf application in dev 11.1.2.2
    vlsn Newbie
    Currently Being Moderated
    I did the jdev uninstall ,install again and created the new application .but still the same problem
  • 6. Re: Unable to run adf application in dev 11.1.2.2
    Shay Shmeltzer Employee ACE
    Currently Being Moderated
    When you started the new JDeveloper - did it prompt you to recreate a WebLogic instance - I'm assuming it didn't and just picked up the existing one you had.
    In that case try and remove your C:\Users\yourname\AppData\Roaming\JDeveloper\system11.1.2.2.39.61.83.1\DefaultDomain directory
    And restart JDeveloper - then create a new application and test to see if it works.
  • 7. Re: Unable to run adf application in dev 11.1.2.2
    vlsn Newbie
    Currently Being Moderated
    Hi,

    Thanks for your help. Now I did the same what you said. deleted the default domain directory. it was prompted me for the weblogic credentials when i am running the new application now. But still it is giving same error.

    Thanks
  • 8. Re: Unable to run adf application in dev 11.1.2.2
    Shay Shmeltzer Employee ACE
    Currently Being Moderated
    Is this happening if you are building a new application too?
  • 9. Re: Unable to run adf application in dev 11.1.2.2
    vlsn Newbie
    Currently Being Moderated
    yeah..still iam getting same problem.
  • 10. Re: Unable to run adf application in dev 11.1.2.2
    Shay Shmeltzer Employee ACE
    Currently Being Moderated
    Can you provide the details of the DB connection you defined in JDeveloper including the connection name?
  • 11. Re: Unable to run adf application in dev 11.1.2.2
    vlsn Newbie
    Currently Being Moderated
    Create Connecion In--Application Resorces
    Connection Name- HRConn
    Connection Type--Oracle JDBC
    UserName--hr
    Password--hr
    Driver--thin
    host--localhost
    JDBCPort--1521
    Service Name--XE
  • 12. Re: Unable to run adf application in dev 11.1.2.2
    Shay Shmeltzer Employee ACE
    Currently Being Moderated
    One thing you can try is starting the Weblogic Console at http://localhost:7101/console and see if you can successfully define a JDBC data service from there.
    One other option - install the newer JDeveloper 11.1.2.3 and see if you get better results.
  • 13. Re: Unable to run adf application in dev 11.1.2.2
    vlsn Newbie
    Currently Being Moderated
    While iam trying to configure datasource in weblogic services->datasources windows getting below error.

    Message icon - Error Connection test failed.
    Message icon - Error Could not establish a XA connection because of java.lang.NullPointerException
    com.bea.console.utils.jdbc.JDBCUtils.testConnection(JDBCUtils.java:759)
    com.bea.console.actions.jdbc.datasources.createjdbcdatasource.CreateJDBCDataSource.testConnectionConfiguration(CreateJDBCDataSource.java:458)
    sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    java.lang.reflect.Method.invoke(Method.java:597)
    org.apache.beehive.netui.pageflow.FlowController.invokeActionMethod(FlowController.java:870)
    org.apache.beehive.netui.pageflow.FlowController.getActionMethodForward(FlowController.java:809)
    org.apache.beehive.netui.pageflow.FlowController.internalExecute(FlowController.java:478)
    org.apache.beehive.netui.pageflow.PageFlowController.internalExecute(PageFlowController.java:306)
    org.apache.beehive.netui.pageflow.FlowController.execute(FlowController.java:336)
    org.apache.beehive.netui.pageflow.internal.FlowControllerAction.execute(FlowControllerAction.java:52)
    org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:431)
    org.apache.beehive.netui.pageflow.PageFlowRequestProcessor.access$201(PageFlowRequestProcessor.java:97)
    org.apache.beehive.netui.pageflow.PageFlowRequestProcessor$ActionRunner.execute(PageFlowRequestProcessor.java:2044)
    org.apache.beehive.netui.pageflow.interceptor.action.internal.ActionInterceptors$WrapActionInterceptorChain.continueChain(ActionInterceptors.java:64)
    org.apache.beehive.netui.pageflow.interceptor.action.ActionInterceptor.wrapAction(ActionInterceptor.java:184)
    org.apache.beehive.netui.pageflow.interceptor.action.internal.ActionInterceptors$WrapActionInterceptorChain.invoke(ActionInterceptors.java:50)
    org.apache.beehive.netui.pageflow.interceptor.action.internal.ActionInterceptors$WrapActionInterceptorChain.continueChain(ActionInterceptors.java:58)
    org.apache.beehive.netui.pageflow.interceptor.action.internal.ActionInterceptors.wrapAction(ActionInterceptors.java:87)
    ...
  • 14. Re: Unable to run adf application in dev 11.1.2.2
    vlsn Newbie
    Currently Being Moderated
    I tried with the latest version now.still getting the same error. First i ran the page with out creating any connection and model compoenents then the page ran fine. As and when i created connection and business components getting this error. Seems the problem weblogic unable to connect to the database. yesterday when i tried to create the datasource from the weblogic services, there also got the error related to XA Connection(my previous post).i have installed oracle 11g XE databse in my system.
1 2 Previous Next

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points