3 Replies Latest reply: Dec 6, 2012 9:15 AM by user8947560 RSS

    wlst.sh How to start Forms/Reports & SOA_Suite with 1 nodemanager

    user8947560
      Hello,

      we have a problem in using wlst.sh to start Forms/Reports and SOA Suite on the same server. On septerate machines it works, on the same machine we get an errormessage because at secound start it will create a secound nodemanager, what is not possible.

      What can we do ? Can we start both with one script ?

      Regards,

      Stephan
        • 1. Re: wlst.sh How to start Forms/Reports & SOA_Suite with 1 nodemanager
          Kalyan Pasupuleti-Oracle
          Hi,

          Might check the port number that would be same change them and thne try to start it again.

          Regards,
          Kal
          • 2. Re: wlst.sh How to start Forms/Reports & SOA_Suite with 1 nodemanager
            user8947560
            Seems like both run the same port. But the configuration of the *.py scripts ist different

            FR:

            try:
            nmConnect(user,password,host,'5556',myDomain,myDomainDirectory,'ssl')
            except:
            startNodeManager(NodeManagerHome='/oraias/appl/fr3/wlserver_10.3/common/nodemanager/', ListenPort='5556', ListenAddress=host)
            nmConnect(user,password,host,'5556',myDomain,myDomainDirectory,'ssl')
            try:
            connect(user,password,url)


            SOA:

            nmfile="/oraias/appl/soa3/wlserver_10.3/common/nodemanager/nodemanager.properties"

            /oraias/appl/soa3/wlserver_10.3/common/nodemanager/nodemanager.properties

            ...
            ListenPort=5556
            ...

            So simply change ListenPort e.g. in SOA and it will work ?

            Regards,

            Stephan

            As I find here http://docs.oracle.com/cd/E14571_01/core.1111/e10105/portnums.htm , only 5556 is allowed. Anyway, I got a downtime this afternoon and will give it a try ...
            • 3. Re: wlst.sh How to start Forms/Reports & SOA_Suite with 1 nodemanager
              user8947560
              Still trouble. I got a secound nodemanager started at

              NMProcess: <Dec 6, 2012 2:23:30 PM> <INFO> <Secure socket listener started on port 5557, >
              NMProcess: Dec 6, 2012 2:23:30 PM weblogic.nodemanager.server.SSLListener run
              NMProcess: INFO: Secure socket listener started on port 5557, host
              Successfully launched the Node Manager.
              The Node Manager process is running independent of the WLST process.
              Exiting WLST will not stop the Node Manager process. Please refer
              to the Node Manager logs for more information.
              The Node Manager logs will be under /oraias/appl/soa3/wlserver_10.3/common/nodemanager
              Node Manager starting in the background
              Connecting to Node Manager ...
              Successfully Connected to Node Manager.
              Connecting to t3://xxxxx:7001 with userid weblogic ...
              Successfully connected to Admin Server 'AdminServer' that belongs to domain 'base_domain'.

              Warning: An insecure protocol was used to connect to the
              server. To ensure on-the-wire security, the SSL port or
              Admin port should be used instead.

              Location changed to domainRuntime tree. This is a read-only tree with DomainMBean as the root.
              For more help, use help(domainRuntime)

              Adminserverstatus: RUNNING
              Starte SOA Server

              Starting server soa_server1 ...Connection refused. Could not connect to NodeManager. Check that it is running at localhost:5556.

              Why does it search at 5556 ?!?!

              start_soaserver.py points to 5557 !

              try:
              nmConnect(user,password,host,'5557',myDomain,myDomainDirectory,'ssl')
              except:
              startNodeManager(NodeManagerHome='/oraias/appl/soa3/wlserver_10.3/common/nodemanager/', ListenPort='5557', ListenAddress=host)
              nmConnect(user,password,host,'5557',myDomain,myDomainDirectory,'ssl')
              try:
              connect(user,password,url)
              except:
              print '################# Error ################'
              print '# Adminserver not started startup now #'
              print '########################################'
              nmStart('AdminServer')
              connect(user,password,url)