10 Replies Latest reply: Dec 6, 2012 6:07 PM by CKPT RSS

    having trouble move Spfile from filesystem to asm

    user569151
      I find out the db started with :
      Using parameter settings in server-side spfile /u01/app/oracle/product/11.2.0/dbhome_1/dbs/spfileTST1.ora

      Tried to create a pfile, then create a spfile ='+DAT' won';t work with ora-03113 error.

      I did srvctl config database, the spfile is point to +dat

      Database unique name: TST
      Database name: TST
      Oracle home: /u01/app/oracle/product/11.2.0/dbhome_1
      Oracle user: oracle
      Spfile: DAT/TST/spfileTST.ora
      Domain:
      Start options: open
      Stop options: immediate
      Database role: PRIMARY
      Management policy: AUTOMATIC
      Server pools: TST
      Database instances: TST1,TST2
      Disk Groups: DAT,FRA
      Mount point paths:
      Services:
      Type: RAC
      Database is administrator managed


      How do I get around this issue and put spfile on ASM so I can bring the RAC instances?

      Thanks in advance.
        • 1. Re: having trouble move Spfile from filesystem to asm
          rp0428
          Please edit your other two posts, replace the content with something like 'network hiccup' and mark them ANSWERED. That way people won't think you are making duplicate posts.
          • 3. Re: having trouble move Spfile from filesystem to asm
            sb92075
            user569151 wrote:
            any help?
            http://www.lmgtfy.com/?q=oracle+copy+spfile+to+asm
            • 4. Re: having trouble move Spfile from filesystem to asm
              CKPT
              user569151 wrote:
              I find out the db started with :
              Using parameter settings in server-side spfile /u01/app/oracle/product/11.2.0/dbhome_1/dbs/spfileTST1.ora

              Tried to create a pfile, then create a spfile ='+DAT' won';t work with ora-03113 error.

              I did srvctl config database, the spfile is point to +dat

              Database unique name: TST
              Database name: TST
              Oracle home: /u01/app/oracle/product/11.2.0/dbhome_1
              Oracle user: oracle
              Spfile: DAT/TST/spfileTST.ora
              Domain:
              Start options: open
              Stop options: immediate
              Database role: PRIMARY
              Management policy: AUTOMATIC
              Server pools: TST
              Database instances: TST1,TST2
              Disk Groups: DAT,FRA
              Mount point paths:
              Services:
              Type: RAC
              Database is administrator managed


              How do I get around this issue and put spfile on ASM so I can bring the RAC instances?

              Thanks in advance.
              Can you please post your complete commands here with outputs?
              Are you using ASM with OMF?
              SQL> show parameter db_create
              • 5. Re: having trouble move Spfile from filesystem to asm
                Aman....
                Are you using ASM with OMF?
                I believe that the OMF parameters are set to the ASM disk groups automatically if you have created a db after installing the asm. And why it would matter if the OMF is set or not as it won't be used for teh spfile anyways , isn't it?

                Aman....
                • 6. Re: having trouble move Spfile from filesystem to asm
                  CKPT
                  Aman.... wrote:
                  Are you using ASM with OMF?
                  I believe that the OMF parameters are set to the ASM disk groups automatically if you have created a db after installing the asm. And why it would matter if the OMF is set or not as it won't be used for teh spfile anyways , isn't it?

                  Aman....
                  We have several options with DBCA while using ASM to use OMF or to use data files all in one location. Even we can use ASM without opt OMF. Here is sample image http://imm.io/O8v4

                  Thats why i asked OP, Let me know if any corrections in it.
                  • 7. Re: having trouble move Spfile from filesystem to asm
                    Aman....
                    Yes that's true.

                    Aman....
                    • 8. Re: having trouble move Spfile from filesystem to asm
                      user569151
                      SQL> show parameter db_create

                      NAME TYPE VALUE
                      ------------------------------------ ----------- ------------------------------
                      db_create_file_dest string +HR_DAT
                      db_create_online_log_dest_1 string +HR_DAT
                      db_create_online_log_dest_2 string +HR_FRA                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                           
                      • 9. Re: having trouble move Spfile from filesystem to asm
                        user569151
                        It seems a very simple task, however I got following error:

                        create spfile='+HR_DAT' from pfile='/u01/app/oracle/admin/TST/pfile/initTST1.ora'
                        *
                        ERROR at line 1:
                        ORA-00600: internal error code, arguments: [], [], [], [], [], [], [], [], [],
                        [], [], []
                        • 10. Re: having trouble move Spfile from filesystem to asm
                          CKPT
                          user569151 wrote:
                          It seems a very simple task, however I got following error:

                          create spfile='+HR_DAT' from pfile='/u01/app/oracle/admin/TST/pfile/initTST1.ora'
                          *
                          ERROR at line 1:
                          ORA-00600: internal error code, arguments: [], [], [], [], [], [], [], [], [],
                          [], [], []
                          Earlier you mentioned errors with ORA-3113 as below..

                          >
                          Tried to create a pfile, then create a spfile ='+DAT' won';t work with ora-03113 error.
                          What is the difference in commands now and before?
                          There are no arguments with ORA-600? Hmm..

                          Once give below output too
                          SQL> show parameter spfile
                          SQL> select name, state from v$asm_diskgroup;
                          $ ls -ltr /u01/app/oracle/admin/TST/pfile/initTST1.ora