This discussion is archived
8 Replies Latest reply: Dec 6, 2012 8:29 AM by _Phil RSS

issues with agent.

948255 Newbie
Currently Being Moderated
Here is the script:

import os
retVal = os.system(r'sqlldr odi_stage/test1234@devodi control=E:\Hyperion\DRM\ODI\Scripts/DRM_ESSBASE_PLANNING.ctl log=E:\Hyperion\DRM\ODI\Logs/DRM_ESSBASE_PLANNING2.log')

when i excecute this script from studio with agent=local(noagent) it runs fine and when i run same script with an agent=d1odiagent_dev it fails with error Traceback (innermost last). it seems like its not able to recognise local drives. anyone came across this issue?

Thanks.
Sri.
  • 1. Re: issues with agent.
    _Phil Journeyer
    Currently Being Moderated
    Is your agent "d1odiagent_dev" on your local machine? If not, then the files on the E: drive need to exist in the same location on the agent machine.
  • 2. Re: issues with agent.
    948255 Newbie
    Currently Being Moderated
    yes. d1odi1agent_dev is on the same windows server, where E: drive is mapped. thx.
  • 3. Re: issues with agent.
    _Phil Journeyer
    Currently Being Moderated
    Can you post the full error message?
  • 4. Re: issues with agent.
    948255 Newbie
    Currently Being Moderated
    Phil..
    Here is the script I have added to capture the message:
    if retVal == 1 or retVal > 2:
    str1 = 'SQLLDR FAILED. Please check logs for details '
    raise str1
    else:
    str1 = 'SQLLDR SUCCESSFULL'

    and please find the error message below.

    Thanks.


    ODI-1217: Session PROC_LD_ESSBASE_PLANNING_SQLLDR_T (841001) fails with return code 7000.
    ODI-1226: Step PROC_LD_ESSBASE_PLANNING_SQLLDR_T fails after 1 attempt(s).
    ODI-1232: Procedure PROC_LD_ESSBASE_PLANNING_SQLLDR_T execution fails.
    Caused By: org.apache.bsf.BSFException: exception from Jython:
    Traceback (innermost last):
    File "<string>", line 7, in ?
    SQLLDR FAILED. Please check logs for details

         at org.apache.bsf.engines.jython.JythonEngine.exec(JythonEngine.java:146)
         at com.sunopsis.dwg.codeinterpretor.SnpScriptingInterpretor.execInBSFEngine(SnpScriptingInterpretor.java:345)
         at com.sunopsis.dwg.codeinterpretor.SnpScriptingInterpretor.exec(SnpScriptingInterpretor.java:169)
         at com.sunopsis.dwg.dbobj.SnpSessTaskSql.scripting(SnpSessTaskSql.java:2374)
         at com.sunopsis.dwg.dbobj.SnpSessTaskSql.execScriptingOrders(SnpSessTaskSql.java:1615)
         at com.sunopsis.dwg.dbobj.SnpSessTaskSql.execScriptingOrders(SnpSessTaskSql.java:1580)
         at com.sunopsis.dwg.dbobj.SnpSessTaskSql.treatTaskTrt(SnpSessTaskSql.java:2755)
         at com.sunopsis.dwg.dbobj.SnpSessTaskSql.treatTask(SnpSessTaskSql.java:2515)
         at com.sunopsis.dwg.dbobj.SnpSessStep.treatAttachedTasks(SnpSessStep.java:534)
         at com.sunopsis.dwg.dbobj.SnpSessStep.treatSessStep(SnpSessStep.java:449)
         at com.sunopsis.dwg.dbobj.SnpSession.treatSession(SnpSession.java:1954)
         at oracle.odi.runtime.agent.processor.impl.StartSessRequestProcessor$2.doAction(StartSessRequestProcessor.java:322)
         at oracle.odi.core.persistence.dwgobject.DwgObjectTemplate.execute(DwgObjectTemplate.java:224)
         at oracle.odi.runtime.agent.processor.impl.StartSessRequestProcessor.doProcessStartSessTask(StartSessRequestProcessor.java:246)
         at oracle.odi.runtime.agent.processor.impl.StartSessRequestProcessor.access$0(StartSessRequestProcessor.java:237)
         at oracle.odi.runtime.agent.processor.impl.StartSessRequestProcessor$StartSessTask.doExecute(StartSessRequestProcessor.java:794)
         at oracle.odi.runtime.agent.processor.task.AgentTask.execute(AgentTask.java:114)
         at oracle.odi.runtime.agent.support.DefaultAgentTaskExecutor$2.run(DefaultAgentTaskExecutor.java:82)
         at java.lang.Thread.run(Thread.java:619)
  • 5. Re: issues with agent.
    _Phil Journeyer
    Currently Being Moderated
    Is there anything useful in the SQLLDR log file?

    There's not an awful lot to go on here.
  • 6. Re: issues with agent.
    948255 Newbie
    Currently Being Moderated
    Phil,

    its not able to create a log file. this tells me there the agent "d1odiagent_dev" even though its on local machine its not able to find and run sqlldr script nor create a log file. but if i run without the agent works fine.
    I am lost because, I CAN run other interfaces/packages/procesdure without any issues with the same agent "d1odiagent_dev".

    normally, I logon to windows machine as administrator but my odi studio login is "supervisor". do you think having two different users causing this issue?
  • 7. Re: issues with agent.
    _Phil Journeyer
    Currently Being Moderated
    I wouldn't think so - the SUPERVISOR user is (generally) the default user for any ODI implementation and unless you've configured your security to use an external authentication (like AD) then your Windows user is unlikely to be your ODI user.

    It does feel like a permissions issue though - check the permissions on the folder and files - the Windows user used to start the ODI agent should have the necessary permissions to write to the folder/files.

    Edited by: _Phil on Dec 6, 2012 4:29 PM                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                   
  • 8. Re: issues with agent.
    _Phil Journeyer
    Currently Being Moderated
    Also check out this thread - It might have some additional clues:

    LKM File to Oracle (SQlLDR) giving errors

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points