This discussion is archived
1 2 3 4 Previous Next 47 Replies Latest reply: Jan 14, 2013 3:15 PM by 741640 Go to original post RSS
  • 15. Re: Oracle 11g R2 DB Failed Installation on RedHat 6.3
    741640 Newbie
    Currently Being Moderated
    I went ahead and created a brand new instance with RedHat 6.3 OS. Well, installing Oracle 11g R2 failed again with similar prerequisite errors. The only critical one that failed though is:

    INFO: *********************************************
    INFO: Package: glibc-2.3.4-2.41: This is a prerequisite condition to test whether the package "glibc-2.3.4-2.41" is available on the system.
    INFO: Severity:CRITICAL
    INFO: OverallStatus:VERIFICATION_FAILED
    INFO: -----------------------------------------------
    INFO: Verification Result for Node:stg01-cs-ord1
    INFO: Expected Value:glibc-2.3.4-2.41 (i686)
    INFO: Actual Value:missing
    INFO: Error Message:PRVF-7532 : Package "glibc-2.3.4-2.41 (i686)" is missing on node "stg01-cs-ord1"
    INFO: Cause: A required package is either not installed or, if the package is a kernel module, is not loaded on the specified node.
    INFO: Action: Ensure that the required package is installed and available.
    INFO: -----------------------------------------------
    INFO: *********************************************
    INFO: Package: glibc-2.3.4-2.41: This is a prerequisite condition to test whether the package "glibc-2.3.4-2.41" is available on the system.
    INFO: Severity:CRITICAL
    INFO: OverallStatus:SUCCESSFUL
    INFO: -----------------------------------------------
    INFO: Verification Result for Node:stg01-cs-ord1
    INFO: Expected Value:glibc-2.3.4-2.41 (x86_64)
    INFO: Actual Value:glibc-2.12-1.80.el6_3.6 (x86_64)
    INFO: -----------------------------------------------

    I don't know why it's looking for i686 glibc library and reports it as failed, when my architecture is x86_64. All other prerequisite checks are for modules with Severity set to "IGNORABLE". My understanding is that I can ignore them. However, how can I fix the glibc (i686) one. I already have glibc-2.12-1.80.el6_3.6 (x86_64) installed as you can see from the log below.

    Please let me know what you think as I am pretty lost at this point.
  • 16. Re: Oracle 11g R2 DB Failed Installation on RedHat 6.3
    sb92075 Guru
    Currently Being Moderated
    post results from LONG running OS command below

    find / -name glibc\* -print 2>/dev/null
  • 17. Re: Oracle 11g R2 DB Failed Installation on RedHat 6.3
    Srini Chavali-Oracle Oracle ACE Director
    Currently Being Moderated
    Pl identify the database version you are installing - as noted above, 11.2.0.3 is the only version certified to be installed on OL/RH 6.x

    Oracle Database (RDBMS) on Unix AIX,HP-UX,Linux,Mac OS X,Solaris,Tru64 Unix Operating Systems Installation and Configuration Requirements Quick Reference (8.0.5 to 11.2) [ID 169706.1]

    HTH
    Srini
  • 18. Re: Oracle 11g R2 DB Failed Installation on RedHat 6.3
    741640 Newbie
    Currently Being Moderated
    OK. Sorry, I was able to install the 32-bit version of glibc command.

    #> yum install glibc.i686

    Now, the only prerequisite checks that fail are with "Severity:IGNORABLE". Do I need to resolve these as well or can they be safely ignored?
  • 19. Re: Oracle 11g R2 DB Failed Installation on RedHat 6.1
    741640 Newbie
    Currently Being Moderated
    I am installing 11.2.0.1.0 version as I believe I can't download 11.2.0.3 one without paid support. When I looked up http://docs.oracle.com/cd/E11882_01/install.112/e24321/pre_install.htm#CHDFFBIF it listed Red Hat 6 as certified for 11.2. That's why I thought it was also certified for 11.2.0.1.0. My other option is RedHat EL 5.5. Is 11.2.0.1.0 certified on it?
  • 20. Re: Oracle 11g R2 DB Failed Installation on RedHat 6.1
    Srini Chavali-Oracle Oracle ACE Director
    Currently Being Moderated
    The link you posted is misleading, unfortunately - pl see the link I posted in my second response above. RH 5.2 (or later) is certified with 11.2.0.1

    HTH
    Srini
  • 21. Re: Oracle 11g R2 DB Failed Installation on RedHat 6.1
    741640 Newbie
    Currently Being Moderated
    I see. This should be the link then: http://docs.oracle.com/cd/E11882_01/relnotes.112/e23558/toc.htm#CJAIJCDC

    I am going to try to install it on RHEL 5.5 then and post my results. I assume it is OK to continue to use this thread. Let me know if I should start a new one with modified subject specific to RHEL 5.5.
  • 22. Re: Oracle 11g R2 DB Failed Installation on RedHat 6.1
    Srini Chavali-Oracle Oracle ACE Director
    Currently Being Moderated
    It does not matter whether you open a new thread or not. I suspect if you install 11.2.0.1 on RH 5.x, and follow the directions in the Install Guide to the letter, it should go thru without any issues. For continuity purposes, I would suggest you continue in this thread if you have further issues.

    HTH
    Srini
  • 23. Re: Oracle 11g R2 DB Failed Installation on RedHat 5.5
    741640 Newbie
    Currently Being Moderated
    I've created a new instance with RedHat 5.5 OS and tried to install again using silent option. The installer appears to be failing again. These are the last lines from the log:

    ... ... ...
    INFO: Adding ExitStatus PREREQUISITES_NOT_MET to the exit status set
    WARNING: [WARNING] [INS-13014] Target environment do not meet some optional requirements.
    CAUSE: Some of the optional prerequisites are not met. See logs for details. /data01/app/oraInventory/logs/installActions2012-12-06_10-47-51AM.log
    ACTION: Identify the list of failed prerequisite checks from the log: /data01/app/oraInventory/logs/installActions2012-12-06_10-47-51AM.log. Then either from the log file or from installation manual find the appropriate configuration to meet the prerequisites and fix it manually.
    INFO: Advice is CONTINUE
    INFO: Finding the most appropriate exit status for the current application
    INFO: Exit Status is -3
    INFO: Shutdown Oracle Database 11g Release 2 Installer

    Looking at the prerequisites check, I see only one check failed:

    INFO: *********************************************
    INFO: Swap Size: This is a prerequisite condition to test whether sufficient total swap space is available on the system.
    INFO: Severity:IGNORABLE
    INFO: OverallStatus:OPERATION_FAILED
    INFO: -----------------------------------------------
    INFO: Verification Result for Node:stg01-cs-ord1
    WARNING: Result values are not available for this verification task
    INFO: Error Message:PRVF-7575 : Encountered an internal error. The range of reference data for verifying swap size has not been correctly defined
    INFO: Cause: Swap size could not be determined based on the physical memory available.
    INFO: Action: This is an internal error that should be reported to Oracle.

    Searching online for a resolution did yield any positive results. Not sure how to go about fixing this issue? It appears that installer doesn't know how to verify the swap space, though when I run the installer, it writes this to the terminal:

    Checking Temp space: must be greater than 120 MB. Actual 29960 MB Passed
    Checking swap space: must be greater than 150 MB. Actual 2045 MB Passed

    Any ideas guys?
  • 24. Re: Oracle 11g R2 DB Failed Installation on RedHat 5.5
    Srini Chavali-Oracle Oracle ACE Director
    Currently Being Moderated
    Can you try an interactive install ?

    HTH
    Srini
  • 25. Re: Oracle 11g R2 DB Failed Installation on RedHat 5.5
    sb92075 Guru
    Currently Being Moderated
    ACTION: Identify the list of failed prerequisite checks from the log: /data01/app/oraInventory/logs/installActions2012-12-06_10-47-51AM.log. Then either from the log file or from installation manual find the appropriate configuration to meet the prerequisites and fix it manually.
  • 26. Re: Oracle 11g R2 DB Failed Installation on RedHat 5.5
    741640 Newbie
    Currently Being Moderated
    I could try to set up X Server on my Windows desktop, but that would take time (never done this before) and no guarantee it won't fail at prerequisites again. I am really hoping to be able to run the silent mode successfully, so I can reuse the response files for provisioning other environments. Is there anything else I can try before moving on to GUI installation? I am using certified OS and following Oracle installation steps to the letter. Not sure why it's giving me such a hard time. Thank you.
  • 27. Re: Oracle 11g R2 DB Failed Installation on RedHat 5.5
    Srini Chavali-Oracle Oracle ACE Director
    Currently Being Moderated
    There is no requirement to set up an X server on your Windows client. If you log in to the Linux server as "oracle" (owner of the Oracle binaries), set the DISPLAY to "localhost:0.0" and ensure that xclock works, you can then run the install interactively.

    HTH
    Srini
  • 28. Re: Oracle 11g R2 DB Failed Installation on RedHat 5.5
    EdStevens Guru
    Currently Being Moderated
    colddata wrote:
    I could try to set up X Server on my Windows desktop, but that would take time (never done this before)
    It really a no-brainer if you use an x-server product that doesn't try to be all things to all people. I use x-ming. Free. Lightweight. No configuration necessary. Just download and run the installer. I did it just this morning on my brand new desktop. Just be sure you actually start it before needing it. I use putty for my ssh client, configure the session for x-11 port forwarding. don't have to mess with setting DISPLAY in my session. I'm good to go.
    and no guarantee it won't fail at prerequisites again. I am really hoping to be able to run the silent mode successfully, so I can reuse the response files for provisioning other environments. Is there anything else I can try before moving on to GUI installation? I am using certified OS and following Oracle installation steps to the letter. Not sure why it's giving me such a hard time. Thank you.
  • 29. Re: Oracle 11g R2 DB Failed Installation on RedHat 5.5
    741640 Newbie
    Currently Being Moderated
    I was finally able to run installer successfully (at least this is what the script showed me at the end). However, checking status of the dbconsole displayed this error:

    *[oracle@stg01-cs-ord1 ~]$ emctl status dbconsole*
    OC4J Configuration issue. /data01/app/oracle/product/11.2.0/db_1/oc4j/j2ee/OC4J_DBConsole_stg01-cs-ord1.colddata.com_webdev not found.

    This directory indeed doesn't exist:
    *[oracle@stg01-cs-ord1 ~]$ ls -1 /data01/app/oracle/product/11.2.0/db_1/oc4j/j2ee/*
    deploy_db_wf.ini
    home
    oc4j_applications
    OC4J_DBConsole
    OC4J_Workflow_Component_Container
    OC4J_Workflow_Management_Container
    utilities

    I've tried to drop and create the repository
    *[oracle@stg01-cs-ord1 ~]$ emca -deconfig dbcontrol db -repos drop*
    ... ... ...
    INFO: Dropping the EM repository (this may take a while) ...
    Jan 9, 2013 5:56:14 AM oracle.sysman.emcp.EMReposConfig invoke
    INFO: Repository successfully dropped
    Enterprise Manager configuration completed successfully
    FINISHED EMCA at Jan 9, 2013 5:56:14 AMINFO: Dropping the EM repository (this may take a while) ...
    Jan 9, 2013 5:56:14 AM oracle.sysman.emcp.EMReposConfig invoke
    INFO: Repository successfully dropped
    Enterprise Manager configuration completed successfully
    FINISHED EMCA at Jan 9, 2013 5:56:14 AM

    *[oracle@stg01-cs-ord1 ~]$ emca -config dbcontrol db -repos create*
    ... ... ...
    INFO: Repository successfully created
    Jan 9, 2013 6:02:37 AM oracle.sysman.emcp.EMReposConfig uploadConfigDataToRepository
    INFO: Uploading configuration data to EM repository (this may take a while) ...
    Jan 9, 2013 6:02:39 AM oracle.sysman.emcp.EMReposConfig invoke
    INFO: Refer to the log file at /data01/app/oracle/cfgtoollogs/emca/webdev/emca_repos_config_<date>.log for more details.
    Jan 9, 2013 6:02:39 AM oracle.sysman.emcp.EMReposConfig invoke
    SEVERE: Error uploading configuration data to the repository
    Jan 9, 2013 6:02:39 AM oracle.sysman.emcp.EMConfig perform
    SEVERE: Error uploading configuration data to the repository
    Refer to the log file at /data01/app/oracle/cfgtoollogs/emca/webdev/emca_2013_01_09_05_57_25.log for more details.
    Could not complete the configuration. Refer to the log file at /data01/app/oracle/cfgtoollogs/emca/webdev/emca_2013_01_09_05_57_25.log for more details.

    Here are the last entries in the /data01/app/oracle/cfgtoollogs/emca/webdev/emca_2013_01_09_05_57_25.log:
    ... ... ...
    Connecting to database using connect string (DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=stg01-cs-ord1.colddata.com)(PORT=1521)))(CONNECT_DATA=(SERVICE_NAME=webdev.colddata.com))) in home /data01/app/oracle/product/11.2.0/db_1 with user "SYS" role "SYSDBA".
    connected to database.
    sql to execute declare repos_pwd varchar2(30); view_user varchar2(30); view_user_pwd varchar2(30); view_user_acc_status varchar2(30); begin repos_pwd := ?; sysman.mgmt_view_priv.get_view_user(view_user); select account_status into view_user_acc_status from sys.dba_users where upper(username) = upper ( view_user ); IF view_user_acc_status like '%LOCKED%' THEN execute immediate 'alter user ' || view_user || ' account unlock'; END IF; IF view_user_acc_status like '%EXPIRED%' THEN sysman.mgmt_view_priv.set_view_user_creds ( repos_pwd ); sysman.mgmt_view_priv.GET_VIEW_USER_CREDS ( view_user, view_user_pwd ); execute immediate 'alter user ' || view_user || ' identified by ' || view_user_pwd || ''; END IF; end;
    noOfParams to bind: 1.
    sql execute successfully.

    Jan 9, 2013 6:02:37 AM oracle.sysman.emcp.EMReposConfig unlockMGMTAccount
    CONFIG: Unlocked mgmt_view account
    Jan 9, 2013 6:02:37 AM oracle.sysman.emcp.EMReposConfig invoke
    CONFIG: Successfully unlocked mgmt_view account
    Jan 9, 2013 6:02:37 AM oracle.sysman.emcp.ParamsManager getParam
    CONFIG: No value was set for the parameter ORACLE_HOSTNAME.
    Jan 9, 2013 6:02:37 AM oracle.sysman.emcp.EMReposConfig uploadConfigDataToRepository
    INFO: Uploading configuration data to EM repository (this may take a while) ...
    Jan 9, 2013 6:02:39 AM oracle.sysman.emcp.EMReposConfig uploadConfigDataToRepository
    CONFIG: Error uploading configuration data to the repository
    oracle.sysman.emdrep.config.ConfigurationException: FATAL Configuration Exceptions

    at oracle.sysman.emdrep.config.EMSchemaConfiguration.perform(EMSchemaConfiguration.java:232)
    at oracle.sysman.emcp.EMReposConfig.uploadConfigDataToRepository(EMReposConfig.java:698)
    at oracle.sysman.emcp.EMReposConfig.invoke(EMReposConfig.java:384)
    at oracle.sysman.emcp.EMReposConfig.invoke(EMReposConfig.java:157)
    at oracle.sysman.emcp.EMConfig.perform(EMConfig.java:253)
    at oracle.sysman.emcp.EMConfigAssistant.invokeEMCA(EMConfigAssistant.java:589)
    at oracle.sysman.emcp.EMConfigAssistant.performConfiguration(EMConfigAssistant.java:1448)
    at oracle.sysman.emcp.EMConfigAssistant.statusMain(EMConfigAssistant.java:573)
    at oracle.sysman.emcp.EMConfigAssistant.main(EMConfigAssistant.java:521)
    Jan 9, 2013 6:02:39 AM oracle.sysman.emcp.EMReposConfig invoke
    INFO: Refer to the log file at /data01/app/oracle/cfgtoollogs/emca/webdev/emca_repos_config_<date>.log for more details.
    Jan 9, 2013 6:02:39 AM oracle.sysman.emcp.EMReposConfig invoke
    SEVERE: Error uploading configuration data to the repository
    Jan 9, 2013 6:02:39 AM oracle.sysman.emcp.EMConfig perform
    SEVERE: Error uploading configuration data to the repository
    Refer to the log file at /data01/app/oracle/cfgtoollogs/emca/webdev/emca_2013_01_09_05_57_25.log for more details.
    Jan 9, 2013 6:02:39 AM oracle.sysman.emcp.EMConfig perform
    CONFIG: Stack Trace:
    oracle.sysman.emcp.exception.EMConfigException: Error uploading configuration data to the repository
    at oracle.sysman.emcp.EMReposConfig.invoke(EMReposConfig.java:396)
    at oracle.sysman.emcp.EMReposConfig.invoke(EMReposConfig.java:157)
    at oracle.sysman.emcp.EMConfig.perform(EMConfig.java:253)
    at oracle.sysman.emcp.EMConfigAssistant.invokeEMCA(EMConfigAssistant.java:589)
    at oracle.sysman.emcp.EMConfigAssistant.performConfiguration(EMConfigAssistant.java:1448)
    at oracle.sysman.emcp.EMConfigAssistant.statusMain(EMConfigAssistant.java:573)
    at oracle.sysman.emcp.EMConfigAssistant.main(EMConfigAssistant.java:521)
    Jan 9, 2013 6:02:39 AM oracle.sysman.emcp.EMConfig restoreOuiLoc
    CONFIG: Restoring oracle.installer.oui_loc to /data01/app/oracle/product/11.2.0/db_1/oui

    I've spend many hours researching online, but couldn't find a solution yet. Please help.

    P.S. Please note, I don't have Oracle paid support, so I can't view their docs on the support site.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points