5 Replies Latest reply on Dec 20, 2012 9:59 PM by chrisk

    Help: Installing Forms (FMW) release 1 on Windows 7 x64 Bit

      Hi Experts,

      I'm attempting to install forms on windows 7 64bit. I have done by homework and found numerous threads on exactly how to do this, but I'm stuck at a peculiar problem that I need some help with.

      I'm following the steps outlined in this thread:
      Steps - Install Oracle Fusion MiddleWare (R1) In Windows 7

      So far I've:
      * Downloaded 64 bit JDK,
      * Installed weblogic 10.3.5 in new middleware home using "generic" jar installer, and using aforementioned 64 bit JDK
      * Downloaded Fusion Middleware x64 bit (V18785 package).

      I will also say:
      * UAC is disabled
      * I'm running as an administrator by default

      Here is where I get stuck - I extracted the four zips, and run "setup.exe" under disk1. I go through the prompts, and pick the Middleware home where weblogic is. At the final screen, when I click "install", the installer just closes instantly. No error message, nothing. It just quits. It is not running in the background, or anything like that.

      I also have down the following:
      * I removed any instances of "Program files (x86)" from my path (replaced with "progra~2")
      * I put the 64 bit jdk in "JAVA_HOME" env var

      Even after those changes , I get the same result.

      If I look in the logs in C:\program files\oracle\inventory , there is a stack trace:
      java.lang.UnsatisfiedLinkError: no GetVolumeInfo in java.library.path
           at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1709)
           at java.lang.Runtime.loadLibrary0(Runtime.java:823)
           at java.lang.System.loadLibrary(System.java:1028)
           at oracle.as.install.engine.modules.util.others.VolumeAPI.<clinit>(VolumeAPI.java:37)
           at oracle.as.install.template.screens.SpecifyInstallLocnWithMWSpecifactionPage.checkIfFileSystemIsFAT32(SpecifyInstallLocnWithMWSpecifactionPage.java:478)
           at oracle.as.install.template.screens.SpecifyInstallLocnWithMWSpecifactionPage.invokeStandaloneValidations(SpecifyInstallLocnWithMWSpecifactionPage.java:421)
           at oracle.as.install.engine.modules.presentation.ui.common.wizard.ModifiedDWizard.doNext(ModifiedDWizard.java:660)
           at oracle.bali.ewt.wizard.BaseWizard$Action.actionPerformed(Unknown Source)
           at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
           at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
           at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
           at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
           at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:236)
           at java.awt.Component.processMouseEvent(Component.java:6263)
           at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
           at java.awt.Component.processEvent(Component.java:6028)
           at java.awt.Container.processEvent(Container.java:2041)
           at java.awt.Component.dispatchEventImpl(Component.java:4630)
           at java.awt.Container.dispatchEventImpl(Container.java:2099)
           at java.awt.Component.dispatchEvent(Component.java:4460)
           at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4574)
           at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4238)
           at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4168)
           at java.awt.Container.dispatchEventImpl(Container.java:2085)
           at java.awt.Window.dispatchEventImpl(Window.java:2475)
           at java.awt.Component.dispatchEvent(Component.java:4460)
           at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
           at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
           at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
           at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
           at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
           at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
           at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
      oracle home in validateData is  as
      middleWare home in validateData is  C:\Oracle\Forms11Home
      needWritableDirectory: true
      os_name = Windows 7
      Platform = win64
      getJavHome Method - middlewareHome: C:\Oracle\Forms11Home
      getJavHome Method - weblogicHome: null
      getCommandOutput: java version "1.6.0_37"
      Java(TM) SE Runtime Environment (build 1.6.0_37-b06)
      Java HotSpot(TM) 64-Bit Server VM (build 20.12-b01, mixed mode)
      In processErrorMsgStringOracle Home Directory
      In processErrorMsgString@SpecifyInstallLocnWithMWSpecifactionPage.m_OracleDirectoryInvalidErrorString
      Obtained the single page data..SpecifyInstallLocnWithMWSpecifactionPage
      According metalink, that java exception could be caused by "Program files (x86)" being in the path, but it is not for sure. I even ran with only JDK in the path, same results.

      Any help or clues would be very appreciated...
        • 1. Re: Help: Installing Forms (FMW) release 1 on Windows 7 x64 Bit
          Carlos Cortez
          So far I've:
          * Downloaded 64 bit JDK,
          * Installed weblogic 10.3.5 in new middleware home using "generic" jar installer, and using aforementioned 64 bit JDK
          * Downloaded Fusion Middleware x64 bit (V18785 package)
          Have you already install the Forms's Base before try to install patchset??

          The it´s a patch and must be applied over installation, in the thread you have provided you can see that is downloaded and then patchset 5 is applied. You can apply patch or but the important point is that you need the base before the patch.

          • 2. Re: Help: Installing Forms (FMW) release 1 on Windows 7 x64 Bit
            Thank you for your answer - upon looking at it further, I had a typo in my original message. I am installing . The version indicated in my original message was incorrect. (If you notice, the zip file name I reference is the same as the thread I link to), and I verified from Oracle Software Delivery cloud that it is v11.1.1.2 I downloaded and am working with.
            • 3. Re: Help: Installing Forms (FMW) release 1 on Windows 7 x64 Bit
              As you probably figured out from your research, FMV is very sensitive to path names - in the Oracle home locations and any intermediate locations used by the installer.

              You likely already checked this, but just on a hunch... did you check that the environment variable TEMP is set to a path that has no spaces or special characters?
              1 person found this helpful
              • 4. Re: Help: Installing Forms (FMW) release 1 on Windows 7 x64 Bit
                I checked and TEMP is set to "C:\Windows\TEMP".

                One other thing I noticed - the installer created two "log" files a .log and .out file. The stack trace in my original post was from the .out file. In the .log file, it lists out all the environment variables, and I found a couple interesting entries:
                [2012-12-06T09:46:16.290-08:00] [as] [NOTIFICATION] [] [oracle.as.install.engine] [tid: 10] [ecid: 0000JhlKnDN5qY05zz9DiW1GkDbc000000,0] ProgramFiles(x86)=C:\Program Files (x86)
                [2012-12-06T09:46:16.293-08:00] [as] [NOTIFICATION] [] [oracle.as.install.engine] [tid: 10] [ecid: 0000JhlKnDN5qY05zz9DiW1GkDbc000000,0] CommonProgramFiles(x86)=C:\Program Files (x86)\Common Files
                So I opened up a Command window, and removed these veriables by executing "SET ProgramFiles(x86)=", etc; then launched the installer from the command window. However, it was the exact same result.

                I'll keep tinkering around, if anyone has any other suggestions, it would be appreciated!

                Edited by: chrisk on Dec 7, 2012 8:23 AM
                • 5. Re: Help: Installing Forms (FMW) release 1 on Windows 7 x64 Bit
                  If anyone else runs into this, I figured out the problem...

                  The problem was that a registry key (HKLM/Softare/Oracle/inst_loc) was pointing at C:\progra~2\Oracle\inventory, which is for 32-bit applications. I changed that registry key to point to C:\progra~1\Oracle\inventory , re-ran the installer, and it worked.

                  The "getVolumeInformation" error that appeared in the logs was a red herring and had nothing to do with the problem at all (it appears every time on 64bit installs and can be ignored).