This discussion is archived
14 Replies Latest reply: Jul 31, 2013 11:56 PM by Sebbes RSS

repomd.xml not found on OEL 6-3 install

Jimbo Explorer
Currently Being Moderated
Hi,

I am trying to install OEL 6-3 from a bootable image I downloaded from OTN. I am installing this onto a virgin x86 server that I have just placed a new ( empty ) hard drive into.

Things were going well until I got the error

Cannot retrieve repository metadata ( repomd.xml ) for repository : anaconda-UEK2
Please verify its path and try again.

There are 3 buttons available - Exit Installer, Edit and Retry
Retry obviously gets me nowhere
Edit seems to bring up a URL based search

However as I have stated this server is completely blank - so there is no way there is any proxy or anything set up yet.

Has anyone experienced this problem and have a resolution ( I am prety sure my bootable image is sound - it just looks like the installer is looking for something which is not supplied with the image )

any help greatly appreciated,
Jim
  • 1. Re: repomd.xml not found on OEL 6-3 install
    Dude! Guru
    Currently Being Moderated
    What exactly did you download and from were? If you want to install and boot your system from DVD you can use the regular distribution DVD from https://edelivery.oracle.com/linux e.g. OracleLinux-R6-U3-Server-x86_64 (V33411-01). It's about 3.6 GB.
  • 2. Re: repomd.xml not found on OEL 6-3 install
    Jimbo Explorer
    Currently Being Moderated
    Yep, I went to E-Delivery and into OEL 6-3 for x86 ( 32 bit ).

    there are 5 options available for this -
    i. Oracle Linux Release 6 Update 3 for x86 (32 Bit ) - 3Gb
    ii. Oracle Linux Release 6 Update 3 Boot iso image x86 ( 32 bit ) - 164 Mb
    iii. Oracle Linux Release 6 Update 3 Source DVD 1 - 3.1 Gb
    iv. Oracle Linux Release 6 Update 3 Source DVD 2 - 1.7 Gb
    v. Oracle Linux Release 6 Update 3 UEK Boot iso image x86 ( 32 bit ) - 164 Mb

    Since I need a bootable DVD, I downloaded ii) and burned the DVD from the iso image
    option v) is the same as ii. except it uses the unbreakable kernel instead of the RHEL one.

    Given that my server is virgin / blank - I assume only a bootable install is suitable for my purposes.

    The problem seems to be that the image is missing the repomd.xml file and the installer appears to want to do a web search to get it ( not really suitable since in the middle of the OS install, I don't really have we available ! )

    any thoughts
    Jim
    Jim
  • 3. Re: repomd.xml not found on OEL 6-3 install
    Dude! Guru
    Currently Being Moderated
    i. Oracle Linux Release 6 Update 3 for x86 (32 Bit ) - 3Gb
    This is the one you need to download. It is the installation DVD and is bootable.

    The other smaller bootable images are for maintenance. You don't need the sources.
  • 4. Re: repomd.xml not found on OEL 6-3 install
    Jimbo Explorer
    Currently Being Moderated
    Ok thanks - that's weird because the image I downloaded gave a complete installation menu i.e.

    - Install or upgrade existing system
    - Install system with basic video device
    - Rescue Installed System
    - Boot from Local Drive
    - Memory Test

    I assumed the first option was a complete install option

    Jim
  • 5. Re: repomd.xml not found on OEL 6-3 install
    Dude! Guru
    Currently Being Moderated
    Ok thanks - that's weird because the image I downloaded gave a complete installation menu i.e.
    You can select this option to use your own installation source from external storage or network. If you want to start your system from DVD and use the same DVD to install the OS you need to use the standard distribution DVD as I mentioned.
  • 6. Re: repomd.xml not found on OEL 6-3 install
    Jimbo Explorer
    Currently Being Moderated
    I downloaded the install image you highlighted and burnt it to DVD. Now to my frustration when I try to boot from this DVD, nothing happens - it just sits at a blank screen. I checked the BIOS to ensure that the boot from DVD is the first operation and indeed I can hear the DVD drive being accessed, simply nothing further happens

    This is also the case if I try booting from this DVD or the previous bootable maintenance image ( that I had previously booted from and which you advised was the wrong one but at least at that stage it was bringing up a menu - it is no longer even doing that ).

    I even tried swapping in a new virgin hard disk but in that case, whilst the device is recognised ( some PIX messages put on screen ) and you can again hear the DVD drive being accessed again nothing further happens ( if fact for the new DVD that I burnt it comes up with 'Non System Disk' )

    All very frustrating ! I am no fan of windows but at least a bootable disk is simple as pie !

    Any thoughts ?
  • 7. Re: repomd.xml not found on OEL 6-3 install
    Jimbo Explorer
    Currently Being Moderated
    I reset the BIOS to factory defauts and tried again. This time the bootable maintenance DVD brings up a menu but the DVD you said is the correct one to use simply bring up 'Non System Disk or Disk Error' - are you sure this DVD is actually bootable ( the readme would appear to suggest it is )
  • 8. Re: repomd.xml not found on OEL 6-3 install
    Dude! Guru
    Currently Being Moderated
    The binary distribution DVD's are bootable and contain the software distribution. The following DVD's:

    Oracle Linux Release 6 Update 3 for x86 (32 Bit) V33415-01 (3 GB)
    Oracle Linux Release 6 Update 3 for x86_64 (64 Bit) V33411-01 (3.5 GB)

    There are as usually a number of things that can go wrong. In order to use these DVD's you should check the following:

    Verify the downloaded ISO image is complete: You can click the "View Digest" button on the Oracle eDelivery web page next to the download to obtain the the MD5 or SHA-1 checksums. I assume you are using MS Windows. See http://support.microsoft.com/kb/841290 how to perform a checksum integrity check. If you are on Linux or Mac OSX, open a Terminal: openssl sha1 filename.

    Burn the raw ISO image: It is important to burn the ISO image directly and not it's possibly mounted volume, which will not contain the boot header. How you burn an ISO image depends on your software. There are plenty of examples and software available, e.g.: http://www.wikihow.com/Burn-ISO-Files-to-DVD

    Verify your BIOS settings: Check your computer BIOS to verify that the CD/DVD device is set with a higher boot priority as any other devices. For startup performance reasons, this may not always be the case.
  • 9. Re: repomd.xml not found on OEL 6-3 install
    Jimbo Explorer
    Currently Being Moderated
    thanks,

    I downloaded the 32 bit version.
    I just used the native Windows Disc Image Burner that comes with my Win 7 professional desktop
    Indeed the BIOS on the server onto which I am installing has the CD drive as the first bootable source.
    I even copied the contents of the DVD that was burned and tried a boot from an USB hard drive - got the same message concerning a non system disk

    I guess that just leaves checking the Digest - I will do that

    Jim
  • 10. Re: repomd.xml not found on OEL 6-3 install
    Dude! Guru
    Currently Being Moderated
    I just used the native Windows Disc Image Burner that comes with my Win 7 professional desktop
    http://windows.microsoft.com/en-US/windows7/Burn-a-CD-or-DVD-from-an-ISO-file
    I even copied the contents of the DVD that was burned and tried a boot from an USB hard drive - got the same message
    That won't work since you cannot copy the hidden boot code.
  • 11. Re: repomd.xml not found on OEL 6-3 install
    Jimbo Explorer
    Currently Being Moderated
    hmmm - can't say definitively ( without checking the SHA or MD5 ), but I am not convinced the source image is right for the OEL 6-3 download. I downloaded it again and got the exact same byte size as the first time I downloaded it. Also I downloaded OEL 6-2 instead and guess what - installed first time, no problems !
  • 12. Re: repomd.xml not found on OEL 6-3 install
    Dude! Guru
    Currently Being Moderated
    Nobody said you should be using the source image, which is not bootable. Why don't you check the SHA checksum? It's faster and more reliable than downloading it again.

    The standard Oracle Linux 6.3 installation DVD's, which I previously outlined are bootable.
  • 13. Re: repomd.xml not found on OEL 6-3 install
    Jimbo Explorer
    Currently Being Moderated
    Thanks - bad terminology on my behalf ( in fact shockingly bad ! ). I didn't really mean the 'source' dvd but rather the 3 Gb install download. Yes I will check the SHA checksum and see what I find
  • 14. Re: repomd.xml not found on OEL 6-3 install
    Sebbes Newbie
    Currently Being Moderated

    Hi Jim/everyone who has this problem,

     

    I just want to share my experience and we overcame this issue. Whenever we installed OEL via an iso or DVD the installation went fine, however via network (in our case http) it did not, we got the above mentioned error. After some digging I found the issue was caused by a missing symlink. in the root of the installation folder there is symlink for repodata pointing to Server/repodata. The problem was caused on our side by a Microsoft NAS server which was Fat32 formatted; it does not support softlinks/symlinks. When we tried the installation off my Fedora machine it went fine. Hope this helps anyone who runs into the same issue.

     

    Regards,

    Sebastian

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points