This discussion is archived
12 Replies Latest reply: Jun 10, 2013 2:21 PM by Admin1001 RSS

urgent asm not starting up with ora 1031..!!!

960521 Newbie
Currently Being Moderated
Hi Guys,
Stuck with a problem not sure how to proceed...cluster services doesnot comeup.....tried staring using crsctl start cluster -n node gives me the below i missing anything here...Can anybody please help me on this....

[node+ASM1:root] crsctl start cluster -n node
CRS-2672: Attempting to start 'ora.asm' on 'node'
ORA-01031: insufficient privileges
CRS-5017: The resource action "ora.asm start" encountered the following error:
ORA-01031: insufficient privileges
. For details refer to "(:CLSN00107:)" in "/u01/app/".
CRS-2674: Start of 'ora.asm' on 'node' failed
CRS-2679: Attempting to clean 'ora.asm' on 'node'
ORA-01031: insufficient privileges
CRS-2681: Clean of 'ora.asm' on 'node' succeeded
CRS-4705: Start of Clusterware failed on node node.
CRS-4000: Command Start failed, or completed with errors.

crsctl check crs shows me the following...

CRS-4638: Oracle High Availability Services is online
CRS-4535: Cannot communicate with Cluster Ready Services
CRS-4529: Cluster Synchronization Services is online
CRS-4534: Cannot communicate with Event Manager

tried starting asm manually...but says insufficient privileges...

[node:+ASM1:grid] echo $ORACLE_HOME
[node:+ASM1:grid] echo $ORACLE_SID

node:+ASM1:grid] sqlplus "/as sysdba"

SQL*Plus: Release Production on Sat Dec 8 15:21:21 2012

Copyright (c) 1982, 2011, Oracle. All rights reserved.

Connected to an idle instance.

SQL> startup
ORA-01031: insufficient privileges

Grid has the following privileges

[node:+ASM1:grid] id
uid=501(grid) gid=501(oinstall) groups=501(oinstall),502(dba),504(asmadmin),506(asmdba),507(asmoper)

[node:ipdexdev1:oracle] id
uid=502(oracle) gid=501(oinstall) groups=10(wheel),501(oinstall),502(dba),506(asmdba)

The other node is working fine...compared the privs they are the same on other node too...


  • Correct Answers - 10 points
  • Helpful Answers - 5 points