This content has been marked as final. Show 1 reply
meandmycode wrote:Depends on how complicated were you planning to make it.
I wonder if this interface will grow too big with operations.
Or is it better to have more that one interface?Well it certainly is easier to have 5 interfaces with 20 methods instead of 1 interface with 100 methods.
For example a grahicoperations() and audioperations(). The drawback with this is that I could have redundant methods.Redundant methods aren't a drawback, and if they are it means your design is poor. I don't see how GraphicsOperations and AudioOperations would have methods in common.
I don't have much experience of providing a public api so any pointers hints or personal experience is appreciated.If you don't have experience doing it, maybe you shouldn't be the one doing it?
You seem to be confusing even the nomenclature, proposing "graphicoperations()" as a name for an interface, when it's clearly a method's name. That would mean that you don't have the experience required to create something that would be of great use. Nothing personal here.