2 Replies Latest reply: Dec 10, 2012 4:00 AM by 843489 RSS

    Essbase with ODBC

      Hello gurus!

      I installed and configured Oracle Hyperion Essbase on DB Oracle 11g in the same server. After I created the new ODBC connection using oracle driver and test connection in ODBC driver configuration was successfull. But when I try to connect to DB in EAS Console I get the next error in essbase logs:

      [2012-12-10T12:01:29.955+03:00] [HRN] [NOTIFICATION:16] [SQL-4] [] [ecid: 1355130037965,0] [tid: 6252] Connection String is generated
      [2012-12-10T12:01:29.955+03:00] [HRN] [NOTIFICATION:16] [SQL-41] [] [ecid: 1355130037965,0] [tid: 6252] Connection String is [DSN=AS2403_CL;UID=...;PWD=...;]
      [2012-12-10T12:01:29.955+03:00] [HRN] [NOTIFICATION:16] [SQL-6] [] [ecid: 1355130037965,0] [tid: 6252] SELECT Statement [SELECT * FROM map_articles] is generated
      [2012-12-10T12:01:30.401+03:00] [HRN] [NOTIFICATION:16] [SQL-13] [] [ecid: 1355130037965,0] [tid: 6252] ODBC Layer Error: [IM004] ==> [[Microsoft][ODBC Driver Manager] Driver's SQLAllocHandle on SQL_HANDLE_ENV failed]
      [2012-12-10T12:01:30.401+03:00] [HRN] [NOTIFICATION:16] [SQL-14] [] [ecid: 1355130037965,0] [tid: 6252] ODBC Layer Error: Native Error code [0]
      [2012-12-10T12:01:30.402+03:00] [HRN] [ERROR:32] [SQL-1] [] [ecid: 1355130037965,0] [tid: 6252] Failed to Establish Connection With SQL Database Server. See log for more information
      [2012-12-10T12:01:30.406+03:00] [HRN] [WARNING:1] [TMG-14] [] [ecid: 1355130037965,0] [tid: 6252] Transaction [ 0x320001( 0x50c5a4e9.0xe5bc8 ) ] aborted due to status [1021001].

      I applied the next solution:

      1. Select Administration Tools , Local Security Setting and Local Policy.
      2. Then select "User Rights Assignment"
      3. Double click on "Create Global Objects"
      4. Select Add User or Group.
      5. Make sure Object Types Group Box is checked.
      6. Select Locations and highlight the name of the server you are working on (Not the Domain).
      7. Enter "Remote Desktop Users" or "Everyone" (without the quotes) into the Object Names Box.
      8. Select OK.
      9. Add the same users to the group "Power User".
      10. If this does not work, after step 8 a reboot may be required.

      but my problem was not resolved.
      Do you have any ideas?

      Edited by: user8886268 on 10.12.2012 1:17