This discussion is archived
1 2 Previous Next 21 Replies Latest reply: Dec 11, 2012 12:04 AM by Gus C Go to original post RSS
  • 15. Re: Tabular Form Not Working After Upgrade to 4.2
    Gus C Journeyer
    Currently Being Moderated
    Yes, no error on oracle .com.
    I tried your suggestion but still got the same problem.
    Here is the html for the date picker. It is different to the other items
    <td class="t15data" style="background-color:#00CC00;">
    <label class="hideMeButHearMe" for="f04_0002">Value Date#ROW_HEADER#</label>
    <span style="white-space: nowrap;">
    <input id="f04_0002" class="hasDatepicker" type="text" autocomplete="off" value="" size="15" maxlength="2000" name="f04">
    <img class="ui-datepicker-trigger" src="/u/asfdcldr.gif" alt="Popup Calendar: Value Date" title="Popup Calendar: Value Date">
    </span>
    </td>
    Seems to have an extra span tag

    Gus
  • 16. Re: Tabular Form Not Working After Upgrade to 4.2
    Arie Geller Guru
    Currently Being Moderated
    Hello Gus,

    >> Seems to have an extra span tag

    I wouldn’t worry about an extra span tag. This code includes a valid input item (f04_0002), which in turn will be populated into G_F04, so your PL/SQL code should work again.

    You didn’t specify the origin of the code. Is it from your own workspace? If so, are you still getting the error?

    Regards,
    Arie.


    -------------------------------------------------------
    &diams; Please remember to mark appropriate posts as correct/helpful. For the long run, it will benefit us all.

    &diams; Author of Oracle Application Express 3.2 – The Essentials and More
  • 17. Re: Tabular Form Not Working After Upgrade to 4.2
    Gus C Journeyer
    Currently Being Moderated
    The code was from my dev system.
    Dev system
    <td class="t15data" style="background-color:#00CC00;">
    <label class="hideMeButHearMe" for="f04_0001">Value Date#ROW_HEADER#</label>
    <span style="white-space: nowrap;">
    <input id="f04_0001" class="hasDatepicker" type="text" autocomplete="off" value="03.12.2012" size="15" maxlength="2000" name="f04">
    <img class="ui-datepicker-trigger" src="/u/asfdcldr.gif" alt="Popup Calendar: Value Date" title="Popup Calendar: Value Date">
    </span>
    </td>
    Still getting the error
    ORA-20000: g_f05 is empty/no present.

    On oracle.com
    <td class="t15data" style="background-color:#00CC00;">
    <fieldset id="f04_0001_fieldset" class="datepicker">
    <table id="f04_0001_holder" class="datepicker" cellspacing="0" cellpadding="0" border="0" summary="">
    <tbody>
    <tr>
    <td class="datepicker">
    <input id="f04_0001" type="text" value="12.01.2012" maxlength="2000" size="15" name="f04">
    </td>
    <td>
    </tr>
    </tbody>
    </table>
    </fieldset>
    </td>
    I don't see why html being generated on my dev is different
    Gus
  • 18. Re: Tabular Form Not Working After Upgrade to 4.2
    Arie Geller Guru
    Currently Being Moderated
    Hello Gus,

    >> I don't see why html being generated on my dev is different /…

    The code from your dev consistent with a Display As of type Date Picker, while the code from apex.oracle.com consistent with a Display As of type Date Picker (Classic). Did you change the Display As field on apex.oracle.com?

    >> Still getting the error ORA-20000: g_f05 is empty/no present.

    It’s entirely possible that the NO DATA FOUND exception is not emanating from a problem with the G_Fxx arrays and it just echo the last value t_arr and t_val were assigned.

    Did you try to run the page in Debug mode? It may give you a better understanding on the source of the exception.

    Regards,
    Arie.

    -------------------------------------------------------
    &diams; Please remember to mark appropriate posts as correct/helpful. For the long run, it will benefit us all.

    &diams; Author of Oracle Application Express 3.2 – The Essentials and More
  • 19. Re: Tabular Form Not Working After Upgrade to 4.2
    Gus C Journeyer
    Currently Being Moderated
    You were right about my html code. I forgot to change the date picker on oracle.com.
    I ran my page in debug, but not a lot of help.

    Every thing is ok until it runs my update process. Then I get
    ..Process "pr_230_update_params" - Type: PLSQL
    
    Execute Statement: begin declare v_count_failed number := 0; v_count_updated number := 0; v_count_failed2 number := 0; v_count_updated2 number := 0; begin for i in 1 .. apex_application.g_f01.COUNT loop --{ if wwv_flow_item.md5(apex_application.g_f01(i) ,apex_application.g_f02(i) ,apex_application.g_f03(i) ,apex_application.g_f04(i) ,apex_application.g_f05(i)) <> apex_application.g_fcs (i) then --{ p_sup_mnt_apx.pr_230_update_params( :P230_SYSTEM ,:P230_CONFIG ,:P230_JOBNAME ,apex_application.g_f01 (i) -- pi_parameter ,apex_application.g_f05 (i) -- pi_param_set ,apex_application.g_f02 (i) -- pi_value_char ,apex_application.g_f03 (i) -- pi_value_number ,to_date(apex_application.g_f04 (i),'dd.mm.yyyy') -- pi_value_date ,apex_application.g_fcs (i) --pi_checksum ,v_count_failed ~
    
    Add error onto error stack
    ...Error data:
    ......message: Mist...
    ......additional_info: ORA-01403: no data found
    ......display_location: ON_ERROR_PAGE
    ......is_internal_error: false
    ......ora_sqlcode: 100
    ......ora_sqlerrm: ORA-01403: no data found
    ......error_backtrace: ORA-06512: at line 16 ORA-06512: at "SYS.DBMS_SYS_SQL", line 1204 ORA-06512: at "SYS.WWV_DBMS_SQL", line 973 ORA-06512: at "SYS.WWV_DBMS_SQL", line 999 ORA-06512: at "APEX_040200.WWV_FLOW_DYNAMIC_EXEC", line 806 ORA-06512: at "APEX_040200.WWV_FLOW_PROCESS", line 138 
    ......component.type: APEX_APPLICATION_PAGE_PROCESS
    ......component.id: 1418519680901853
    ......component.name: pr_230_update_params
    ...Show Error on Error Page
    ......Performing rollback
    Gus
  • 20. Re: Tabular Form Not Working After Upgrade to 4.2
    Arie Geller Guru
    Currently Being Moderated
    Hello Gus,

    I looked at your application on apex.oracle.com.

    It seems that your Tabular Form doesn’t include the fcs column you are referencing in your update process.

    How did you create this form? Did you use the Tabular Form wizard, or did you do it manually? Can you check if this (hidden) column exists on your instance?

    Regards,
    Arie.

    -------------------------------------------------------
    &diams; Please remember to mark appropriate posts as correct/helpful. For the long run, it will benefit us all.

    &diams; Author of Oracle Application Express 3.2 – The Essentials and More
  • 21. Re: Tabular Form Not Working After Upgrade to 4.2
    Gus C Journeyer
    Currently Being Moderated
    I have re-built the report using APEX_ITEM and it works.
    Thanks for all your help

    Gus
1 2 Previous Next

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points