6 Replies Latest reply: Oct 8, 2013 10:59 PM by b9d42b30-6870-44cc-929d-9f5c14cf06ed RSS

    oepe juno 4.3 support

    978757
      When is there going to be an all-in-one-bunde for eclipse 4.3?

      I tried to add oepe plugin to eclipse 4.3 sdk and it gave me a strange error and would not let me install oepe plugin.

      Edited by: SamuelMager on Dec 8, 2012 9:06 AM
        • 1. Re: oepe juno 4.3 support
          kosta
          Do you mean Eclipse 4.2? Eclipse 4.3 is part of the Kepler release for June of 2013 and there is no OEPE support for that version yet.

          Eclipse 4.2 is a less stable platform than Eclipse 3.8, which has all of the same features. There are no plans to produce OEPE distros with Eclipse 4.2, but the combination is supported and tested by Oracle. For best results, start with Eclipse IDE for Java EE Developers distro that you can find on the eclipse.org download site. Installing OEPE into a different distroy can be more difficult due to unsatisfied dependencies.

          - Konstantin
          • 2. Re: oepe juno 4.3 support
            gstachni-Oracle
            We will start producing OEPE builds on Eclipse Kepler Milestone releases next year (in the past it has been around the March/April time frame) but whether this will be on Eclipse 3.x or 4.x is still being evaluated.

            Thanks,
            Greg
            • 3. Re: oepe juno 4.3 support
              978757
              First I download eclipse-jee-kepler-M3-win32.

              Second I tried to install via update
              http://download.oracle.com/otn_software/oepe/juno

              NOTE: There is no http://download.oracle.com/otn_software/oepe/kepler

              When tried to install OEPE JUNO via update I got this dependency error:

              Cannot complete the install because one or more required items could not be found.
              Software being installed: Oracle WebLogic Server Tools 2.2.0.201211211917 (oracle.eclipse.tools.juno.weblogic.feature.group 2.2.0.201211211917)
              Missing requirement: Oracle WebLogic Web Services Tools UI 5.2.0.201211211917 (oracle.eclipse.tools.webservices.ui 5.2.0.201211211917) requires 'bundle org.eclipse.jdt.ui [3.8.0,3.9.0)' but it could not be found
              Cannot satisfy dependency:
              From: Oracle WebLogic Server Tools 2.2.0.201211211917 (oracle.eclipse.tools.juno.weblogic.feature.group 2.2.0.201211211917)
              To: oracle.eclipse.tools.webservices.ui [5.2.0.201211211917]

              I have real development to do at work.

              I am switching back to Eclipse Juno OEPE all-in-one-bundle.

              I don't have time to figure out how to make Eclipse Kepler work with OEPE plugin.

              I like the new UI I see in Kepler. And I am excited to use Kepler once the OEPE plugin can work with Kepler.

              We use WebLogic and I need to use the OEPE so I can start and stop WebLogic.

              I hope you make OEPE available on the 4.3 branch since that seems to be the one with the new UI.

              Edited by: SamuelMager on Dec 11, 2012 1:46 PM
              • 4. Re: oepe juno 4.3 support
                gstachni-Oracle
                Hi,

                Yes, please continue to use OEPE with Eclipse Juno as we have not started supporting Eclipse Kepler yet.

                Thanks,
                Greg
                • 5. Re: oepe juno 4.3 support
                  978757
                  The question is answered.

                  I really can use OEPE for Kepler