12 Replies Latest reply on Dec 11, 2012 11:13 PM by 441858

    RMAN backup unable to write to share

      Oracle 11gR2 OEL5 64bit

      I am unable to execute my backups because the files cannot be written to the NFS share. The share has been mounted with 'oracle:oinstall' and '777' for permissions. However, I still get the following error:
      ORA-19504: failed to create file "/rman/backup/prod/ctrl_file.bckp"
      ORA-27040: file create error, unable to create file
      Linux-x86_64 Error: 22: Invalid argument
      I have researched different mount option on ML and I have tried them also, but I still get the same issue. It's weird because the last time I did this it worked and it was also able read and recover the files from the share.

      Is there a mount option out there that works so that RMAN can write to an NFS share?

      I used the following opton:
      mount -t cifs -o username=winorcl,rw,dir_mode=0777,file_mode=0777,uid=1003,gid=1003 //myshare/oracletmp /rman/backup/prod/
      Just some more info. The 'winorcl' user has full RWX privs on the share. The uid and gid are for 'oracle' and 'oinstall' which in this case are the same.

      Thank you.