Linux 6 multipath

user10122998
    Hi, I'm a newbie and have a question about bindings file on Linux 6.
    We're migrating our server from Linux 5.4 to Linux 6.3. Both environments have direct attach storage, no SAN
    Even though we're not using multipath, but we noticed the bindings file exists in version 6.3 and not version 5.4.

    This is the version 6.3 /ect/multipath/bindings looks like:

    # Multipath bindings, Version : 1.0
    # NOTE: this file is automatically maintained by the multipath program.
    # You should not need to edit this file in normal circumstances.
    #
    # Format:
    # alias wwid
    #
    mpatha 3600508b1001c4d8881330e7027020cab


    However this WWID belongs to an internal device.

    Can you please help explain why this is happening in 6.3?

    Second question, in the case if we use multipath for SAN in Linux 6.3 and want to exclude this mpath from the bindings file, is it recommended or even possible and how?

    Thank you in advance.
      • 1. Re: Linux 6 multipath
        Billy~Verreynne
        Not using Linux 6 as yet (we need RAC certified kernels), but are using multipath extensively.

        This issue you raised - is there some kind of problem that you expect from having a mpath device?

        Is the multipathd service enabled? What is the contents of +/etc/multipath.conf+ ? (you can easily blacklist that WWID if needed)

        Can you post the result of a multipath -l (listing) command?
        • 2. Re: Linux 6 multipath
          Avi Miller-Oracle
          Billy  Verreynne  wrote:
          Not using Linux 6 as yet (we need RAC certified kernels), but are using multipath extensively.
          Slightly off-topic, but both Standalone DB and RAC are both certified on Oracle Linux 6 and have been for a while now.
          • 3. Re: Linux 6 multipath
            Billy~Verreynne
            Thanks Avi. :-)

            Have not checked for a while as there is no real opportunity for upgrading or using Linux 6 this side of the pond.
            • 4. Re: Linux 6 multipath
              898553
              This isn't uncommon at all. Any scsi device has the potential to show up and be scanned by DM-Multipath. What I'd suggest doing is running:

              scsi_id whitelisted replace-whitespace --device=/dev/<device>

              where <device> is/are your local disk(s) and blacklist by WWID.
              • 5. Re: Linux 6 multipath
                user10122998
                The server only has direct attach scsi disks and no SAN, multipath is turned off (see below). I'm trying to understand why i still get an mpath entry for my /u01 folder? Doesn't DM-multipath need to be active for mpath devices to get generated?


                [oracleuser@servername ~]$ multipath -l
                -bash: multipath: command not found
                [oracleuser@servername ~]$

                [oracleuser@servername ~]$ sudo multipath -l
                [oracleuser@servername ~]$

                [oracleuser@servername ~]$ sudo cat /etc/multipath.conf
                cat: /etc/multipath.conf: No such file or directory
                [oracleuser@servername ~]$

                [oracleuser@servername ~]$ sudo locate multipath.conf
                [oracleuser@servername ~]$

                [oracleuser@servername ~]$ sudo service multipathd status
                multipathd: unrecognized service
                [oracleuser@servername ~]$
                • 6. Re: Linux 6 multipath
                  898553
                  The device is picked up by device mapper which is why it's showing up.
                  • 7. Re: Linux 6 multipath
                    user10122998
                    Thanks theanswriz42

                    It turned out I had a blacklist in the multipath.conf file which was out dated (it looks like it came from ver. 0.4.7) and we have ver. 0.4.9 installed...not sure how that happened. Anyway, once I updated the blacklist with the WWID like you suggested, the scsi device removed from the bindings file.

                    Also, thanks everyone else for taking your time to response to the question.