1 Reply Latest reply on Dec 12, 2012 6:03 AM by fatehcis-JavaNet

    Interactive Report will not save BLOB Column Attributes

      I have created many interactive reports with 4.0 and 4.1 that had BLOB columns with no problems and the download link worked fine. After upgrading to 4.2, the interactive reports get the following error when clicking on the download link:
      Not found
      The requested URL /apex/apex_util.get_blob was not found on this server

      If I open the edit page from the report, the BLOB downloads fine. When I looked at the report attributes details for the BLOB column, I noticed the BLOB Column Attributes had not been populated. I have tried repeatedly to populate them (Table Name, Column Name, Primary Key, MIMETYPE, etc.) but after applying the changes and reopening the attributes page for the blob column, the values I entered are not saved.
      For completeness, here is the select statement for the report:
      select "DESC_ATT_ID",
      dbms_lob.getlength("DESC_ATTACHMENT") "DESC_ATTACHMENT"
      from "#OWNER#"."ALTEC_BR_DESC_ATT"
      WHERE BR_ID = :P3_BR_ID

      Also, here is the value for the Number/Date format for the BLOB Column:

      Can someone please point me in the right direction to get the link for the interactive report working properly?
      Many thanks,
        • 1. Re: Interactive Report will not save BLOB Column Attributes
          How about you do not use BLOB format Column, you do it manually as this example here:

          workspace: somefeto
          user: test
          pwd: test
          Application 63066

          in the same workspace, there is      Sample File Upload and Download (App ID 10540), and it is working fine ....

          Otherwise, Pls, reproduce the problem on apex.oracle.com

          Best Regards,
          If you believe that my answer is correct or helpful to you, then pls, mark the answer as helpful or correct