This discussion is archived
4 Replies Latest reply: Dec 16, 2012 10:36 PM by 959059 RSS

OGL balance not loading when creating new dimension

959059 Newbie
Currently Being Moderated
Hello Grus

Can some one please help with the following issue.

We are trying to transfer OGL balances into Hyperion planning application and it works fine with the standard dimension i.e Account, Entity, Period, Scenario, Year, Alias and Version. The problem is when we create a new dimension with a dimension type as "Generic", thats when the OGL balances are NOT loading into the application....Can someone please help us out..

Can we create a dimension which doesn't have mapping to Oracle GL segments?

Your help will be appreciated. Thanks

Regards
  • 1. Re: OGL balance not loading when creating new dimension
    Agnete Explorer
    Currently Being Moderated
    You don't say anything about how you are loading the data into Planning, nor exactly what you mean when you say not loading (do you get any errors, or do you simply not see any data where you would expect it to be).

    Here are a couple of things you need to consider: If you change your planning application and you add a dimension, and you are using an ETL rule in Oracle Data Integrator, Informatica or any other tool (even loadrules) then these ETL rules need to be updated to reflect that you have a new dimension. Remember that to load any single data point into an application you need to specify one member from each dimension to indicate what intersection you want to load that data at. If you have added a new dimension then you need to add one member from that dimension to your loaddefinition to be able to load correctly. If the new dimension has no bearing on the data you are loading from your General Ledger then you should have a member in your new dimension called something like no <newdimname>


    I hope this give you something to work with, but you will need to be a lot more specific about exactly what you are doing, what products you are using to load, and exactly what error behaviour you are seeing for us to be able to assist you better.
  • 2. Re: OGL balance not loading when creating new dimension
    959059 Newbie
    Currently Being Moderated
    Hi Agnete,

    Thank you for the reply.

    We have the following dimensions
    1 - Account (Mapped to GL Account Segment)
    2 - Period (Mapped to GL Calendar)
    3 - Scenerio
    4 - Entity (Mapped to GL Branch Segment)
    5 - CRC (Mapped to GL Cost Center Segment)
    6 - Year
    7 - Version (Mapped to a single GL Ledger)
    8 - Product (Mapped to GL Product Segment)
    9 - Others (Unmapped to any GL Segments) - Dimension Type: Generic

    The "Others" dimension is a local dimension which is only used for categorization of data in Hyperion only. This dimension has no link to GL. It is for use in Hyperion data forms only.

    We are integrating Oracle Hyperion with Oracle General Ledger. To accomplish this, we have used ODI and ERP Integrator for standard mappings.
  • 3. Re: OGL balance not loading when creating new dimension
    Agnete Explorer
    Currently Being Moderated
    Hi

    When you are loading the data into Planning from another place, even if there isn't a mapping directly from your GL to your Planning dimension, the ETL is providing some sort of mapping to the remaining unmapped dimensions (either implicit or explicit) as otherwise it wouldn't be able to fix an intersection to put the data into. Therefore you need to check how your ETL is set up exactly and you will probably see that it is still providing information about the Scenario (most likely some scenario referring to Actuals) to load to and the year to load to. Once you add a new dimension the ETLs and integrations therefore will have to be updated to include the Others dimension.



    Your others dimension may for example need to be something like this:

    Others- Member1-Member11
    -Member12
    - NoOthers

    In which case the ETL has to define NoOthers as the member to load to, as No others simply implies that this particular dimension is not relevant for the dataset you are loading.

    You will need to look at the ODI and ERPi integrations and include the others dimension.

    You still didn't tell me whether you are seeing errors on running the integration. If it completes successfully and you still aren't seeing any data then it could be possible that the ETL is implicitly loading to the hierarchy top of Others. In which case you would see your loaded data if you look for it in the intersections with Others

    Ie one member from each dimension where you would normally expect the data to be AND Others.

    In any case it is much preferable to update your ETLs and explicitly state where in the others dimension you want the data to reside.

    Agnete
  • 4. Re: OGL balance not loading when creating new dimension
    959059 Newbie
    Currently Being Moderated
    Agnete
    Thanks you so much for your reply. Is it possible if you can share your email addy or chat link so that its easier for us to communicate and explain you the real problem...
    Many thanks

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points