3 Replies Latest reply on Dec 17, 2012 1:17 AM by ksunil

    lib/mod_wl.so failed

      This is on Solaris which returns the following for "uname -a", SunOS myMachine 5.11 11.0 sun4v sparc SUNW,T5240

      We are trying to put "Oracle iPlanet Web Server 7.0" in front of the above machine. We downloaded the plugins and setup the iPlanet server and all that. While starting the server, we keep getting

      failure: CORE2253: Error running Init function load-modules: dlopen of /test/Arch/WLS_Plugin_SPARC/lib/mod_wl.so failed (ld.so.1: webservd: fatal: libapr-1.so.0: open failed: No such file or directory)

      We then tried to run "ldd mod_wl.so" and it reported many failures. We updated the LD_LIBRARY_PATH to include the /test/Arch/WLS_Plugin_SPARC/lib and /test/Arch/iPlanetWS/lib/sparcv9 and now we can run "ldd mod_wl.so" without any issues. However, when we try to start the iPlanet server, it still gives the same error as above (libapr-1.so.0: open failed)
        • 1. Re: lib/mod_wl.so failed
          René van Wijk
          Maybe this can help: http://docs.oracle.com/cd/E23943_01/web.1111/e16435/iplanet.htm#PLGWL537 and
          - http://www.doxer.org/learn-linux/resolved-ld-so-1-httpd-fatal-libaprutil-0-so-0-open-failed-no-such-file-or-directory/

          "When I tried to start up IBM http server on my Solaris, I met this error message:
          ld.so.1: httpd: fatal: libaprutil-0.so.0: open failed: No such file or directory

          This error was caused by library libaprutil-0.so.0 can not be found in the current library path environment variable.
          We should add /apps/IBMHTTPD/Installs/IHS61-01/lib to LD_LIBRARY_PATH to make libaprutil-0.so.0 be seen by ld.

          Here goes the resolution:
          #export LD_LIBRARY_PATH=/apps/IBMHTTPD/Installs/IHS61-01/lib:$LD_LIBRARY_PATH #set environment variable
          #/apps/IBMHTTPD/Installs/IHS61-01/bin/httpd -d /apps/IBMHTTPD/Installs/IHS61-01 -d /apps/IBMHTTPD/Installs/IHS61-01 -f /apps/IBMHTTPD/Installs/IHS61-01/conf/ihs.conf -k restart #restart IHS
          #/usr/ucb/ps auxww|grep -i ibmhttpd
          #check the result"
          • 2. Re: lib/mod_wl.so failed
            We know about LD_LIBRARY_PATH. That is now set correctly. And I can do a "ldd mod_wl.so" without any issues which to me says that LD_LIBRARY_PATH is correct. We came to this forum after doing a google search for the issue

            Edited by: ksunil on Dec 13, 2012 6:56 AM
            • 3. Re: lib/mod_wl.so failed
              apparently, we need LD_LIBRARY_PATH_64 and not LD_LIBRARY_PATH. Works now!