9 Replies Latest reply: Jan 10, 2013 6:22 AM by Fabian RSS

    deployment problem on weblogic server 10.3.3.0

    Masood
      Hi
      When I try to deploy a sample application from jdeveloper 11g R2 to weblogic server 10.3.3.0, I get the following error
      03:36:50 PM] Wrote Web Application Module to C:\JDeveloper\mywork\10mindemo\ViewController\deploy\10mindemo_ViewController_webapp.war
      [03:36:50 PM] WARNING: Connection ApplicationDB has no password. ApplicationDB-jdbc.xml file not generated for connection ApplicationDB.
      [03:36:50 PM] WARNING: Connection application has no password. application-jdbc.xml file not generated for connection application.
      [03:36:51 PM] Wrote Enterprise Application Module to C:\JDeveloper\mywork\10mindemo\deploy\10mindemo_Project1_10mindemo.ear
      [03:36:52 PM] Redeploying Application...
      [03:36:53 PM] [Deployer:149193]Operation 'deploy' on application '10mindemo_Project1_10mindemo' has failed on 'AdminServer'
      [03:36:53 PM] [Deployer:149034]An exception occurred for task [Deployer:149026]deploy application 10mindemo_Project1_10mindemo on AdminServer.: [J2EE:160149]Error while processing library references. Unresolved application library references, defined in weblogic-application.xml: [Extension-Name: oracle.adf.desktopintegration.model, exact-match: false]..
      [03:36:53 PM] Weblogic Server Exception: weblogic.management.DeploymentException: [J2EE:160149]Error while processing library references. Unresolved application library references, defined in weblogic-application.xml: [Extension-Name: oracle.adf.desktopintegration.model, exact-match: false].
      **[03:36:53 PM] See server logs or server console for more details.**
      **[03:36:53 PM] weblogic.management.DeploymentException: [J2EE:160149]Error while processing library references. Unresolved application library references, defined in weblogic-application.xml: [Extension-Name: oracle.adf.desktopintegration.model, exact-match: false].**
      **[03:36:53 PM] Deployment cancelled.**
      **[03:36:53 PM] ---- Deployment incomplete ----.**
      **[03:36:53 PM] Remote deployment failed (oracle.jdevimpl.deploy.common.Jsr88RemoteDeployer)**

      Please advice me where is the error or if I have to install any other relevant software on weblogic server 10.3.3.0 or in jdeveloper11gR2.
      Your suggestion in this regard will really help me.
      Masood
      from Abu Dhabi - UAE
        • 1. Re: deployment problem on weblogic server 10.3.3.0
          978049
          Seems like server misses some library you are using in yor project. Try to add libraries to your WEB-INF/lib folder or check if you need to deploy some application as library on application server you are deploying application on.
          • 2. Re: deployment problem on weblogic server 10.3.3.0
            Masood
            Hi
            WEB-INF/lib folder - on weblogic server or jdeveloper side?

            The following items are installed on weblogic server.

            1. Weblogic server 10.3.3.0
            2. ADR (Oracle Application Development runtime) 11.1.1.2.0
            3. ADR ( " " ) 11.1.1.3.0

            Pls let me know, if i have to install anything else on server side or this much is sufficient to deploy and application from jdeveloper version R2 11.1.2.3.0

            Waiting.......

            Regards,
            Masood
            • 3. Re: deployment problem on weblogic server 10.3.3.0
              anjhawar - oracle
              The missing library in your case is:
              "oracle.adf.desktopintegration.model"

              This is normally located under:
              ..\jdev\oracle_common\modules

              Options:

              You can access you WLS admin console and check whether there is any application deployed with this name, if yes whats the state of the same.. It has to be active if its there.
              If this library is not there then you can manually deploy the same using the admin console from the above mentioned location. Once you this library I think this application should work for you.

              Alternatively you can import the required libraries for the application using JDev studio, and this would move all the application required libraries to the web-inf\lib.

              HTH,
              AJ
              • 4. Re: deployment problem on weblogic server 10.3.3.0
                Masood
                Thank you for your help but the result is still the same.
                I deployed the library on weblogic server suggested by you.

                File Deployed as library = oracle.adf.desktopintegration.model.ear

                From the folder = C:\Oracle\Middleware\oracle_common\modules\oracle.adf.desktopintegration.model_11.1.1

                It is active.
                After this I loaded jdeveloper and deploy the same sample application and found that the result is same.
                Pls let me know where I am going wrong.
                Regards,
                Masood

                [11:53:09 AM] ---- Deployment started. ----
                [11:53:09 AM] Target platform is (Weblogic 10.3).
                [11:53:09 AM] Retrieving existing application information
                [11:53:09 AM] Running dependency analysis...
                [11:53:09 AM] Building...
                [11:53:09 AM] Deploying 2 profiles...
                [11:53:09 AM] Wrote Web Application Module to C:\JDeveloper\mywork\10MinDemo\ViewController\deploy\10MinDemo_ViewController_webapp.war
                [11:53:10 AM] Wrote Enterprise Application Module to C:\JDeveloper\mywork\10MinDemo\deploy\10MinDemo_Project1_10MinDemo.ear
                [11:53:10 AM] Deploying Application...
                [11:53:10 AM] [Deployer:149191]Operation 'deploy' on application '10MinDemo_Project1_10MinDemo' is initializing on 'ADFServer'
                [11:53:11 AM] [Deployer:149193]Operation 'deploy' on application '10MinDemo_Project1_10MinDemo' has failed on 'ADFServer'
                [11:53:11 AM] [Deployer:149034]An exception occurred for task [Deployer:149026]deploy application 10MinDemo_Project1_10MinDemo on ADFServer.: .
                [11:53:11 AM] Weblogic Server Exception: weblogic.management.DeploymentException:
                [11:53:11 AM] Caused by: java.lang.ClassNotFoundException: oracle.adf.share.weblogic.listeners.ADFApplicationLifecycleListener
                [11:53:11 AM] See server logs or server console for more details.
                [11:53:11 AM] weblogic.management.DeploymentException:
                [11:53:11 AM] Deployment cancelled.
                [11:53:11 AM] ---- Deployment incomplete ----.
                [11:53:11 AM] Remote deployment failed (oracle.jdevimpl.deploy.common.Jsr88RemoteDeployer)
                • 5. Re: deployment problem on weblogic server 10.3.3.0
                  anjhawar - oracle
                  The later posted error is different.. The failure this time is due to:

                  Caused by: java.lang.ClassNotFoundException: oracle.adf.share.weblogic.listeners.ADFApplicationLifecycleListener

                  I have faced this issue is past (and is a common error reported on forums), and following is what I have tried:

                  Workaround:
                  Remove the entry for the ADFApplicationLifecycleListener from the weblogic-application.xml file and redeploy to the standalone WLS, the application is successfully deployed, and can be run.

                  I guess this was a problem with JDev 11.1.1.1.0.

                  But you need to check how are you are starting the targeted server, are using nodemanager? If yes, check whether "StartScriptEnabled=true" is set. You need to restart the nodemanager and the mapped managed node for the same.

                  HTH,
                  AJ
                  • 6. Re: deployment problem on weblogic server 10.3.3.0
                    Masood
                    After rectifying previous as you advised, I get the another error.
                    Pls have a look.
                    Rdgs,


                    [04:18:30 PM] ---- Deployment started. ----
                    [04:18:30 PM] Target platform is (Weblogic 10.3).
                    [04:18:37 PM] Retrieving existing application information
                    [04:18:37 PM] Running dependency analysis...
                    [04:18:37 PM] Building...
                    [04:18:58 PM] Deploying 2 profiles...
                    [04:19:00 PM] Wrote Web Application Module to C:\JDeveloper\mywork\10MinDemo\ViewController\deploy\10MinDemo_ViewController_webapp.war
                    [04:19:01 PM] Wrote Enterprise Application Module to C:\JDeveloper\mywork\10MinDemo\deploy\10MinDemo_Project1_10MinDemo.ear
                    [04:19:01 PM] Deploying Application...
                    [04:19:03 PM] [Deployer:149191]Operation 'deploy' on application '10MinDemo_Project1_10MinDemo' is initializing on 'ADFServer'
                    [04:19:03 PM] [Deployer:149193]Operation 'deploy' on application '10MinDemo_Project1_10MinDemo' has failed on 'ADFServer'
                    [04:19:03 PM] [Deployer:149034]An exception occurred for task [Deployer:149026]deploy application 10MinDemo_Project1_10MinDemo on ADFServer.: .
                    [04:19:03 PM] Weblogic Server Exception: weblogic.management.DeploymentException:
                    [04:19:03 PM] Caused by: java.lang.ClassNotFoundException: oracle.security.jps.wls.listeners.JpsApplicationLifecycleListene[04:19:03 PM] See server logs or server console for more details.
                    [04:19:03 PM] weblogic.management.DeploymentException:
                    [04:19:03 PM] Deployment cancelled.
                    [04:19:03 PM] ---- Deployment incomplete ----.
                    [04:19:03 PM] Remote deployment failed (oracle.jdevimpl.deploy.common.Jsr88RemoteDeployer)
                    • 7. Re: deployment problem on weblogic server 10.3.3.0
                      anjhawar - oracle
                      Do you have ADF installed on this WLS setup?

                      ClassNotFoundException: oracle.security.jps.wls.listeners.JpsApplicationLif
                      https://kr.forums.oracle.com/forums/thread.jspa?threadID=825393

                      You can check the above threads to find any feasible fix.
                      • 8. Re: deployment problem on weblogic server 10.3.3.0
                        Masood
                        Re: ClassNotFoundException: oracle.security.jps.wls.listeners.JpsApplicatio
                        Posted: Jan 15, 2009 6:10 PM in response to: user9928981 Reply

                        I ever met the similar question, pls. check META-INF/weblogic-application.xml in your ear, and whether there is the following snippet:
                        <listener>
                        <listener-class>oracle.security.jps.wls.listeners.JpsApplicationLifecycleListener</listener-class>
                        </listener>
                        <listener>
                        <listener-class>oracle.security.jps.wls.listeners.JpsAppVersionLifecycleListener</listener-class>
                        </listener>

                        Delete it , will be ok.


                        Above reference I got from the link you gave me.

                        I have the same in my ear file, I click it and try to delete the below lines. It is not deleting. Any other way to delete it from the ear file.
                        Rdgs,

                        <listener>
                        <listener-class>oracle.security.jps.wls.listeners.JpsApplicationLifecycleListener</listener-class>
                        </listener>
                        <listener>
                        <listener-class>oracle.security.jps.wls.listeners.JpsAppVersionLifecycleListener</listener-class>
                        </listener>
                        • 9. Re: deployment problem on weblogic server 10.3.3.0
                          Fabian
                          Hi Masood,

                          Extract the Ear ball
                          Open the weblogic-application.xml in wordpad or notepad,You would be able to delete the lines.
                          Once your done with changes save it back as weblogic-application.xml.
                          Now again create the ear ball with the new weblogic-application.xml
                          jar -cvf ear_file_name.ear folder_name

                          Regards
                          Fabian