5 Replies Latest reply: Dec 28, 2012 12:56 PM by Mriem-Oracle RSS

    JSF 2.1.7 requirements

    641285
      Hi,
      I'd like to know if JSF 2.1.7 requires servlet 3 or 2.5: if I look at pom http://repo1.maven.org/maven2/com/sun/faces/jsf-api/2.1.7/jsf-api-2.1.7.pom there is indicated servlet 3, but it seems referred to JSF 2.2 (see also tag name: "Oracle's implementation of the JSF 2.2 specification API.")

      Then I've seen these links:

      http://stackoverflow.com/questions/9597568/mojarra-java-ee-5-6-compatibility
      http://markmail.org/message/jt4swuhryekin7dg#query:+page:1+mid:jt4swuhryekin7dg+state:results
      Re: Mojarra JSF 2.1.x servlet requirement or dependency

      Can JSF 2.1.7 run on Java EE 5? Is there any sure answer?

      Thanks!
        • 1. Re: JSF 2.1.7 requirements
          gimbal2
          I remember that there were a few versions that required servlet 3.0 because of one dependency which was resolved in later versions (JSF 2.1.14 is the latest). JSF 2.2 is going to be servlet 3.0 though.
          Is there any sure answer?
          Try it? In any case this seems pretty definitive, a simple Google search for "jsf 2.1 servlet" gave it as the first hit:

          http://www.java.net/forum/topic/glassfish/glassfish-webtier/mojarra-jsf-21x-servlet-requirement-or-dependency-0

          Ed Burns is the lead developer of JSF.
          • 2. Re: JSF 2.1.7 requirements
            641285
            Yes, I've seen that link. But I'm still a bit confused: I've already tried it and it seems to work, but I'd want to prevent unwanted behaviors in future.
            Nevertheless if you look at pom of 2.1.14 there is still this dependency:

            <dependency>
            <groupId>javax.servlet</groupId>
            <artifactId>javax.servlet-api</artifactId>
            <version>3.0.1</version>
            <scope>provided</scope>
            </dependency>

            If anyone has more info, please write.
            Thanks.
            • 3. Re: JSF 2.1.7 requirements
              EJP
              JSF 2.1.14 is the latest
              I am using 2.1.15, which is the latest I can find via Maven, but I'm sure I've seen references to 2.1.19.
              • 4. Re: JSF 2.1.7 requirements
                gimbal2
                EJP wrote:
                JSF 2.1.14 is the latest
                I am using 2.1.15, which is the latest I can find via Maven, but I'm sure I've seen references to 2.1.19.
                ??

                checks website

                Darn! The JSF gods play tricks on me.

                http://javaserverfaces.java.net/download.html

                2.1.16 is the latest official release.
                • 5. Re: JSF 2.1.7 requirements
                  Mriem-Oracle
                  The 2.1.x branch requires Servlet 2.5.