3 Replies Latest reply: Dec 21, 2012 11:36 AM by Alejandro Sosa RSS

    Workflow Notification Issue r12

    user457349
      Hi

      I have two issues with Workflow notification in r12.

      1. Users get notification with a file attached called notification.html. This is not required. How can I stop workflow attaching this file when sending emails.
      2. How can I unanimously change notification preferences for all users?

      Thanks,
        • 1. Re: Workflow Notification Issue r12
          SarojaKandepuneni
          what is the notification preference value of the recipient.

          If you don't want the 'notification.html' attachment in email, then set the user notification preference value as 'HTML mail' (MAILHTM2) .

          From UI

          Follow the naviagation

          user login --> Preferences tab--->Email Style -> 'HTML mail'

          In the wf_local_roles it should appear as 'MAILHTM2'.

          2. For FND user you can call the below API

          fnd_preference.put(username,'WF','MAILTYPE','MAILHTML');

          For other users you can directly update wf_local_roles with the required notification preference value
          • 2. Re: Workflow Notification Issue r12
            user457349
            Thanks Saroja,

            We have new user account getting created in Oracle EBS every day. Do we must run these scripts individually for each new user? Is there any global, site level setting that can enforce the "HTML Mail" regardless of new user creation and all new users will have by default this setting applied from global, site level.

            Please advise.

            Darsh
            • 3. Re: Workflow Notification Issue r12
              Alejandro Sosa
              Yes, you can do this by setting the Notification Preference globally. This way any new user will get the preference from this value. To set this global preference do as follows:
              - Connect to apps using the Workflow Administrator Web Applications responsibility
              - Go to Administrator Worfklow -> Administration
              - Scroll down to Global Preference and set Notification Field accordingly.

              Regards,

              Alejandro